Build a PC Computer started smoking, now won`t turn on.

Status
Not open for further replies.

teddymonster

Posts: 9   +0
ok having a problem with my computer..

its only like 3 years old i think

ok so i turned my computer on one morning, and left to eat breakfest, took like 5minutes then i went back to my computer and it was shut off. so i tried turning it back on but it wouldn't turn on. i opened the side, took bit of dust off of fan... not taht it did anything, i hit the power switch, the fans starting spinning, then suddenly STOPPED and this grey box with outlets in them a fan and some other wires started to smoke... and now my comp won't turn on! :( can someone possibly tell me what i have to do??

P.S im not very good with computers or the language / short forms, can you be specific please :)

o and my comp has

pentium / 3.1GHz
1.24GB ram
80GB hard drive
all i know :D
 

foozy

Posts: 139   +1
grey box with outlets in them a fan and some other wires started to smoke...
Sounds like a toasted power supply. Hopefully thats the only thing that fried and it'll be the only thing you have to replace.
 

marcuskarl73

Posts: 12   +0
sounds like your power supply cooked ! I would recomend dusting your machine from time to time ! Dust and electronics aren't the best of friends you know . Buy a new power supply , put it in and hope nothing else got fryed !
 

teddymonster

Posts: 9   +0
  • Thread Starter Thread Starter
  • #4
thanks :D ye i dusted my whole machine 2day b/c a friend said that was the reason it wasn't turning on :p and wow their was A LOT of dust, but i guess that wasn't the reason :S

how much does a power supply usually cost??

and ye i dun wanna start a new topic, but my computer sucks :p nothing but problems... heres a few :( my CD ROM won't read any discs i put in and my computer can't find the drive.. its suppsoed 2 be in 'My Computer' no? its not there, either is my DVD drive, and both are plugged in and such, my computer just won't find them, sorry if its unclear. also sometimes my computer starts up and has no sound... why?? ye i don't know much lol

is a pentium 4 3.1GHz, 80MB hard drive and 1.24GB RAM good?? b/c it takes my computer ATLEAST 10minutes to start up and load everything before i can click on anything, is their anyway i can fix this?? my friends say i have 2 much space taken up or too much icons on my desktop, but i have 5 icons on the desktop and used only 50-60GB...

thanks
 

marcuskarl73

Posts: 12   +0
if you only have 80gig total ,then using 60 gig of that will slow your machine down but 10 min bootup is def. toooo long . have you tried defraging the harddrive ? are you running antivius/antispyware ? A power supply gonna cost you around $40.00 at newegg.com . Fix that first , then defrag your harddrive .try that for starters and then let us know how your machine is doing and we'll take it from there
 

teddymonster

Posts: 9   +0
  • Thread Starter Thread Starter
  • #6
kk thanks, prob gonna get one 2morrow, ill let you know how it runs after i clean it up a bit, thanks again
 

kitty500cat

Posts: 1,391   +6
I'd go with the one dmill89 suggested, just because it's an FSP, but the XClio should work as well.

These are good brands:
davidhammock200 on extremeoverclocking.com said:
Class 1: These are the Best:

PC Power & Cooling (All Turbo Cool & ULTRA-QUIET SILENCER 610W & 750W),
Seasonic (S-12, S-12E+, M-12),
Corsair,
Silverstone (Zeus models ST56ZF, ST75ZF, and ST85ZF),
Etasis &
Zippy.

Class 2:

Antec,
Enermax,
Enhance,
Fortron (FSP),
Hiper (Type-M 670W & 730W & Type-R 730W)
I-Star,
Mushkin,
OCZ Technology,
PC Power & Cooling,
Seasonic,
Silverstone,
Sparkle,
Tagan,
Thermaltake ToughPower (Only the ToughPower Line!),
Vantec &
XCilo.

Class 3:

Hiper (Type-R 580W, 530W & 480W) &
Sunbeam NUUO
 
Status
Not open for further replies.