Computer Won't Shut Down Automatically after change from 98 to XP

By hdmk ยท 19 replies
Oct 15, 2002
  1. I upgraded from Windows 98 to WinXp ages ago, and with it lost the ability to automatically turn the power off after shut down.

    Instead of the power turning off, I get the 'You can turn the power off now' message. Does anyone know how I can remedy this?

    I have a Gigabyte 7IXE Mobo
    and a 'generic' 250 watt psu.
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    You can try changing to an ACPI hardware abstraction layer.

    (Before doing this, ensure that ACPI is enabled in the BIOS)

    Open Computer Management.

    Select Device Manager.

    Expand the computer group.

    You should see a subitem called "Standard PC" or something like this.

    Right click and select update driver.

    Select install from a list or a specific location.

    Select "Don't search I will choose the driver to install."

    Ensure that "Show Compatible Hardware" is ticked and then select "ACPI Uniprocessor PC" from the list.

    Following remaing instructions and reboot.

    WARNING: If your machine is NOT ACPI compliant, then it will NEVER BOOT UP AGAIN UNTIL YOU REINSTALL OR DO A PRETTY GOOD REPAIR JOB. So much sure that it is (motherboard manual will tell you, most modern motherboards from the last several years are....)
  3. hdmk

    hdmk TS Rookie Topic Starter Posts: 104


    Where I right clicking on the 'SCARAB' and the main computer but I don't see what you're talking about?

    BTW - thanks for the constant help
  4. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    you expand the computers bit under that and then right click the item beneath that....
  5. StormBringer

    StormBringer TS Maniac Posts: 2,244

    Before going through all that Go to Control Panel and open System. Select the Hardware tab and then select Device Manager. Under the 'View' menu select Show Hidden Devices. Double click NT/Apm/Legacy Support and then open NT/Apm/Legacy Interface
    Node and enable device(if it isn't already). De-select show hidden devices again and re-boot.

    Sometimes this is is disabled if you upgrade to XP from 9x. I don't know why but I've never found it disabled on a clean install, just on upgrades and quite often.

    If that doesn't fix the problem then you'll need to try Phant's suggestion which has to be done in the BIOS. When you boot the machine, you'll see a message telling you how to get to the BIOS, usually something like press DEL to enter setup. Press whatever key it says, then you can follow his instructions.
  6. hdmk

    hdmk TS Rookie Topic Starter Posts: 104

    I've done what you said, Strombringer, but I can't find the NT section/tab on the list...where should it be?

    Thanks again

    EDIT: and I tried what you said Phantasm, but it says Standard PC - not ACPI Uniprocessor PC - on the upgrade driver page
  7. RustyZip

    RustyZip TechSpot Paladin Posts: 322

    Hasn't this got something to do with APM in the power options, try enabling APM in Power Options in the control panel..

    I may be wrong though, try it...
    Im sure the others will correct me if im wrong...
  8. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    I think its time you posted a screenshot....
  9. StormBringer

    StormBringer TS Maniac Posts: 2,244

    If you look at the device manager, you'll see the view button at the top, click it, then choose "show hidden devices" now you will see the NT/Apm/Legacy Support listed double click it or click the + to expand it then you are where you need to be.

    BTW, I think APM needs to be enabled as well but I'm not sure, that may just be to use Hibernate.
  10. hdmk

    hdmk TS Rookie Topic Starter Posts: 104


    I can't find APM under the power options...

    and here's the screenie of device manager:


    No NT or ACPI to be found - checked under non-plug and play devices as well
  11. RustyZip

    RustyZip TechSpot Paladin Posts: 322

    To get to APM:-

    Open control panel
    click on performance & maintenance
    click on power options
    then click the APM tab

    Voila - All though i still don't know whether that will solve it, its worth a go though.

    Just a thought, if these things aren't definately in your WIN XP, then maybe you've got ACPI disabled in your BIOS...

    Are you sure you got ACPI enabled in your BIOS ??
  12. hdmk

    hdmk TS Rookie Topic Starter Posts: 104

    no APM tab like I said:


    I'll try looking at the BIOS....
  13. hdmk

    hdmk TS Rookie Topic Starter Posts: 104

    checked the BIOS - no mention of ACPI - but APM is enabled under Power Management

  14. RustyZip

    RustyZip TechSpot Paladin Posts: 322

    I've just had a look at my BIOS and i've got ACPI disabled, and mine shuts down automatically...

    Hmmm puzzling..:confused:

    My APM is enabled though.

    Just found this in "help & support centre":-
    The APM tab is unavailable on ACPI-compliant computers. ACPI automatically enables Advanced Power Management, which disables the APM tab.

    Also this:-
    During Windows Setup, ACPI is installed only if all components present during Setup support power management. Some components, especially legacy components, do not support power management and can cause erratic behavior with Advanced Power Management (APM), or may prevent ACPI from being installed. Examples of such components are Industry Standard Architecture (ISA) components and an out-of-date BIOS.

    So judging by that, i'd of thought you do have ACPI installed, because you've no APM tab...

    Put ACPI in the search field in the help & Support Centre; it throws up quite a lot. Have a look there.

    This is getting more confusing...:confused:

    I don't know much really about computers so i'll stop here and let someone else have a go...

  15. StormBringer

    StormBringer TS Maniac Posts: 2,244

    I've also got ACPI disabled.

    In device manager, you have to click View> Show hidden devices, then the APM/NT Legacy Support will be listed, along with some other stuff that stays hidden. After you enable it, APM should show up in Power options.
  16. hdmk

    hdmk TS Rookie Topic Starter Posts: 104

    APM still doesn't turn up in Power options, but then 'show hidden devices' is nt saved when I close device manager.

    I can't find an APM or NT section or part under device manager at all. :(
  17. RustyZip

    RustyZip TechSpot Paladin Posts: 322

    I wonder if re-formatting and doing a clean install would help you solve this???

    Or is that out of the question??
  18. hdmk

    hdmk TS Rookie Topic Starter Posts: 104

    I could do a re-format and a re-install, but I'm due to upgrade at Xmas, so I won't bother - I have to much stuff that I want to keep, yet don't want to burn to cd...I have no other means of storage.
  19. StormBringer

    StormBringer TS Maniac Posts: 2,244

    To get the APM/NT/Legacy Support you have to "View hidden devices" from the Device Manager menu. You can then enable it and APM should show up in Power Options.
  20. hdmk

    hdmk TS Rookie Topic Starter Posts: 104

    StormBringer, I've done that already and it doesn't bring it up.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...