Conflict with CD ROM and CR RW

By rash ยท 6 replies
Jul 25, 2007
  1. I have a windows 2000 pc. I have just recently noticed there is a conflict on both the CD ROM and the CD RW. They are both connected together and are Master/Slave. When i open 'My Computer' there are no cd drives visible, but in device manager there is a conflict. I have tried re installing the drivers but it doenst resolve the problem. I have also tried to disconnect one of the drives and load windows but still no luck, still a conflict. They are both detecting in bios. Can someone please help

  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    I dont know why but Just out of interest why bother having both anyway, the CDRW can just as happily play CD's.

    What does Device manager say the conflict is, is your BIOS set to Plug and Play aware OS, are there any faults with the cables, can you not set one of the devices to be a slave to the master HardDrive.?

    I might not have an idea what the problem is but I always have plenty of questions.

  3. rash

    rash TS Rookie Topic Starter

    i got given the computer with two drives. I assume the previous owner installed the cd rw after. I am not bothered if one of them only works but in BIOS it is set to plug and play. I have tried disconnecteing one but no luck...Thanks
  4. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Have you tried connecting just one (preferably the cd/rw drive) which is set as master (jumpers on the back of the drive between the ribbon cable socket and the audio output)?
    Also try connecting one of them as a slave to the hard drive - not recommended as a permanent solution as it will slow down the hard drive.
    If you do both of these and there is still a reported conflict, there is probably an ATAPI driver fault. Fixing this can be a real pain so you need to be sure first.
    Hope this helps
  5. rash

    rash TS Rookie Topic Starter

    thanks albertlionheart. i am at work at the moment but will try when i get home. thanks
  6. rash

    rash TS Rookie Topic Starter

    this is the error in device manager :

    This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

  7. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Do a search in Kb at Microsoft . I seem to recall a registry hack for your problem. If you have confirmed Cable,CD Romare good, and Master/Slave jumpers are correct.Do not use Cable Select option.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...