Connection Problems

By Izopyn ยท 10 replies
Jun 28, 2005
  1. Hey, everyone, and thanks in advance for any input you may provide; it is greatly appreciated.

    In the last week I've been doing battle with several worms and trojans on my computer, and today all reports show cleanliness. -But-, one problem still remains, and I am out of ideas.

    I can't connect to the internet through Warcraft III, UT2k3 or 2k4, or Final Fantasy XI. I have no problems connecting through Starcraft, Diablo, Neverwinter Nights, or any other connections issues.

    Any ideas or suggestions will be greatly appreciated.
  2. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    May still be a proxy set. But in game! Check each of those games settings for a proxy Internet access setting. Make sure they are using NO proxy.

    Also check that Windows itself doesn't have a proxy set. One easy way to do that is to go through the Internet Connection Wizard. That is, if you're on high-speed. If I remember right you are on DSL.
    Anyway, go to Control Panel to Internet Settings. Also get here from IE by Tools-Internet Options.
    Next go to the Connection tab. The wizard is the top-most button. Within that wizard it will come to the proxy settings page, make sure NOTHING has a check in the box.
    When the wizard is done, try your games again.

    When in the wizard you are basically saying that you want to set up a connection to the Intenet, and create it manually, say you are connection to an "always-on" connection through LAN. With NO proxy, and DON'T set up a mail program. But it's really easy.

    Somehow a proxy still seems like an issue.

    good luck
  3. Izopyn

    Izopyn TS Rookie Topic Starter Posts: 22

    Proxies came to my mind too, but it never occurred to me to set up a new connection. Still no dice on the games though... It's odd how some Blizzard Entertainment games will connect to the servers but others will not, no? It made me think it could be some problem with deep registry.
  4. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    The games may-well have registry settings or even a config file somewhere with settings that are wrong for connection.

    As an experiment I guess you could try uninstalling and reinstalling just one of the games to see if that fixes it. Then you'll know.
  5. Izopyn

    Izopyn TS Rookie Topic Starter Posts: 22

    Oooh I've been down that road... uninstalled/reinstalled WC3 4 times now, repatching and regediting each time. Uninstalled and reinstalled FFXI once, and I didn't bother with UT2k3/4 yet.
  6. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    What about firewall then? Whether hardware or software. Check Windows firewall and/or a software firewall like the one that comes with Nortin Internet Security or whatever you have.
    Try turning them off, or check the "allow" list and make sure your games are set to have access.
  7. Izopyn

    Izopyn TS Rookie Topic Starter Posts: 22

    Both down, and both configured to the games... hmmm... I'm starting to wonder if the worms didn't alter my TCP settings... I don't think the problem is a firewall, or registry, or proxy now... the games all worked fine before the worms.

    It's just that "little" games, requiring less data through the connection like Starcraft, Diablo and Neverwinter Nights have no problems at all connecting... It's the "big" games that can't get through.

    But ya, I'm still thinking that it has to be either something those dastardly worms did, or something that my cleaner programs did to kill the worms. In the interest of following the latter path, here are the programs I used.

    AdAware Personal
    Spybot Search and Destroy
    Registry Fix
    The Cleaner

    Is it possible that one of those programs altered something undetectable?
  8. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    As far as I know, those cleaners wouldn't alter your winsock beyond having to kill LSP software.

    What we have to do is try to find out where it's getting blocked. There has to be a log or a record recorded somewhere. If it was being blocked by a firewall, it would record the activity. So turn all the logs ON and whatch them.

    If it was an error with the game, does it pop up and give you an error or sorts? Check the games directory for any kind of error log.

    Also check Windows own Application and System logs for anything that might relate to the games.

    Are there errors or logs anywhere?
  9. AyatoKamina

    AyatoKamina TS Rookie

    same prob >.>

    Hi ...
    im having the same problem as Izopyn.... the modem is up and running i can browse sites and go on my IM...but when i want to play FFXI i cant login.. it says that "there is a problem in your connection, check ur settings" i did and everything was fine.
    i was reading this posts and some others and they are all talking about a worm and trojans to i used my antivirus program and nothing came up i alos used Hijackthis and adware and spybot.... nothing came up there too...

    whats wrong is it my ISP? or my computer?
    thanks ^^

    im using an ADSL wireless modem running Windows XP
  10. AyatoKamina

    AyatoKamina TS Rookie

    ok the viewer is workin now and it updated its self....but i cant login the game >.> is there a way i can fix this? it started happening a couple of days ago...btw my laptop does the same thing ; ; HELP
  11. BloodRaven

    BloodRaven TS Rookie Posts: 89

    i have an existing computer that already works on the internet that is hooked up to a 5 port hub. my friend did a fresh install of windows xp connected to that same hub. my ip address showed an expected local ip address ( but his ipconfig displayed a unfamiliar ip address. he can see my computer on the network after going on to my workgroup but cant access the internet. his network status activity display's extreme amounts of bytes sent when it has only been running for a few minutes(ex. 180,700 sent and 565,700 recieved -- while mine is at 4,000 sent to 4,000 recieved) does anyone have an idea why the internet browser still doesnt work? becuase obviously i see that it is recieving something.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...