Constantly Losing Internet Connection!!

By Alex.A ยท 13 replies
Jul 6, 2007
  1. Hi. I have a router that shares internet to my computer and to another. I am loosing internet connection pretty often and it never comes back only if I restart the router, restart it's settings to default, disable, enable then repair from my network connection. Without the router, I don't have problems so it must be this
    cursed router. Another strange thing is that it's company gave me a new one, but no result. I don't know what's the problem, maybe you can help me.

    Note: I noticed that sometimes, when I move the ending of the cable a little, the light from the router turns off, so I need to move it again, to keep the light on. The network is always working, but the internet doesn't, so it must be something between the router and the modem.

    Help please!
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    Sounds like a dodgy cable alright, get it replaced and see if it cures it.

    Post back and let us know...

  3. tipstir

    tipstir TS Ambassador Posts: 2,477   +126

    Try different patch cables see if that helps? Could be a bad port in the router? Try the cable idea and see if that helps...
  4. Alex.A

    Alex.A TS Rookie Topic Starter Posts: 73

    I already replaced the cable but no result. Also changing the patches is not a good solution. I don't know whats happening. Everything is checked and seems to be ok but I can't find whats the problem. Maybe its a curse or something.:confused:
  5. tipstir

    tipstir TS Ambassador Posts: 2,477   +126

    Yes changing the patch is a good solution which you told us you have to fiddle with the ends.. Do a direct connect from the modem to the PC and see if that works. Then you know it's the Router gone DOA..
  6. almcneil

    almcneil TS Guru Posts: 1,277

    Check your router settings and make sure you're using the latest firmware release for it.
  7. Alex.A

    Alex.A TS Rookie Topic Starter Posts: 73

    tipstir, you understood me in the wrong way. I did not meant to say that your advice is not a good one, but I tried it and it changed nothing so its not good for my
    case. I did a direct connect, still no result. About finding if i'm using the latest firmware release, how can i know that?

    Thanks for trying to help. :)
  8. almcneil

    almcneil TS Guru Posts: 1,277

    There's a special IP address you enter that puts your router into diagnostic mode, either or From there you find the firmware version. Then go to the web site for the manufacturer and see what the latest firmware version they have for download. Usually they have something more recent. So download and install it.
  9. CCT

    CCT TS Evangelist Posts: 2,653   +6

    The question might well be, 'What about the other computers' connection?'

    Is it also intermittent? Any problems at all?

    If not, and you have switched cable ports on the router to your comp and changed cables from the router to your comp and not fixed the problem, then the problem may be your ethernet in your computer.

    Download the latest drivers for your adapter and put them in a file you can find.

    Then Remove the ethernet driver from add/remove programs.

    Then go to Device Manager and right click on the adapter and click uninstall.

  10. tipstir

    tipstir TS Ambassador Posts: 2,477   +126

    Yes this can happen,... Go to your router manufacture web site and see if they released a firmware update and while you're there grab the manual for the router so it can tell you how to update the firmware for it?
  11. Alex.A

    Alex.A TS Rookie Topic Starter Posts: 73

    My router's name is RPC IP 2105 but I didn't find any site from where I can download firmware or drivers. It's weird, doesn't have this company an official site?
    When the internet is loosing, is loosing for all the computers but the network is still working. So it isn't the cable from the router to my comp.
  12. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Google for RPC IP 2105 - looks like a port, not a router.

    Enter in the Google address bar then click 'Go' - that should get you to your router.
  13. Alex.A

    Alex.A TS Rookie Topic Starter Posts: 73

    I googled for RPC IP 2105 but I didn't found my router, but I went to, I entered in my router's settings and i found out that my firmware version is: IGD Software, V0.78B1 English version , 2004.12.15.

    I have no idea what that means but first i need to find the right site for my router.
  14. CCT

    CCT TS Evangelist Posts: 2,653   +6

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...