Corrupt Files

By Kralnor ยท 8 replies
Oct 20, 2007
  1. I can't for the life of me figure out why certain games either won't install, update or run properly because of corrupted files.

    Just today I downloaded the Hellgate: London Beta and it kept saying various cab files were corrupt. I tried downloading the installation files on another PC running Ubuntu and it installed fine there. I was able to copy over the installation and the game runs well on this PC but for some reason it cannot install the game.

    I also get the odd crash or two once in a while in WoW, usually once or twice per day, resulting in Error 132. I have tried with several fresh installs and have also run the repair tool which seems to suggest that the installation is corrupt but after a fresh installation I run it once more, it is able to verify the installation yet later the same day, WoW crashes giving Error 132.

    Any ideas? I'm fairly sure I have the latest drivers for every piece of hardware I'm running. The chipset drivers I am not completely certain of, but I think they are the most recent ones. How can I verify them?

    Note: I have only had issues with these two games. Other games such as Doom3, HL2 etc. have run flawlessly.

    If you need any specific system information I will do my best to provide it.

    Cheers in advance for any help!
  2. Jeev

    Jeev TS Rookie

    Trying running the chkdsk utility. Go to Start, Run, and type "cmd".

    In this window type the following:

    chkdsk /f /r

    It will ask you if you would like Windows to check the disk on the next reboot. Simply type Y and press enter, and reboot.

    This will check your hard drive for bad sectors and repair where nexessary. If it finds bad sectors, this could indicate that your hard drive is on its last legs and will need replacing. You will know 100% if it indeed finds errors on more than one occassion on the same drive.

    I would assume that your other games run fine due to them already being installed, and on undamaged sectors of the hard drive. Windows merely needs to read from your game directories and store information on the RAM. However, you are encountering these problems when trying to store new data to the disk, so I would first check the health of the hard drive.

    If all other games run fine and Windows runs stable I see no reason to immediately consider the memories or CPU to be at fault.

    Hope this helps.
  3. Kralnor

    Kralnor TS Enthusiast Topic Starter Posts: 37

    I have already run chkdsk numerous times although only with the /f switch. However, no bad sectors were found at any times. It did return a few corrupted files during one scan out of many but those were all WoW related and quickly fixed.

    Windows is generally very stable except a few times where the CPU has been overheating which happened because of improper throttling. I have since run the fan at 100% at all times and have had no issues with overheating since then.

    Prime95 can run for hours without producing any errors.

    I'll try chkdsk with both the /f and the /r switch and report any findings back.
  4. Kralnor

    Kralnor TS Enthusiast Topic Starter Posts: 37

    Finished running chkdsk with both switches and all drives came out clean.
  5. Kralnor

    Kralnor TS Enthusiast Topic Starter Posts: 37

    Today I was able to install WoW successfully for the first time on this PC. So far, so good. Now I hope it won't crash like the other installations I have had.

    I downloaded the entire client through torrents. This time around I used uTorrent just to eliminate the possibility of my PC not liking the Blizzard Downloader.

    Now I'm going to download patches through uTorrent as well and see how that goes ;)

    EDIT: Seems like I got too optimistic. The patcher was unable to read expansion.MPQ and thus could not patch.
  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Go over all your hard drive cables and make sure they are fimly seated.

    Test the hard drive with the proper diagnostic utility from the HDD maker.
    Test your system RAM with memtest86(+)

    There is also a small possibility of some security software interfering with the downloads or open files. Maybe disable your software firewall (enable the windows builtin one!) and antivirus?
  7. Kralnor

    Kralnor TS Enthusiast Topic Starter Posts: 37

    I'll try running HDD tests and memtest86 overnight and reseat the hard drive cables.

    I have tried applying the WoW patch in safe mode but that did not work either - it still came back as being corrupted. The patch has been downloaded both with and without AV running in the background. It has also been downloaded on a different machine yet it could still not be applied on this one after being transferred over network. However, the game was successfully patched on the other machine, using the very same patch file.
    I think I can rule out AV being the problem.

    My gut feeling says there is some Windows/BIOS setting or driver that isn't properly setup, but it's just that - merely a feeling.
  8. Kralnor

    Kralnor TS Enthusiast Topic Starter Posts: 37

    Bingo! The RAM is giving me trouble. Memtest didn't even run for a minute before it started producing errors.

    Boy am I happy to have found the source of the problem, it's been nagging me for over a month.

    I'm running four sticks of 1GB each. I'll test them in various configurations to find out whether it's simply because of running them all at once it doesn't work, whether they are compatible with my motherboard or if they are simply faulty.

    There is of course also the possibility that the memory timings are too aggressive.

    Update: Still too soon to conclude anything but I am fairly certain one of the RAM sticks is bad. I tested them one at a time and none of them gave any errors after running memtest86 for a few minutes (not very long, I know, but originally I got loads of errors in 30 seconds!). However, the last stick I tested did produce errors in less than a minute.

    I am now testing the three good sticks and they have run for just shy of 15 mins without errors. So far, so good. If memtest86 runs successfully overnight with the three sticks I am using now, I am going to RMA the bad one.

    WoW has been successfully installed and patched as well :)
  9. Kralnor

    Kralnor TS Enthusiast Topic Starter Posts: 37

    I decided to RMA the RAM and was easily able to get it replaced. Have run memtest86 for an hour without any errors. So far, so good.

    However, WoW still crashes, although now it doesn't show an error message, it simply quits to the desktop. Usually right before it crashes, lots of artifacts are shown on the screen. I know my card isn't overheating because while playing WoW it peaks out at 73 C.

    I have spoken to other people who have the same problem and they suspect it might be a problem with memory on the card being full. One person was able to clear the artifacts by changing the video settings for multisampling, thus forcing the video card to redraw the screen.

    I have seen no such behavior in other games than WoW.

    It should be noted that my video card is a 320MB 8800GTS.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...