1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Corrupted JPGs - No preview available

By kritonas · 43 replies
Sep 11, 2005
  1. I recently backed up some photos from my laptop to my desktop and formatted the laptop. Then i found out that 80% of the pictures are corrupted in some way. This is what i know by now:

    - The photos are there, all have .jpeg extension, and are the size they used to be. I can also copy, delete, rename them and change their attributes etc.

    - Explorer shows no preview in preview mode, i get "No preview available"

    - Windows picture and fax viewer - the same "No preview available"

    - Other programs say something along the lines of "Cannot read from file" or "File contains errors"

    - My hard disk is checked and fine and doesnt contain any bad sectors.

    If i didnt have any previous experience with this matter, i'd think that they just got corrupted during transfer. I remember a friend of mine having the same problem though, without moving the pictures. One day, they just behaved like that.
    Also, i found many other ppl posting requests like this in forums, that have exactly the same problem - none of them seems to have found a solution.

    Well, this is the experts forum, i hope somebody knows the answer!

    Other ppl with similar problems:
    https://www.techspot.com/vb/topic21717.html [my disk didnt crash tho]
    http://www.planetpdf.com/forumarchive/119118.asp [i can delete/copy etc...]

    Thanks for your time!
  2. IronDuke

    IronDuke TS Rookie Posts: 801


    Try Irfanview and see if that has any more success.
  3. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    As i guessed - nothing.. I get "No preview possible" at the preview window, and when i try to open a file i get : "Can't read file header ! Unknown file format !"

    The problem lies in the file structure/windows...

    What pisses me off is that the photos are there, i just cant see them.

    Any more ideas?
  4. greenflash

    greenflash TS Rookie Posts: 99

  5. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    Thanks, but i don't think its the associations, since i tried opening the jpgs with other programs too...

    I tried copying the jpgs to another pc as well, and i get the same problem.
  6. Nodsu

    Nodsu TS Rookie Posts: 5,452   +7

    How exactly did you perform the backup? Could it be you compressed/encrypted the files somehow?

    Are you sure the pictures are JPG and not some other format?
  7. greenflash

    greenflash TS Rookie Posts: 99

    if preview fails on other computers too files r corrupted or something else
  8. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    I just copied/pasted from networked pcs. The files are not compressed, and not encrypted (a small number of the photos still works)

    that;s what i guessed, my problem is: how did the jpgs get corrupted, how can i fix them, and most important, why do some random ones still work??
  9. greenflash

    greenflash TS Rookie Posts: 99

    I had similar problem ages before...I had downloaded many pics in jpg format then located them in explorer and most of them corrupted due to some crap...i havent find a solution for that yet...

    Im not sure but Data recovery software wont be your medicine too..

    Maybe the loss of data became in Network Transfer Session..

    If u have a possibility try to Copy/Paste files again
  10. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    Yeah, i think that too because data recovery software look for bad sectors and stuff..

    Maybe, but i think not, because a friend of mine had exactly the same problem, but she never moved her files. And if you look online, many ppl have the same prob, without moving their files.[/QUOTE]

    Unfortunately, i don't have the originals.... :(
  11. danield

    danield TS Rookie

    No preview available in windows explorer

    If you recently updated your OS with the latest updates, windows explorer doesn't show your jpg's and doesn't play any media when you klik on the play button.
    I solved this problem by removing update KB900725 :)
  12. sky_sparkle

    sky_sparkle TS Rookie

    Corrupted Jpgs


    I've recently had the same problem

    I was transferring about 250photos from my memory card to a usb pen via a laptop and only 100 photos can now be viewed in every viewer I've tried. This includes video footage, though I can still get audio on them.

    It happened on another occasion with different photos, but I only copied the photos over and discovered it was the laptop that was causing the problems and it worked fine when I tried a different machine.

    However the 1st lot of photos I transferred are still affected.

    I have tried all the above suggestions and have not managed to fix it.

    Can anyone suggest anything further?

    Thank you
  13. alfath80

    alfath80 TS Rookie

    EXACTLY had the same problem! If only someone could tell me how to recover these file... I do believe the files are there but maybe the MFT is corrupted...
  14. fspiegel

    fspiegel TS Rookie

    Same Problem Please Help!!!!

    I have exactly the same problem. I tried to save the pictures on a DVD and view it on another PC. Backup works but same error message on different system. I think it has something to do with the compression. I think when I did a clean up disk and compressed old files the jpegs became unreadable.

    CAN ANYONE HELP? I lost most pictures of my wedding and my wife is getting really sad...

  15. 18sx

    18sx TS Rookie Posts: 37

    install adobe photoshop....
  16. fspiegel

    fspiegel TS Rookie


    man that comment was useless!

    for all others: it does not depend on the application with which you open the file. there's something wrong with the file itself - might also be due to some virus... does anyone know if in that case the file can be restored?
  17. Tedster

    Tedster Techspot old timer..... Posts: 5,746   +14

    when backing up important stuff like that, ensure the back ups work.
    sorry to hear about your photos.
  18. hvelliott

    hvelliott TS Rookie

    Removing KB900725 no help

    I removed KB900725 and it was no help.

    BTW, the threads here are kind of old. Does no one have this problem anymore, or is it just me?

    If important and precious photos are simply going to go away then I need to revert back to regular film photography, and forget digital!

  19. MyQ83

    MyQ83 TS Rookie


    I have the solution for you
    i have the same problem and i started to search on the internet
    for th solution and i didnt find any,
    so i tried to open the photo with the "Paint" Program
    it gives me an access denied msg, so its a security reason
    but u can rename, delete, the photos so u have permission to access them
    but the problem were in the Ownership.

    so go to the folder which contains pics and follow these steps :
    1- right click >> Properties
    2- go to Security tab
    3- Click on Advanced
    4- go to Owner tab
    5- Click on ur username then select the " Replace owner on ...." check box
    6- click ok
    7- right click >> refresh

    then u'll be accessing ur photos again

    try it and tell me
  20. ricochet1969

    ricochet1969 TS Rookie

    Seems I have the same problem

    Hi Everyone,

    I'm new here, but it looks like you guys will be able to help me.
    I have this same problem, and this reply seems to make sense - I copied JPEg photos onto my work Laptop while I reformatted my home harddrive. On transferrring back, many of my JPEGs are giving "No Preview Available". My work laptop has all sorts of "locks" in place to stop us messing with them, so the permissions stuff seems likely.
    My problem, however, is that I don't have the "Security" tab in properties. It's on my work laptop, but not my home pc.
    Any ideas?

  21. jodyh54

    jodyh54 TS Rookie

    I hope that you still have your photos because I know how to fix them. The same exact thing happen to me when my wife was sorting our vacation photos. It seems that the attributes got hosed up. Anyway here is how I fixed mine.
    1. Download program “ERD Commander 2005” You will have to make an ISO image and boot to it.

    2. When you are booting to ERD Commander 2005 and it comes to the “Network Configuration” prompt, just click skip.

    3. When you get to the screen where it says c:\windows just click OK

    4. When it finishes loading, you will see a desktop with icons. Click Start – System Tools- Disk Commander.

    5. Use the wizard and choose the default buttons.

    6. After it searches for “regular and damaged files” Browse to wedding photos folder… select it and move it to a new location. Get done and reboot. (Pop the disk out)

    WHA LA…TA DAH… BAH DA BOOM, BAH DA BING!!! Who’s the man??? Let me know what happen.
  22. rossxxxx

    rossxxxx TS Rookie

    corrupted JPEGs

    This is a common problem and has no easy fix, that I've found. Somehow the offsets get corrupted and you get the back half of a previous file in the front half of the current file...a bit of empty space and then the front half of the current file. No viewer will touch it 'coz they can't see a valid jpeg header at the start. A hex editor like WinHex will show this and will recover the part of the jpeg AFTER the header; sometimes it's most of the jpeg, sometimes only a part. JPEG Recovery does the same job. Reassembling the files into the correct order doesn't seem to work, but I'm still investigating. I think it's a problem in the MBR allocating offsets for files. Google signature based recovery to see more. PS jpeg headers are usually hex FF D8 FF E1 or FF D8 FF DB, jpeg end markers are hex FF D9. Good luck.
  23. Peppa

    Peppa TS Rookie


    I dont know how long ago it was post (forgot to look) but I tried this ... well attepmted to but I got as far as Properties lol. I dont have a Security tab... It has "Gernal" "Sharing" and "Customise"
    I kept looking but couldnt find it anywhere...Are you still helping??
  24. luvhuffer

    luvhuffer TechSpot Paladin Posts: 433

    If you have XP Pro you need to disable simple file sharing in folder options to see the security tab. If you are using XP Home, then you need to boot into safe mode to access the security tab. That's how to get there. Whether the permissions thing actually works for this issue I can't say. Good luck.
  25. wildman6801

    wildman6801 TS Rookie Posts: 62

    Best advice is when backing up files or copying over files from one location to another check the file out afterward to see if everything transferred over. You should have done this! I don't know how to fix your problem but you may have learned a lesson to always check the files that you copied over before deleting the original.
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...