Crashing or BSODing randomly when playing games

By CatastrophE
Dec 29, 2005
  1. Ok everyone, I have a nasty problem, after recently changing my Mobo and Processor I did a repair of windows XP and had pretty poor performance and slow running speeds, I installed drivers and such which appeared to fix my problems however when running games I would find (specifically with HL2 and Vampire The Masquerade Bloodlines) they would randomly crash to desktop at any given time, sometimes with BSOD or Restart of PC or sometimes with an Error Log explaining what went wrong (albeit not very specifically) to counter this I put it down to my lack of a clean install of XP, so I bought a new HD and did a fresh XP install and kept my files on my old HD to avoid problems, All drivers appear to be latest, and the slowness seem's to have gone, all problems are fixed...except my games still crash to desktop with the same Minidumps and BSOD's and all that crap, ive tried basically everything to no avail (chkdsk, reinstalling drivers, looking for conflicts etc etc) I decided to check over my Error logs and Minidumps, it appears that as i've gone along the line installing new drivers and such, i've been getting less error's until only one remains, a DRIVER_CONFLICT with atikvmag.dll...
    now I have no idea what to do since i'm at a total loss as to what's causing all this crap, and have been trying for a whole week to fix it to no avail, ive got a feeling it's something obscure rather than serious, so i'm hoping that by giving you some Error logs and Minidumps to look at you guys can help me out, this is driving me mad and I just dont feel like my PC can be used for leisure anymore as long as this carries on :(


    AMD Athlon 64 3700+
    1 gig matched Duel Channel DDR400 Ram
    Asrock duel SATA 939 mobo
    Samsung 200GB 8MB cache HD

    any more info needed, just ask :)

    MiniDump 1

    This is a very common bugcheck. Usually the exception address pinpoints
    the driver/function that caused the problem. Always note this address
    as well as the link date of the driver/image that contains this address.
    Some common problems are exception code 0x80000003. This means a hard
    coded breakpoint or assertion was hit, but this system was booted
    /NODEBUG. This is not supposed to happen as developers should never have
    hardcoded breakpoints in retail code, but ...
    If this happens, make sure a debugger gets connected, and the
    system is booted /DEBUG. This will let us see why this breakpoint is
    Arg1: c0000005, The exception code that was not handled
    Arg2: bfa620ea, The address that the exception occurred at
    Arg3: b81789b8, Trap Frame
    Arg4: 00000000

    Debugging Details:

    ***** Kernel symbols are WRONG. Please fix symbols to do analysis.

    FAULTING_MODULE: 804d7000 nt


    EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx" referenced memory at "0x%08lx". The memory could not be "%s".

    bfa620ea 8b5224 mov edx,[edx+0x24]

    TRAP_FRAME: b81789b8 -- (.trap ffffffffb81789b8)
    ErrCode = 00000000
    eax=e165c010 ebx=01000002 ecx=00000000 edx=0000108d esi=e1f86211 edi=e1f86210
    eip=bfa620ea esp=b8178a2c ebp=b175f0c0 iopl=0 nv up ei ng nz ac po cy
    cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010297
    bfa620ea 8b5224 mov edx,[edx+0x24] ds:0023:000010b1=????????
    Resetting default scope




    LAST_CONTROL_TRANSFER: from c3f55d8b to bfa620ea

    WARNING: Stack unwind information not available. Following frames may be wrong.
    b175f0c0 c3f55d8b 43cf1743 ff000000 3e600000 atikvmag+0x120ea
    b175f0c4 43cf1743 ff000000 3e600000 3e000000 0xc3f55d8b
    b175f0c8 ff000000 3e600000 3e000000 3f7c0000 0x43cf1743
    b175f0cc 3e600000 3e000000 3f7c0000 3f7c0000 0xff000000
    b175f0d0 3e000000 3f7c0000 3f7c0000 43803614 0x3e600000
    b175f0d4 3f7c0000 3f7c0000 43803614 c3f572cb 0x3e000000
    b175f0d8 3f7c0000 43803614 c3f572cb 43cf4867 0x3f7c0000
    b175f0dc 43803614 c3f572cb 43cf4867 ff000000 0x3f7c0000
    b175f0e0 c3f572cb 43cf4867 ff000000 3dc00000 0x43803614
    b175f0e4 43cf4867 ff000000 3dc00000 3e000000 0xc3f572cb
    b175f0e8 ff000000 3dc00000 3e000000 3f7c0000 0x43cf4867
    b175f0ec 3dc00000 3e000000 3f7c0000 3f7c0000 0xff000000
    b175f0f0 3e000000 3f7c0000 3f7c0000 4294f079 0x3dc00000
    b175f0f4 3f7c0000 3f7c0000 4294f079 c3f09d6c 0x3e000000
    b175f0f8 3f7c0000 4294f079 c3f09d6c 43c712de 0x3f7c0000
    b175f0fc 4294f079 c3f09d6c 43c712de ff000000 0x3f7c0000
    b175f100 c3f09d6c 43c712de ff000000 3dc00000 0x4294f079
    b175f104 43c712de ff000000 3dc00000 00000000 0xc3f09d6c
    b175f108 ff000000 3dc00000 00000000 3f7c0000 0x43c712de
    b175f10c 3dc00000 00000000 3f7c0000 3f7c0000 0xff000000
    b175f110 00000000 3f7c0000 3f7c0000 429566c9 0x3dc00000

    bfa620ea 8b5224 mov edx,[edx+0x24]


    FOLLOWUP_NAME: MachineOwner

    SYMBOL_NAME: atikvmag+120ea

    MODULE_NAME: atikvmag

    IMAGE_NAME: atikvmag.dll

    STACK_COMMAND: .trap ffffffffb81789b8 ; kb


    Followup: MachineOwner

    and here's the latest Error Log from Vampire

    * * * Vampire Crash Data Log, Generated From Exe Built On: Oct 6 2004 * * *

    vampire caused an Access Violation (0xc0000005)
    in module client.dll at 001b:1d286830.

    Read from location 5508245c caused an access violation.

    EDI: 0x1de43f38 ESI: 0x00000001 EAX: 0x00000000
    EBX: 0x00000000 ECX: 0x1de43f38 EDX: 0x20174c54
    EIP: 0x1d286830 EBP: 0x1de43f3c SegCs: 0x0000001b
    EFlags: 0x00210293 ESP: 0x00097818 SegSs: 0x00000023

    Bytes at CS:EIP:
    53 8b 5c 24 08 55 56 57 8b e9 83 cf ff 57 8b cd

    -----[ SysInfo ]-----
    Error occurred at 12/28/2005 16:49:14.
    1 processor(s), type 586.
    94% memory in use.
    1024 MBytes physical memory.
    52 MBytes physical memory free.
    2461 MBytes paging file.
    1242 MBytes paging file free.
    2048 MBytes user address space.
    904 MBytes user address space free.

    -----[ StackTrace ]-----
    0x1D41CFD4 : CreateInterface in f:\program files\activision\vampire - bloodlines\vampire\cl_dlls\client.dll
    0x1D284040 : <unknown symbol> in f:\program files\activision\vampire - bloodlines\vampire\cl_dlls\client.dll
    0x1D284040 : <unknown symbol> in f:\program files\activision\vampire - bloodlines\vampire\cl_dlls\client.dll
    0x90909090 : <unknown symbol> in <unknown module>

    -----[ ScopeTrace ]-----
    SCOPE_TRACE data, stack depth = 9
    08. CViewRender::DrawTranslucentRenderables ()
    07. CViewRender::DrawHelper ()
    06. CViewRender::ViewDrawScene_NoWater ()
    05. CViewRender::ViewDrawScene ()
    04. CViewRender::RenderView ()
    03. CViewRender::Render ()
    02. RunListenServer ()
    01. CEngineAPI::Run ()
    00. LauncherMain ()
  2. CatastrophE

    CatastrophE TS Rookie Topic Starter Posts: 19

    Strange, ive fixed it.
    It seem's a week of crap finally paid off.
    I (pointlessly now that this breakthrough occured) uninstalled, clean sweeped in safe mode, and re installed from Omega to latest Catalyst (this didnt fix the problem sadly) then I went into Bios and noticed my memory was forced to DDR400, which is fine...or so I thought, I decided to set it to Auto and set AC97 to FORCE audio for me, i'm not sure which one fixed the problem, but I did notice it scaled my memory down to DDR333, although I must confess I dont notice any difference in loading or anything, in fact everything seem's perfect, only without crashes to ruin my fun :)
    Re did my 3D mark 2003 and got more Marks than I did originally with my Omega Drivers, so i'll just stop messing about incase it all goes wrong again lol, was tempted to re install Omega's but nah, i'll just forget that one, yeah.

    3D Mark 2003 = 11805 Marks or something to that degree :p

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...