D-Link Wireless Adapter no longer turning on

By miamai
Jun 11, 2007
  1. Hi, umm, I had a D-Link WUA-1340 Wireless G USB Adapter before, and it worked fine up until recently, but then my computer suddenly didnt recognise it. After pulling it out alot, and putting it back in it would suddenly work and be back to normal. After about a week it completely died though, and we replaced it with a new one of the SAME MODEL. We plugged it in and it worked fine, but just today I expeirienced the same problem! The light doesnt go on anymore and it doesnt work in any of my USB's but my webcam and other things do.

    My computer has "safely remove hardware" up, but it doesnt work when I tryand remove the D-link. It waits for forever and never tells me I can remove it, as it stays in the same process for hours and hours. Re-instaling the program that goes with it doesnt do anything to help, I've tried

    how can I fix this?
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    Is the PSU powerful enough for all your components?
    Have you checked the PSU with a multimeter?
    Have you tested your usb port also with a meter?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...