D3D initialization failed DUNGEON SIEGE 2

By Robzilla
Aug 28, 2005
  1. Hello,
    Either the demo or full game I get this error. I've tried the latest drivers, from Cat, to Omega, to older ones and nothing. Have tried the usual: clean install, no overclocked settings, and other boards. My direct X is the 9.0c also. Nothing! I do notice that the ds2videoconfig.exe doesn't seem to work. I've a Radeon 9600se which is supposed to be supported. Even tried running with different levels of hardware acceleration and still nothing. I think this is a driver issue. Help!

    AMD 64 2800+ 512 mb RAM
    WinXP w/ sp2
    DFI LanParty MB with latest BIOS
    I don't use onboard graphics/sound

    Feedback appreciated!
  2. Rik

    Rik Banned Posts: 3,814

    It could be a compatability issue with 64bit, visit the game manufacturers site to see if they have a patch.
  3. cmr611

    cmr611 TS Rookie

    Got it!

    Tried everything, even microsoft tech said I needed to upgrade my video card, lol! What finally worked was renaming all old directX .dll to .old from inside the dxdiag! Had to search for them and was time consuming, but well wirth the wait!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...