Data error cyclic redundancy check ssd


Posts: 328   +24
Hello all,
Windows 7 doesn't recognize my SSD drive. When I go to disk management, it shows a message to initialize it (image no.1) but when I press OK to do that, one another message appears and says: Data error cyclic redundancy check (image no.2). My computer windows doesn't show that drive and also when I went to cmd->diskpart, again it didn't show that disk to use of chkdsk /f command. How to solve the problem please?


  • 1.PNG
    67.9 KB · Views: 3
  • 2.PNG
    33.2 KB · Views: 3


Posts: 328   +24
I could to revive that disk in diskpart using PartedMagic in boot. I've uploaded a new image from that. The remained problem here is that I can't delete it there.


  • 3.PNG
    23.2 KB · Views: 5


"NORMALLY" we don't run these tools on SSD devices, as it reduces the life of the media.

It would appear that you need to create the partition and Quick Format it.

chkdisk x: /F /R will read (repair) every sector which should be kept to an absolute minimum.


Posts: 328   +24
I downloaded a new version of Parted.Magic and I was going to use of it to create table on and format/delete that SSD when I booted the PC on it. Do you say that I don't do that?
As well as, I used the chkdsk G: /f /r (I thought the letter of that drive should be G:\) but got the "Can not open volume for direct access." :confused:


Posts: 328   +24
Hey guys,
Fortunately I could to revive it completely!!!!
I've also uploaded a new snapshot of disk management. Now there is only one problem. Its format is in NTFS, I need to someway convert/reformat it to exFAT to be usable on its device. But there isn't such a way to format it in that file system in disk management or by right-clicking on it in My computer window! Do you have any idea?


  • 4.PNG
    37.5 KB · Views: 6


Posts: 328   +24
After checking the disk using chkdsk /f /r command every thing became okay, that is, that command said there isn't any error with this drive.

Then I was alone with it. The reason that the Windows wouldn't format it in exFat was that the OS would consider the drive as a Local Drive not as a removable device. If I could change that consideration some way from the Windows' mind, I could easily format it as exfat by normal method of Windows. I tried other OSes (I have some as virtual machines). I used Windows 8.1 for formatting that SSD. I put it into USB port of PC running win 8.1. It showed a messae in bottom right corner that would say it couldn't recognize the SSD. I tried other USB ports but same result!

I returned to win 7 and was thinking to find other ways, but this time win 7 said this ssd should be formatted! I formetted it again but win said "unable to format the drive"!!! It was like a disaster.

I imediately went to Disk Management. The only work I can do there is just deleting the volume but can't format it :(:(:(

Now again I should search for solutions.
I'm going to once again use of Parted Magic tool. But this time its new version. Use it to both format it and in exfat too.

Is there anybody to say me does he agree with this or not!?

I thank any idea for solving the problem.

thank again.

  • Reply
  • Reply with quote
  • Edit
  • Report abuse
Last edited: