deleted partition now invalid boot.ini

By steeve ยท 7 replies
Oct 10, 2007
  1. I have seen some similar posts to this but not exactly the same.

    A while ago my mobo died and after replacing it, I had to reinstall windows (XP SP2).
    So I installed it in a new partition so that I could transfer settings, data, etc from my old installation.

    All good until yesterday when I decided the day had come to use the old windows partition for other things.

    Of course it couldnt be done from inside windows, so I used Cute Partition Manager.
    CPM doesnt have a format function so I just deleted the partition containing the old xp instal.

    Mistake. On reboot, I was told no NTLDR and No problem, I copied those over OK form the xp cd.
    But then, "invalid boot.ini" and "missing or corrupt hal.dll". So I expanded hal.dll over from the cd.

    Since then, in spite of trying everything I could find to try, those same errors continue to come up, ie "invalid boot.ini" and "missing or corrupt hal.dll".

    Basically, bootcfg fails every time, chkdsk /p and /r work fine with no errors. Fixboot appears to create a new bootsector on C: . Attrib -h-r-s on boot.ini fails to find appears not to exist on C: or to be creatable! Fixmbr runs ok but to no avail. The XP set up facility has no repair option...

    Any ideas, I've run out.

    Sempron 3000 processor
    new Asus motherboard
    Two 80gig hdd
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Can you move the second partition to the beginning of the disk?

    If not, what about creating a new partition where you deleted the old one, or undeleting the old one?

    Did you mark the second partition as active after deleting the first one?
  3. steeve

    steeve TS Enthusiast Topic Starter Posts: 146

    Yes, an inspired idea!

    I moved the second partition to the beginning of the disk and rebooted. Black screen only....on second reboot windows started.

    strangely, it behaved like a new installation and "found" all my hardware as if it was new. For some reason it can't see my drivers. Any ideas?

    It will be a small price to pay if I have to reinstall drivers!

    Thank you Mictlantecuhtli
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Hrm.. maybe because there are some registry keys left where the installation partition is the second one?
  5. steeve

    steeve TS Enthusiast Topic Starter Posts: 146

    Not sure what to do about registry issues except scan and clean.

    It is possible that windows has all along been booting from the old windows partition (C:) because now the current windows partition (F:) does not appear to have a boot.ini file.

    I think this because, when I uncheck "hide protected files" and look in F:, no boot.ini. Also from the dos prompt, attrib -r-a-s-h boot.ini
    fails to find boot.ini in windows root (F:).

    Also, when I boot up, just before windows starts, the message flashes: "invalid boot.ini" and then it starts anyway. I did use Bootit NG to move the partition and fix the MBR.

    Also, when I go to system properties\advanced\settings I am told "C:\boot.ini cannot be opened". Then when I hit OK and edit, "the system cannot find the path specified" which must be true since C: does not exist.

    So something is pointing to C:\boot.ini as the boot file. It doesn't exist and yet the system boots perfectly!
  6. steeve

    steeve TS Enthusiast Topic Starter Posts: 146

    By the way those smiley faces are meant to be colons!
  7. steeve

    steeve TS Enthusiast Topic Starter Posts: 146

    Does anyone have any ideas where my boot.ini may be?

    I have been through a lot of "missing boot.ini" discussions which all eventually end in boot.ini being found. Mine still cannot be found.

    After unchecking all hide system, hidden and protected files boxes I run msconfig and there is no boot.ini tab.

    System properties dialog does not find it.

    Is it possible that it resides on Bootit EMBR partition?

    If so how do I access that? It doesn't show up in explorer.
  8. steeve

    steeve TS Enthusiast Topic Starter Posts: 146

    In case anyone is interested, problem is now solved.

    I copied an old boot.ini.backup from windows\pss to <root>\boot.ini removed the line refering to the old version of XP.

    I booted into Bootit enviroment again and made sure the XP partition was still at the top of the MBR. Still within Bootit, edited the new boot.ini to read ....partition(1)...reboot and away we go.

    It sounds easy, but it took a lot of @#*%ing around mostly in the dark.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...