Dell Inspiron 3668 Strange Power Problem After Adding WIFI Card

I just added a WIFI card to my Dell 3668 today, adding it to a PCI/E slot. The PC had been running fine but when I tried to power it up after adding the card, the unit wouldn't power up. I got no light at all, either amber or white in the power on button but I did get a strong, steady green led light on the power supply. Strangely enough, all of the internal hard drives (there are 3) started spinning up on their own and the CD-ROM drive was usable as well. None of the fans operated however and there was no signal to the monitor.

I removed the card, returning the CPU to the state in which it had just been previously working. Again, I could not power up the machine. The symptoms were now the same as when I had the new card in. After making sure I had disconnected all peripherals, I started disconnecting the internal components one by one as well (hard drives, RAM, etc) but each time I tested those, I still had no success. I also tried replacing the CMOS battery and always made sure I bled any residual power off by holding the power button in for an extra long time.

Nothing I have tried so far has been successful. I am down to thinking it has to be either the power supply or the motherboard at this point. The fact that I have always had the green led lit solid whenever there was power to the system and the fact that the hard drives would spin up OK (strangely enough when the system wasn't powered on) make me think the power supply may be OK and the MB is the problem, particularly since the CPU broke (MB fried?) when I installed the card (which was a brand new TP_Link Archer 1300 by the way). I'm still not certain which one it is though.

I've been through Dell's "power on" trouble shooting lists with no success. Does anyone have any ideas about what is going on here? Does it sound like as PS or the MB? Thanks in advance for any help.


Posts: 934   +223
TechSpot Elite
OEM systems generally do not include a lot of overhead or 'extra' power on the PSU. Maybe it does have the extra power to run the card? You could also inspect the PCIe slot where the WIFI card is going or maybe just switch to a USB WIFI card? That might work just fine.