1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Dell Latitude adapter or motherboard issues

By bongby ยท 19 replies
Nov 2, 2005
  1. I get the following warning just after the BIOS loads, on my Dell
    Inspiron 8200:

    WARNING: 70 Watt (20v,3.5A) AC adapter detected. System will not be
    capable of running in full performance mode without a 90 watt (20V,
    4.5A) AC adapter. Press F1 to continue in battery optimized mode, or
    F2 to shut down.

    However, I do _not_ have a 70 Watt adapter. I have two 90 Watt
    adapters. Both are reasonably new (less than 3 months old i am sure it is working properly). There is
    no pin damage on either the laptop or the adapters. I also get the same warning when I used a duck station.

    I have flash to the previous Bios, turn down the intel speedstep in CMOS, and set the power management in Windows to Max as well but no helpful

    would anyone have a idea to fix it

    thank in advance

  2. AdB

    AdB TS Rookie

    Dell ac adapter problems

    Helllo there,

    got the same message from my latitude d600,
    before booting is says; "ac adapter could not be determinded" ,
    press F1 to continue, it also turns out the batterie does not
    charge at all , so I bought a new one, no results.
    I tried an other adapter from a friend , same message, tried
    my adapter on his D600, no problems.
    We are in big trouble here, and need some help !!

    Thnx , AdB
  3. examdevil

    examdevil TS Rookie

    D600 Not powering Up

    Hi All

    Need some help with Dell d600 worked fine for ages now not booting up , If I plug charger into electric socket power light turns green but as soon as I press power button on laptop , charger powers off. Laptop will not power up. tried diffrent chrager same issue my charger on with other laptops . tried removing memory hdd same issues .

    Any Tips ?

  4. bushwhacker

    bushwhacker TechSpot Chancellor Posts: 783

    I have been using D600 for long time. I dont have any problem with it. Maybe you guys fooling around too much?
  5. almope78

    almope78 TS Rookie

    Helloo everybody

    am just having problems with my inspiron 8200. warning 70 watts detected but am using 90 watts cord
  6. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    wrong forum. This belongs in the laptop forum.
  7. lamo

    lamo TS Rookie

    almost all dell ac adaptors are with single-wire eeprom which contains adapter p/n. this eeptom connected to 3d pin of adapter and goes right into KBC multicontroller(well, almost :) thru some defence schematics).
  8. MeTiger

    MeTiger TS Rookie

    something ive seen before here, i have a dell and im using a smaller replacement power supply without problems.the pc requires a p-a6 and im using a p-a2.. 1.5 amp difference on the smaller side, but what ive knowticed with these lappies... when its plugged in, the adapters end( thats connected to lappy) seems to be loose a bit, im sure with lots of abuse, bumping and tugging would make it looser, i think actually it could be the power connector sauder joints on the motherboard that could be loose and slightly corroded thus the lappy only getting 1/2 or 3/4 of its power, try charging the battery on a friends exact same pc< MUST be exact match laptop> if possible, and try it with that if its ok.. i would consider looking into that by checking for looseness where it plugs into the laptop then go from there... it may provide a clue... never know...ooh and just for sakes end, grab a tester and check the wall socket... (110v min and 125v max <north america>)
  9. larrrardintx

    larrrardintx TS Rookie

    I had a similar issue with an 8200 I used to own. Turns out the onboard power inverter had a fault in it, that would cause it to not recognize the 90W adapter. Two adapters and a lot of less hair later, I realized when I ran other tests that the laptop was running fine and it was the fault in the power inverter.
  10. Nothinkinq

    Nothinkinq TS Rookie

    Dell Inspirion 8200 Battery Optimized Mode Help please

    Hello and happy new year,

    i have a problem, my dell have a same problem with 70Watt AC Adapter Detected.
    Please can everone explain me, how can fixe it myself please. I have already changed my dc adapter, but he have no effect and my batteries was not load :-(

    Thank in advane
  11. lamo

    lamo TS Rookie

    2 all user, who receive this message. dell PSU's have the data pin(it's the middle thin pin). PSU has eeprom memory which located inside and transfer data about PSU to laptop. so, if you receive this message - it means, that eeprom is unavailable or data is corrupted in it. or you just loose the contact with middle pin. the solution is only one: replace PSU. but if you receive the same message after replacing - this is bad motherboard(KBC may be damaged or data line from PSU's data pin to KBC may be corrupt).
  12. Nothinkinq

    Nothinkinq TS Rookie

    Hello Lemo, thank for help. I dont understand, what do you mean with PSU. Is that the DC Charger? I have already change that, but no effect. What means KBC?

    Thanks in Advance Nothinkinq
  13. lamo

    lamo TS Rookie

    PSU - Power Supply Unit. yes, it has eeprom inside. if your laptop won't recognize this charger, then try to update BIOS(there's small hope, that in your case, we have just some minor errors in KBC firmware). after updating the BIOS check adaptor compatibility(btw, is it original dell PSU?) or some error messages connected with adaptor. if the problem persists - this is motherboard faulty(i can propose the charging PWM controller faulty(max1908, or max8731 or something like this, i don't remember exactly))
    KBC(we call it KBC multicontroller) is the main low-level power\security\charging battery controller. it has firmware and it recognizes all dell's PSU's(via single-wire bus).
  14. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

  15. Nothinkinq

    Nothinkinq TS Rookie

    Hello Lamo,

    thanks for support. I will try this way. I Buying KBC controller, when i get this item, than i will give feedback again :)

    thank for link

    Thanks in Advance Nothinkinq
  16. playininthesand

    playininthesand TS Rookie

    does not recognise ac adapter press f1 dell d600

    I mess around with laptops so you may be able to decipher what all this means ..I had 3 Dell d600 and one 600m..I had two dell PA10 adapters.On every laptop with each adapter I would get a warning message at startup saying does not recognise ac adapter and although it would work on ac it wouldnt power up the battery. After hair pulling I bought a new PA12 adapter ..result ..no warning messages and charged as normal. The PA10 and PA12 are listed as compatible for these models so go figure. Maybe both my PA10s are screwed ..anyway there you have it
  17. Nothinkinq

    Nothinkinq TS Rookie

    Hello Friends, i have received my item, its a DC Charger Board into the Board. After replaced its no effect, i have same error message :-(

    Have anyone more idea?

    May be get solution when i choose and try with stronger adapter, but is it comptaible PA12 Adapter for Dells Inspirion 8200 Serlies?

    Thanks in advance
  18. igelkott

    igelkott TS Rookie

    Also having this problem!


    I do also have this problem with my old Latitude C840.

    I was wondering if anyone have any news about this issue?

    It seems that the CPU goes slower due to this problem, but that can be helped by removing all batteries.
    Also I sometimes get time and date reset. Is this due to me not having any battery installed? Or is my CMOS battery dead?

    Best regards from Magnus
  19. Knighthawk5193

    Knighthawk5193 TS Rookie

    Hello all, I'm new here, and need assistance, I have NO technical training or background at all so please be gentle! LoL! Ok so I have a Dell Inspirion 1150, and it's shutting down on me, after it shuts down I try to turn it back on and the battery light comes on as if it's charging, but it's not, when I disconnect the power supply it's dead. I tried buying a new power supply, but it's not working or charging. Is there any advice someone can give me?...i WAS able to get through the boot / start up once, but like 10 minutes in...it shut down on me and I haven't been able to bring it back up yet....I decided to try to let it charge overnight, and I'm hoping it works...my next thought is to change the battery, but that's about as far as I'll be able to take it on my own...can ANYONE help?...
  20. iwin12

    iwin12 TS Rookie

    Knighthawk5193 possible answer

    Sounds like the Processor is not cooling. Try cleaning the fans, heatsinks and airways. As well as, possibly re-seating the CPU with new thermal compound.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...