1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

"Detect Drives Done, No Any Drives Found"

By sakhurst · 10 replies
Jun 22, 2007
  1. Hi, I have an ASUS P5B Deluxe motherboard, a SATA HD and a SATA optical drive.
    Until today, all was working as it should. I tried to rescue data off an IDE HD by adding it as a second drive. This failed miserably for reasons I'm still not sure of. I could less about that now, however. Once I gave up on the IDE drive, and disconnected it from the system, I get the POST message "Detect Drives Done, No Any Drives Found". Not the SATA HD, not the SATA optical. This means I can't boot up period.
    I've tried reflashing the BIOS, playing around with the BIOS settings, but all to no avail. The weirdest thing is that the BIOS lists both drives and correctly identifies which port they are plugged into. I don't get it. Anybody out there with some idea?
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    What do you see when you go to Control Panel ->Administrative Tools -> Computer Management ->Drive management.
  3. sakhurst

    sakhurst TS Rookie Topic Starter

    Thanks for replying raybay. Unfortunately I can't tell you what I see there, because I can't boot up. I can't boot from the HD and I can't boot up from a CD/DVD because "Detect Drives Done, No Any Drives Found"
  4. CCT

    CCT TS Evangelist Posts: 2,653   +6

  5. sakhurst

    sakhurst TS Rookie Topic Starter

    Thanks for the suggestions CCT, I've tried disabling the JMicron controller, and the error message disappears, but it still does not boot up. I'm at work, so I can't try out your other suggestions, but I'm not sure what the benefit would be in borrowing an IDE CD drive...even if I get that to work, and am able to boot into the recovery console from the Windows XP CD, what then? It's no help if it doesn't recognize my HD.
    I think this is a motherboard issue. I'm going to get an external case for the HD tonight and tomorrow to make sure the data is all still intact, but I'm pretty sure it is.
    I'll also try flashing to an early BIOS...because who knows? This is the weirdest ( and most frustrating) problem I've ever encountered!
    I should also mention that the mobo has 8 SATA ports - 4 for boot drives, and 4 for data...the HD and optical drives are both plugged in to the boot ports.
  6. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Funny - I can't find any manual that says the P5B deluxe has 8 Sata - only 6. Section 4.3.5 of the manual I can find details how to set up the cdRom as well as the drive as an IDE (non-raid).

    gl anyway

  7. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Sorry. Stoopid of me.
    I doubt that it is a real motherboard issue, in the sense that I don't think it is a permanent condition. It is fixable.
    Some things to try first:
    One drive at a time.
    Floppy drive boot to MS-DOS or to Windows 98 if you have the floppy drive.
    BIOS. Can you boot up far enough to reach the BIOS? Boot pressing the various possibilities: <F2>, <F1>, <F10>, <ESC>, <F12>
    Can you get to a Safe Mode boot pressing <F8> repeatedly?

    Change the SATA cable and the SATA location? A replacement SATA cable will cost you anywhere from $3.49 to $12.99 depending on where you buy it.

    The basic idea is to remove every thing except what you need to do to boot: One power supply, one memory module, one bootable CD or one bootable floppy or one bootable flash drive.

    You need to get to where you can re-set the BIOS or Disc Management, then you are on your way to recovery.

    Sometimes it takes a clean drive with nothing on it... then boot to a cd and do a minimal install. Can you borrow a drive?

    Does your board have a couple of EIDE sockets? Remove SATA cables and attempt to boot to an EIDE drive of any size.
  8. raybay

    raybay TS Evangelist Posts: 7,241   +10

    CCT is essentially correct, with an exception or two. Double check all those SATA cables and socket locations. There is the potential for problems. I don't have a P5B board map in front of me right now, but I know there are four P5B motherboard versions: P5B, P5B-E, P5B Deluxe and P5B Deluxe/WiFi-AP.

    The P5B is the ASUS basic P5B model... can we assume that is what you have?... No... looking back, I see that you have the Deluxe.

    P5B-E uses ICH8R south bridge instead of ICH8 like on P5B, so on this board there are six SATA-300 ports controlled by the chipset supporting RAID (0, 1, 10 and 5) plus two extra ports controlled by a JMicron chip. P5B-E has also two Firewire ports. The rest of the specs are equal to P5B. P5B Deluxe has two Gigabit Ethernet ports, two x16 PCI Express slots (the second one running at x4), only one x1 PCI Express slot and a passive cooling solution using a heat-pipe. The rest of the specs are the same as P5B-E.

    ASUS P5B has four DDR2-DIMM memory sockets, supporting up to 8 GB officially up to DDR2-800, however this motherboard supports DDR2-1066/PC2-8500 memories. On this motherboard sockets 1 and 3 are yellow and sockets 2 and 4 are black. Configuring DDR2 dual channel on this motherboard is pretty easy: just install each module on a socket with the same color.

    On the hard drive storage side, where your interest lies, there are a total of six SATA-300 ports, four provided by the south bridge (ICH8) and two provided by a JMicron JMB363 chip. The ports controlled by the chipset do not support RAID, as the south bridge used is ICH8 and not ICH8R, however the two ports controlled by the JMicron chip support RAID0, RAID1 and JBOD. One of these two ports is located externally, for connecting an external drive. This port is different, as it is a port multiplier connector, SO YOU CANNOT USE A REGULAR SATA CABLE ON IT.

    Port multiplier technology is targeted at external hard disk drives, allowing you to connect up to 15 Serial ATA hard disk drives to a single SATA-300 port. In order to use more than one SATA HDDs on this port you need an external port multiplier bridge, which is an external device sold separately. The hard disks are connected to this device, while this device is connected to this port multiplier port, which, in turn, is internally connected to one of the SATA ports controlled by the JMicron JMB363 chip on the motherboard.

    It is critical to observe that the single ATA/133 port available on this motherboard is controlled by the JMicron chip, not by the chipset. This means that if you still have a parallel IDE optical drive it will only be recognized on Windows after you install JMicron’s driver. The problem is that this driver comes on the motherboard CD-ROM, and you won’t be able to install it, as the system does not recognize your optical drive. You can download the driver from the net, however the driver for the on-board LAN port is also on the CD-ROM… The only option you have is to copy the JMicron driver from the CD to a floppy disk or a USB flash drive using another PC. This problem happens not only with this motherboard from ASUS, but also with all other motherboards based on Intel P965 chipset. If you have a SATA optical drive you probably will not face this issue.

    You might want to think your problem through in relation to the above, and retrace all your steps to assure you haven't missed something too simple to look at.

    Again, I do not think your problem is a motherboard issue... meaning a failure or a defect, but this info here should clear up some flow problems.
  9. sakhurst

    sakhurst TS Rookie Topic Starter


    Just wanted to post a quick thank you to you both for going above and beyond in trying to help me! It was most appreciated!
    Turns out you were right...it wasn't a motherboard issue. It was a bum drive. Well, not so much a bum drive as a bum boot sector on that drive. Since that was the only HD, and since the Windows CD requires the detection of a HD to boot up, of course it seemed like nothing was working.
    In any case, since I now need to reinstall everything, I decided this would be the perfect opportunity to set up a RAID 1 array, as I had been planning to for a while now. So at least some good has come of a bad situation.
    Since the original HD had some data on it that would be nice to have back, I've set it aside for now...anyone know of a good data recovery program?
  10. Foo

    Foo TS Rookie

    Similar problem on a P5KR

    I've faced a similar problem on boot-up. I'm was running a RAID 1 volume with 2 x Seagate Barracude 7200 500GB. It has been running fine for the last 3 wks. However, I was faced with the "Detect Drives Done, No Any Drives Found" on the JMicron Raid Controller page during boot-up. On the RAID volume page, there were no RAID volumes detected/defined but both disks were detected, albeit, they were both labelled as "Offline Member".

    I went to BIOS Setup, turned off RAID and set them up as 2 IDE drives instead. Subsequently, I was able to boot up and both hard disks were detected. Fortunately, no data was lost.. A clear benefit of running RAID 1. I reckon that this proves that the SATA cables work and there is nothing wrong with the hard disks as well. However, I do not possess a RAID volume now.

    Can anyone advise me on what's wrong with my system (why did the RAID 1 volume suddenly disappear??) and what I can do to restore my RAID 1 volume without losing any data I have on my hard disks?
  11. billm2

    billm2 TS Rookie

    Same Problem -

    Sakhurst or who ever may know - I am experiencing the same problem but I still have access to my CD Drive (sata) and have run repair from the Vista CD. It now recognises the drive and OS and says it is bootable but the jmicron is still giving me the no drive detect message. If I let it keep booting it starts to load windows then goes to a black screen with cursor. I can get it to the same place in safe mode and know it has loaded the minimums as the cursor arrow is larger due to the resolution change but I still just have a black screen. I also ran Western Digitals lifeguard utilitities on the drive and it says the drive is fine. So, is it still possible I have a boot sector problem? I have run chkdsk, fixboot and fixmbr and they all say sucsessful. Can that jmicron driver get corrupted? I am not running raid but should I try to set the drives to IDE as the poster above did. I am being cautious as I just built this a month ago and finally have everything set-up and running fairly well (for vista). Abit IP35 pro board, Intel 6600 quad, 4 GB ram. The bios seems to detect the drives it is just the controller that seems to be the problem. For some reason though the repair in windows recovery will not find my restore points which are current and could probably fix this. I do have a fairly current back-up but know I will probably lose a few things if I have to resort to that and since the drive seems to test out fine I hate to reinstall if I don't have to.
    Any suggestions welcome, Thanks
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...