Device driver installation in Vista-Access denied

By mormol
Oct 3, 2007
  1. Hi to all,
    I have a problem when installing usb devices drivers the last few weeks. It all started when Windows update tried to install an update for a Logitech webcam and it failed. The error was: Access denied. Since then whenever windows update tries to reinstall the driver I get the same error.
    Recently, I bought a usb 4-to-1 hub (which normally doesn't need any drivers) and when I first plugged it in I got an access denied error again.
    Finally, I bought a Canon scanner today and, guess what: Access denied when I tried to install the driver.
    I am the only user on this computer so I have administrative rights. I also have the UAC off.
    Any ideas?
  2. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    Try installing again with UAC on. I've had problems with certain hardware and softawre that cannot be installed unless UAC is on.
    If this doesn't work, with UAC still on, try installing again but run as administrator.
  3. mormol

    mormol TS Rookie Topic Starter

    Thanks for your rersponse. I tried turning UAC on and running as administrator but I get the same access denied error.Another weird thing is that, if I try to install the drivers through windows (either automatically or by browsing to the driver folder) I get the error, while if I run the driver setup.exe file, it appears to be installing properly but then it doesn't work and I get an exclamation mark in device manager.I dont know if this points to any direction.
  4. mormol

    mormol TS Rookie Topic Starter

    Here's an update of what I've tried: I first tried creating a new account in case my current account was corrupt, but no luck. Then I uninstalled every USB root hub and USB controller and I created a havoc, cause when I restarted, I got the access denied error for the drivers of these too. Thank Bill Gates for system restore.
    The last thing I've discovered is that in my registry, if I try to access HKEY_CURRENT_CONFIG/System/CurrentControlSet I can't even click on it :S
    I get the following error:
    CurrentControlSet cannot be opened. An error is preventing this key from being opened. Details: Access is denied.
    If I try to look at its permissions I get the following message:
    You do not have permission to view the current permission settings for CurrentControlSet, but you can make permission changes.
    Which of course then I can't cause I get an error saying:
    Unable to save permission changes on CurrentControlSet. Access is denied.
    I don't know if this is what causes the problem, but it sure looks suspicious...

    Any ideas? Pleeease help!!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...