DI-624 Router: It stopped working

By pc_illiterate ยท 13 replies
Sep 26, 2005
  1. Ok, here's the whole story. I was making some adjustments on my router the other day for my azereus bittorent client and I was told that I have double NAT or something. Everything was still working fine at this point. I use a siemens speedstream 5200 modem that came from the ISP, and I changed it to bridged mode. I couldn't access my modem's ip any more after that, so I decided to turn off and on my modem. The problem is, after rebooting my modem, my router stopped working. I can still connect through the modem though.

    The day I got my modem, I had a similar problem. I couldn't get my router to work. After running the wizard like 20 times, it somehow magically worked... for my computer only. Then I had to run it more times to get my sister and my computers to work. Once I plugged in my brother's cable, everything stopped working. After a series of plugging, unplugging, and rerunning of the wizard, it worked (don't ask me how).

    Can anyone help?

    PS. should I get a different router? I heard that d-link is horrible, especially the wireless. Is linksys better?
  2. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    you do not want bridge mode. Start with one computer to the router, cabled to the modem.
    Internet connection should be ok. Then the other computers should work too.
    The bittorrent client is a separate issue.
  3. pc_illiterate

    pc_illiterate TS Rookie Topic Starter

    My modem is probably reset back to its original settings when I rebooted (though I'm not certain), but I can't access my modem's ip any more, so I can't be sure what mode it is in right now.

    I tried to connect one computer (unplugged all the other ones) to the router, then router to modem, but it still doesn't work. It's most likely a router issue.
  4. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    then cable the system directly to the modem.
    using the RUN->cmd, enter
    ipconfig /all

    you'll get the IP address (assigned to your computer)
    gateway, mask, and DNS Address (which belong to the ISP).
  5. pc_illiterate

    pc_illiterate TS Rookie Topic Starter

    I tried every address given and I still can't access my modem. Isn't the issue with my router?
  6. tdeg

    tdeg TS Rookie Posts: 119

    Is your computer set for DHCP or did you assign it a static IP address?
  7. pc_illiterate

    pc_illiterate TS Rookie Topic Starter

    I assigned it a static IP. It was part of the configuration of the bittorrent client.

    Everything was still working fine even after i gave my computer a static ip.
  8. tdeg

    tdeg TS Rookie Posts: 119

    Did you happen to change the IP address of the router before you assigned the static IP address.

    What static address did you assign it?

    It should be in the 192.168.0.xx range.

    I would change your IP to dynamic again and then log onto with user admin password password .

    You will need to set up the port forwarding again.

    A better way to set up your static IP address is to use the DCHP static IP address function of the router then if you get a reset of the router you can still get a valid IP address.
  9. pc_illiterate

    pc_illiterate TS Rookie Topic Starter

    I can still access my router with my old router IP. I changed my IP in the lan settings to the IP that is displayed im ipconfig/all which is

    Does it matter if I change MY ip back to dynamic? Because NOBODYin my house can access the Internet through the routers, so it may not be the static ip that's causing the problem. My router was still working fine even after I changed the IP to static.

    I've tried what you told me, and after I changed the settings back to obtain ip address automatically (same for dns server), a new network icon at the bottom right corner popped up. It's the LAN status, and the status says acquiring ip address... after a while it changes to limited or no connectivity.
  10. tdeg

    tdeg TS Rookie Posts: 119

    It sounds like the DCHP server is turned off on your router.
  11. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  12. pc_illiterate

    pc_illiterate TS Rookie Topic Starter

    Whoa slow down... you lost me there already. I didn't do all these complicated steps when my router worked the first time (after like 30+ times of rebooting). All I did was reboot my router many times until it worked, which was very strange. I set up my router using the wizard so there wasn't much configuration done to the router, and I didn't do anything to my LAN's ip properties (the one where you get to from view network connections in the control panel).
  13. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    Suggestion on this forum are intented to help YOU with your problem.
    It is very easy to make mistakes when one has little prior experience in a given area.
    You can go it on your own or try to use the information and skills of those who
    know how. It's your choice.
  14. pc_illiterate

    pc_illiterate TS Rookie Topic Starter

    Every time I was given a suggestion, I try it. It doesn't work, that's why I'm inputting my opinion on it. I don't only try out suggestions that are more plausible to work considering I don't know anyways.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...