Diablo is available to play for free in your web browser

Shawn Knight

TechSpot Staff
Staff member

Diablo, the beloved action role-playing game from Blizzard, is now available to play in your web browser courtesy of RivSoft.

Essentially the shareware version, the browser game (dubbed Devilution) is reconstructed from the original Diablo source code – complete with bugs and poorly written code. Should you own Diablo, you can use its main data file to unlock the full version in your browser. If not, you can grab a copy over on GOG for $9.99 which includes the Hellfire expansion.

If you’re like me, you’re probably wondering if this is even legal. According to the development team, they aren’t really sure.

Under the DMCA, reverse-engineering has exceptions for the purpose of documentation and interoperability. Devilution provides the necessary documentation needed to achieve the latter. However, it falls into an entirely gray area. The real question is whether or not Blizzard deems it necessary to take action.

Here’s to hoping Blizzard doesn’t take action.

Permalink to story.

 

Nero7

TS Evangelist
Dude, you gotta own the gme and drop a file in the website to be able to play.

This is not play for free this is play in your browser if you own it.
 

MannerMauler

TS Addict
I think they might've gotten that cease and desist letter, if you click on the shareware version, you get a 404.
 

Mugsy

TS Evangelist
I have D1 installed already (patched to run under Win7 at high resolution) and was able to provide my MPQ file. It worked.

If you have D1 but were never able to get it to work under Win7/8/10, the web player is a great way to get a working game again, but there's no way to mod it.
 
  • Like
Reactions: SolarisGuru

Mugsy

TS Evangelist
FOLLOW-UP: I don't know if my (Firefox) Browser is at fault, but the emulation seems to be very buggy.

I started a new game. Everything looked & worked perfectly. I cleared Level-1 (using my official MPQ file off my CD) and tried to return to town.

I first got the "Decend" (stairs down) image and the Loading progress bar rapidly flicker-filled a dozen times, then switched to the "Accend" (town) image, same rapid flicker-fill of the Loading bar, and when the Dungeon entrance appeared, my character was nowhere to be seen, I couldn't move, and in the top-left corner, it said "Level-159".

I saved & reloaded but it did not fix it.

I started a new game with the same character, went down to Level-1 and the map was all screwed up (doors that could not be opened or floating in mid room and rooms I could not access at all.)

I'll try again with another browser, but so far, the emulation seems to be too buggy to risk attempting an entire campaign.
 

Latest posts