Did Something Stupid

By walkergm
Feb 27, 2005
  1. Hey, I did something stupid. My RP614 router was working fine, and then I upgraded it, but used the wrong firmware upgrade. Now when connected to my dsl modem, my Netgear RP614 router cannot connet to internet.

    My dsl modem does not see the ethernet connection when my router is connected. Modem is showing dsl, internet, and power connection, but not ethernet.

    When connected directly to dsl modem, I can connect to internet just fine.

    I can not get to the Netgear wizard via the browser in order to correct the faulty ungrade.

    Did I destroy my router?
    Is there anyway to fix this?
    I tried resetting router to factory setting, buy alas, no success. How can I achieve the factory properties?

    Thanks for your help in advance.
  2. Killer_Byte

    Killer_Byte TS Rookie Posts: 21

    You should not have done any physical damage to your router. They are pretty robust pieces of hardware. However firmware can be very complex and goes wrong easily if a wrong version is used.

    Did you try to put the old firmware back on. You should know the version that you replaced.

    I use the motto "If it isn't broke dont try and fix it"
  3. walkergm

    walkergm TS Rookie Topic Starter

    I wish I had adhered to your motto.

    I have tried to put the old firmware back on but because my dsl modem does not recognize the ethernet connection when hooked to router, I cannot get to the internet to correct the problem.

    I have tried resetting it to factory settings according to the instructions, but still can't do it. It was pretty easy before to go to my browser and put in (default address) and gain interface with the router.

    I am beginning to think that the router is shot for other reasons. The day that I put on the new firmware I had lost internet connection and my power breakers kept going off. The power switched off more than 10 times that day and stayed off for awhile. Everytime, I went to tamper with the router, the breakers will flip.

    So, I am thinking that the router is dead. What do you think?
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    If you put wrong firmware on and you can no longer access the firmware upgrade place then you are out of luck.

    If the router is under warranty then you can just take it back to the shop saying that "it broke".
    If there is no warranty then you can try opening it up to see if the flash memory is on a separate removable chip which could be programmed in some other device.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...