Difficulty performing save as ...

By JeremiahJohnson ยท 6 replies
Jan 9, 2007
  1. Hello to the board!

    First and foremost, my apologies if this problem has been covered already. I did a search and I couldn't find exactly what I was looking for. In addition, I checked a couple of articles that have been written about the issue -- IE, Rally 'Round the Tri-Mode Flag -- but, despite these efforts, wasn't able to actually resolve the problem.

    My problem appears to be a simple one. Whenever I attempt to perform a Save As from practically any application, I get a dialog box telling me:

    The file could not be accessed. Try one of the following:

    After this intro, I'm presented with four bullets outlining various options. Of these options, the second one seemed the most likely:

    Make sure the folder that contains the file is not read-only.

    So ... I went to the folder in question and checked its properties ... and, as I later learned, it has a checked Read-only attribute box with a faint grey background: referred to as a tri-mode flag. Although it's great to learn the name of this annoyance, I'd really like to learn more about a remedy for it. The article I referenced above seems to indicate that it appears because sub-folders and/or the files they contain are read-only. I've checked a few folders that don't even contain anything and I still have the same issue.

    Specifically, the OS is setting the tri-mode flag automatically [after it is removed by myself].

    I am not running a network, and the OS in question is Win XP SP2. Once again, I'm sorry if this is dead horse thread, but I did try to resolve it before I came here. Have a great one.

    As I was writing the initial message [above], I performed a Start | Run... | winver | OK to obtain detailed version info, but lost the OS in the process.

    Anyway, I've got it now. I hope this helps:

    Windows XP Professional

    Version 5.1 (Build 2600.xpsp_sp2_gdr.050301.1519 : Service Pack 2)

    Thanks again for any help :)
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,739   +417

    Do you have administrative rights on this computer?
  3. JeremiahJohnson

    JeremiahJohnson TS Rookie Topic Starter

    That's a good question ...

    The OS was installed -- by myself -- to make its use is as simple as possible for anyone using it. Consequently, there are no user name or password entries that are required during the startup process.

    Nevertheless, I do see [what appears to be] a user name at the top of my Start window, so I'm assuming that is the default user. With that in mind, I checked into the administrative rights question in this manner:

    R-click on My Computer
    L-click on Manage
    Expanded Local Users and Groups
    L-click on Groups
    Dbl-click on Administrators

    At that point, I got an Administrators dialog box listing the user name in question as a member. I'm assuming that would indicate that the default user has administrative rights. Is this correct?

    By the way, thanks for editing my post. :)
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,739   +417

    Is this happening to all locations you try to save? If you open a previously created file are you able to save changes? (by regular save not save as) Do you happen to have a flash drive you can try to save to? Flash drives are formatted as FAT or FAT32 in most (all) cases and because of the file system they do not have permissions defined by the file system, so unless the drive is locked you should be able to write to them.

    If you are unable to save as to a flash drive it would start looking like you've got some malware. Is this happening in all programs you said practically any in your first post, but are there any you can save as from?
  5. jobeard

    jobeard TS Ambassador Posts: 10,835   +894

    SNGX1275 is headed in the right direction:
    On XP, there are only TWO areas that all users can save into:
    \Docs & Settings\$yourlogin$\ and the common
    \Docs & Settings\$allusers$\

    Only an Admin can move or save elsewhere.
  6. JeremiahJohnson

    JeremiahJohnson TS Rookie Topic Starter

    Good information ...

    Very good posts!

    I will check into both of your insights as soon as I get a chance and get back to you. I've been so swamped with work that I haven't had a chance to get back to this issue.

    Thanks very much for your time ...
  7. Goalie

    Goalie TS Booster Posts: 616

    Jeremiah, first off, welcome to Techspot!

    If you're not concerned about local security on your computer, as an option, you can force your userID to have write permissions to the whole harddrive. Right click on the drive under "My Computer" and under security, add your user account with full permission (as you are an administrator, you can do this. Save encrypted directories/files, if you use those.) Be sure under advanced that the "Replace permission entries on all child objects..." is checked, click apply, then ok until you're out of the dialog. Restart to be safe, and you should be able to write to anywhere on the harddrive.

    Still no luck? Ok, two possibilities: 1. The permissions issue is in the registry, and the access denied is actually about that problem, or 2. Corrupt file system. I know Poertner had a good post on this issue once (corrupt), but I can't recall where it is right now. Scandisk isn't a bad idea, obviously. The fix to situation #1 is similar to giving yourself access to the harddrive- you can give your user unlimited access to the registry, as well, in a very similar manner. (look up regedt32.exe for information on this. It's really pretty obvious if you've worked with NT based permissions before.)

    There are actually more directories that ALL users are allowed to write to, but those are trivial and semantics only worth pointing out, not bickering about. ;)

    To answer above, If your userID was listed in the Administrators, you are either an administrator, or will be after the next reboot (if your userID was added to the administrator list after you were logged in, you won't be an admin until you log out and back in. Restart's the failsafe way to enforce that.)

    SNGX's suggestion about a flash drive is very good, as he is correct that they use FAT and won't have security descriptors to muck with your permissions. Floppy disks are a good alternative to USB drives, as they usually use FAT12. If you get errors after that, we know it's not the save itself that gives permission problems, but the process of preparing to save as.

    If you haven't resolved it yet, what happens if you use the simple "save"? What directory did you use, and if you have mixed results tell us what directories work and what ones don't.

    Hope this helps somehow!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...