Direct 3D Problem

By benderda ยท 9 replies
Apr 9, 2004
  1. Every time I try to run a game I get the message that Direct 3D could not be initialized. Also when I run directx diagnostic tool I get the massage:

    "Hardware accelerated Direct3D 9+ is not available because the display driver does not support it. You may be able to get a newer driver from the hardware manufacturer."

    I can not figure out how to fix this problem.

    Thanks for you help.
  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Sounds like you having either a problem with Direct X or your video driver.

    The first thing I might do is update your video driver with the latest available. The second thing I might do is update or repair your Direct X installation with the latest version.

    There may also be some sort of strange software problem that is consequent of some certain set of circumstances.. Perhaps a certain combination of hardware or software.

    If you can, provide more details such as the model of your video card, operating system, current drivers etc.. If you are unable to provide this information, we'll help you find it out as much as we can. :)
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    If your video card actually supports 3D acceleration you need to install drivers for it. If you have the drivers then try reinstalling them.

    It would help if you filled in your computer specs in your profile or at least told us what type of video card and Windows you have.

    And don't double post please.
  4. benderda

    benderda TS Rookie Topic Starter

    Profile Updated

    I have updated my profile so with all of the information that I know. I hope that info will help. If you need more info I may need some help finding it.

    Thanks again.
  5. Lordslayer

    Lordslayer TS Rookie


    hya, i have the same problem.. my direct3d its always goin down, i never had this kind of problems... my Directx V. its 9.0b cuz i cant install 9.0c, it says finished but the version doesnt change.. i used to have it, but it gave me sum error a few days ago & now it doesnt let me install...

    u have a nvidia Gforce mx 4400 128Mb.. with the latest drivers installed...

    can u help me? either intalling directx9.0c or fixin my direct3d problem...

    thank you..

    ps, u can see my system specs in my profile..(i think:p)
  6. Warrior72

    Warrior72 TS Rookie

    Its a fix

    This fixed my computer when i came across this problem.

    DirectX 9.0b SDK Extras: Direct3D

    i had directx 9.0c but this is the only thing i could find pertaining to fixing direct3d. even though it says 9.0b i l still installed becasuse i was desperate and it fix my direct3d problems. now the tests work in dxdiag and my games work.
  7. andy04

    andy04 TS Rookie


    I'm having a similar problem. I've downloaded the Direct X 9.0b SDK extras software but I don't know where the files need to be placed. I thought it would just install the software where it needed to be installed, just like DirectX but it doesn't. I've placed the files where I thought they should go system 32 but I'm still getting the same error as before when I run the DirectX diagnostic tool:
    D3D7 Test Result: Failure at step 8 (Creating 3D Device): HRESULT = 0x80004005 (Generic failure)
    D3D8 Test Result: Failure at step 8 (Creating 3D Device): HRESULT = 0x8876086c (error code)
    D3D9 Test Result: Failure at step 8 (Creating 3D Device): HRESULT = 0x8876086c (error code)
    I've already re-installed Direct X 9.0C and my video card driver is up to date, for a RADEON X700 Series card, it was installing the new driver when the problem started! Something went wrong with the install and I ended up with 4 bit graphics and 240 by 200 display. I sorted that out but need to sort Direct 3D now! Any ideas?
  8. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    Simple - The latest drivers have no 100% support for the AGP bus. If you have an ATI card please try to install the Catalyst 7.7, it's the recommend and most stable driver for AGP cards:

    "Failure at step x (Creating 3D Device)" means that DirectX was not able to get an connection over the driver to the graphic hardware. Usually OpenGL use another connection to the Hardware.

    And on a side note, from what I have found directx 9.0c cannot be uninstalled or rolled back to a previous version
  9. andy04

    andy04 TS Rookie

    Thank you!

    It works!

    A BIG THANK YOU to you from me and my son, who can now go back to playing Settlers!
  10. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    No probs, I know what a pain that is cause I had same thing happen when the new ATI drivers came out.

    I would bet you have same problem even though I'm not as familiar with Nvidia. Try going back to the last driver with 100% support for AGP
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...