Direct X 9.0c Problem

By AnimaPrincess ยท 9 replies
Dec 31, 2004
  1. I've looked in every one of your threads about the issues of downloading the Direct X 9.0c, and none of the threads seem to have my problem. Everything I try to download Direct X 9.0c a message pop up say " A cabinet file is necessary for installation can't be trusted." So could someone help me fix this problem? My computer is a Compaq Presario 5315KS and I have a Geforce FX 5700 LE graphice card. I'm also trying to play The Sims 2. :confused:
  2. Lostfaith

    Lostfaith TS Rookie Posts: 19

    1: did you download the dxwebsetup? in that case try downloading the full setup file directly at microsoft's webite.
    2:do you have a beta sp2 installed (i got a similar problem with this one on another pc i had to service) then quite possibly only a reinstall of sp2 or worse, a reformat/clean winxp install should help, cause beta sp2 supposedly had dx9c beta too (not 100% sure on this, anyone?)
  3. SiNz

    SiNz TS Rookie Posts: 21


    I believe the problem is the Windows trust security where it allows/denys flowing of programs/downloads (basically the firewall). I'm not sure if its the firewall though, but I suggest looking into that. Try going to your control panel and checking your network connections. Check to see if the internal firewall is on or off. But other than that, I'm not totally sure what else to suggest.
  4. AnimaPrincess

    AnimaPrincess TS Rookie Topic Starter

    Thanks for helping me, but I'm still having the same problem.
  5. annedisaster88

    annedisaster88 TS Rookie

    I'm having the same problem. I can't find any troubleshooting sites that know how to fix it. Did you fix it yet? What did you do?
  6. Rodex

    Rodex TS Rookie Posts: 29

    I had a similiar problem, after days of no help I burnt all my cherished files and stuff onto a dvd disc and system restored. If you do not have a system restore feature, call your manufacturer.

    Works fine now.
  7. secondsysop

    secondsysop TS Rookie

    DirectX 9.0c Error Message Solutions from Microsoft

    Entire message can be found at Microsoft DirectX Development Center
    at this link...

    :blackeye: (I think these directions only apply to Windows XP)

    DirectX 9.0c gives error "A cabinet file is necessary for installation and cannot be trusted." ERROR during installation. This problem happens in most cases due to system corruption or users disabling their cryptography services. Please try the following steps to see if it resolves the issue.

    1: Make sure your cryptography services are enabled. To do this, go to my computer | manage | services and applications | services. Then go to cryptography services properties and make sure the service is started and startup type is set to automatic.

    2: If you are running Windows on a FAT32 drive, run scandisk.

    3: Try the resolution steps in;en-us;813442.

    4: Try the resolution steps in;EN-US;822798.

    4: Remove temporary files in %temp% and (if installing end-user runtime)
    %windir%\system32\directx\websetup Error
  8. secondsysop

    secondsysop TS Rookie

    Hope that reply helps. Does anyone else have problems with your computer running slow after installing DirectX 9.0c?
  9. jamietowers219

    jamietowers219 TS Rookie

    Directx 9.0c cabinet file problem

    If you have the message 'a cabinet file necessary for installation cannot be trusted' this is the solution.
    First get service pack 2, either from the Internet or from Pc world.
    You will need to activate the .dll files. To do this follow these steps:

    1. Go to start menu, then Run
    2. Type in cmd
    3. Type the following, pressing enter after each line. (press OK if prompted)
    regsvr32 /u softpub.dll
    regsvr32 /u wintrust.dll
    regsvr32 /u initpki.dll
    regsvr32 /u dssenh.dll
    regsvr32 /u rsaenh.dll
    regsvr32 /u gpkcsp.dll
    regsvr32 /u sccbase.dll
    regsvr32 /u slbcsp.dll
    regsvr32 /u mssip32.dll
    regsvr32 /u cryptdlg.dll


    Restart the computer.
    Go to start, then run.
    Type in cmd.
    Type the following, pressing enter after each line:

    regsvr32 softpub.dll
    regsvr32 wintrust.dll
    regsvr32 initpki.dll
    regsvr32 dssenh.dll
    regsvr32 rsaenh.dll
    regsvr32 gpkcsp.dll
    regsvr32 sccbase.dll
    regsvr32 slbcsp.dll
    regsvr32 mssip32.dll
    regsvr32 cryptdlg.dll

    :) :)
  10. jjthedead

    jjthedead TS Rookie

    Shorter Method worked for me

    Do not worry about getting the service pack.

    Copy the first group of regsvr32 commands.
    ( the component unregister commands ).

    Open a command prompt window
    and paste in the first group then
    hit return once to force the last command to execute.

    ( components should unregister or say they do not exist. )

    Paste in the second group - hit return once.

    (components should register or say they do not exist).

    No reboot needed

    direct x 9c install then worked.

    This worked on Windows 2000 SP4.

    Please note the sccbase.dll did not exist on my particular 2000 installation.

    May apply to all 2000 or maybe not.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...