DirectPlay problem or the Ethernet card?

Not open for further replies.


Posts: 12   +0
Ok, folks. I have this strange problem that I can't shake and I need some help.

DirectX will not properly install directplay (as you can see in my dxdiag). I've tried installing and reinstalling severall versions/different sources, just to see if I could get it through. I can't.

Effect: Even when setting up a dedicated server (any given game that uses DirectPlay) on my own computer and running game on same, game is unable to find server. Homeworld 2 even registers "Network unavailable" (LAN and Internet both) which I have confirmed is usually due to inproperly installed DirectX (Forum at their hompage). Firewalls are killed and AntiVirals are disabled, during atempts.

Related specs:


MB/LAN: ASUS P4P800-E Deluxe w/Marvell Yukon Gigabit Ethernet (appears to be working fine) Onboard sound is disabled. Onboard 1394 is Enabled in BIOS, but manually disabled in Windows.

LAN setup: Two PC's through twist.
PC1: Gigabit LAN - IP: / - PROBLEMS w/DirectX
PC2: 1 run of the mill PCI Ethernet card 100mb IP: / 255.2 etc - FINE

I would guess DirectX is the problem, so how do I get it in there?

About DXdiag.txt Video and Sound checks out fine, just didn't bother clicking through tests

when I made this report.


Posts: 613   +2
From looking at your directX, I'm guessing that your install is hosed. The dxDiag log indicates many missing registry keys, which can impact many many things in unpredictable patterns.

DX9 should be available from MS's website, I'd suggest downloading and trying to install that.

Also, in applications like Windows File Sharing, do you have any problems between the machines? I mean, can you tell us for sure that the networking between the two is functional? If you have a cable or configuration error where windows can't find the network, then DX won't find it either.


Posts: 12   +0
  • Thread Starter Thread Starter
  • #3
Sorry for my delayed response, but it has been a while since I last had an uplink available.

I went through every thing I had done when setting up the computer and realized: My bad. I botched things when installing the drivers in XP.

First I installed different gfx driver than the one I wanted, then I saw what I had done and replaced it ASAP _without rebooting_ Here in lays my mistake. It caused a cascade of errors in the entire drivers system and played merry devils with the registry. No matter how much I tried to hunt down the errors through editing the registry or reinstalling drivers, removing drivers and reinstalling, removing ALL drivers and reinstalling... nothing helped. In the end I accepted defeat and reinstalled windows without making the blasted mistake. Broblems gone.
Not open for further replies.

Latest posts