1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Disk 2 unstable, plz help save data!

By scorpion_1112 ยท 12 replies
Nov 22, 2006
  1. I have two Seaget Hardisk.

    First one is 20GB one on which i have made 4 partitions (all ntfs) and WindoxXP pro is installed on Primary Partition as only OS for my pc.
    (C= 6291MB, D,E,F = 4267MB each)

    Second drive is 40GB one, on which also i have made 4 partition.(all ntfs)
    (C=10.7GB, D,E,F = 8.86GB each (now thats its not visible, i dont remember exact values, nehow, 6910MB was free on C of Drive 2)

    Today i saw my computer was not recognising partions of Drive 2 so i tightened the sockets for Drive 2. It worked for a while but then all of a sudden my computer hang...

    Then when i restarted the computer, the partitions of Drive 2 were not showing up in my computer folder.

    Now when i use Partition Magic, it says
    "Powerquest Partition Magic has detected an Error 110 on the partition starting at sector 61 on disk2
    Length of partition in partition table is incorrect.
    CHS length is 2314222 and LBA length is 2314224"

    Powerquest Partition Magic has determined that the length can be changed to correct value of 2314224"

    Then when i click yes to fix it and it says fixed, and when the main screen comes up, it shows only the primary partition of Disk 2. Even in that it shows its capacity as 6910MB which was the free space on that partiton b4 all this happened.

    Other partitions (logical partition in extended partition) are just not showing up!

    (Disk makes no noise, i dont want to format it!)

    Plz, i use this Drive for storage purpose and the Data on this Drive is priceless for me, not just all the songs and movies, lots of my important articles and notes r on it. I need to save it in any case. So what can i do?

    "Any" help with be highly appreciated!
  2. sghiznaneck

    sghiznaneck TS Maniac Posts: 394

    If you stated that you tightened the connection, I would try swapping out the ribbon cable for that drive first. It sounds like the cable may be bad. These cables will go bad due to the heat in side the case. Does the cable seem hard and brittle?? If it does, I'd bank on a bad cable.
  3. Nodsu

    Nodsu TS Rookie Posts: 5,452   +6

    It is not a good idea to let Partition Magic to "fix" stuff..

    Before doing anything, tets your drive with the Seagate diagnostic utility.

    See your system BIOS for any settings about drive addressing or mode (under IDE settings). Set those to LBA manually instead of Auto or whatever.

    Take a look at the raw partition table on disk 2 (PM should supply some utility). It could be that there is some logic error that is confusing Windows. A la PM "fixed" the thing so that the extended partition begins inside the primary partition or suchlike. (PM did increase the size of the primary partition by 2 sectors). Make a copy of that partition table. Write the numbers down with a pencil if you have to! Even if you can't make sense of the numbers, someone else may.

    Now, if you feel adventurous, you can try playing around with the numbers like changing the size of the first partition back to 2314222.

    You can throw some recovery utility at that drive that will try to find any "lost" partitions and restore the partition table to a workable state.
  4. scorpion_1112

    scorpion_1112 TS Rookie Topic Starter Posts: 18

    I tried what sghiznaneck told, i replaced the ribbon cable.

    Again i set the ST320413A (20GB Seaget Disk Having Win XP on Primary Partition C) as the master drive and ST340015A (40GB Seaget Disk, Drive two) as slave on same ribbon cable.

    Earlier i used to see just one thing from the Drive 2 in my computers folder, "Local Disk D" and windows used to detect its capacity as 6.9GB, that was actually the free space on it b4 all this happened. (i saw it after i uninstalled second drive from control panel and then let windows re-install it automatically with apt driver, i have alsways used it with windows driver

    After doing sghiznaneck thing something strange happened, my computers folder showed absolutely nothing from Drive 2. Then i opened up diskmgmt.msc from system32 folder, it showed presence of Drive 2 with Primary partition of 10.7GB all free (that was real size of C drive, primary partiton of Drive 2) and an extended partition of 28.3 GB (which i had divided into 3 logical partitions).

    But sadly, i read Nodsu's post right now only. So i did use PM again and i think it just uncreases troubles. After checking with diskmgmt.msc, i again opened PM and this time it showed an additional error 116 and error 110 like before, i chose to fix both. Once open, it showed the complete 38162MB of Drive two as bad partition, raw in its sense.

    After that i again used diskmgmt.msc, and now this windows disk management tool shows rediculous stats!

    Im attaching screen shots of whats been shown by diskmgmt.msc and PM right now. I also diagnosed my disk using Seage Diagnostic Utility, attaching screenshots.

    So what more can be done from here?
  5. Nodsu

    Nodsu TS Rookie Posts: 5,452   +6

    Well, it looks like the partition table(s) on the second drive are FUBAR..

    Did you check the BIOS setup for any LBA settings?

    Other than that.. Your best bet may be recovery software. Any data and filesystems on the drive should be in perfect condition - it is the partitions that are messed up.

    ZAR lets you recover 4 folders at a time for free IIRC.
  6. scorpion_1112

    scorpion_1112 TS Rookie Topic Starter Posts: 18

    K now i checked BIOS setup for IDE controller, this is what i got (i wrote it down with pen on a paper)

    Primary IDE Slave

    Drive Install ST340015A
    Type {ATUO} (can be changed)
    Maximum Capacity 38166 MB

    Option Selected by BIOS

    LBA Mode Control Enabled
    Multi-Sector Transfer 16 Sec
    PIO Mode Mode 4
    Ultra DMA Mode 5
    Cable Detected 40 Conductor

    Well thats all thats available from BIOS, at most i can change the auto option and change the Multi sector, PIO and Ultra DMA... I did not change anything.

    Yeah i also always felt that Partitions r messed up

    Then i tried the Trial Version of ZAR. I m giving screen shots with each step.

    In Advanced options, I know all the partitions were ntfs, so i foce NTFS. And in nTFS tab, when resolving MFT fragmentation. I think these settings r k. Then i click Next.
    Shot 001 and 002.

    Then Recovery Type = Recover Data from a Simple Voume or functional RAID Volume
    Shot 003.

    It detects Model of Drive 1 and 2, they are fixed drives. k. I click 2nd one and Next.
    Shot 004.

    Then i get screen thing in screen shot 005.

    Steps ahed of this r really confusing. Infact this stage in itself is confusing.
    As u can see its saying primary partition has an offset of 10894MB and Size of 27139 MB...
    Actually this was the location of the logical partition D and E on this drive.

    I tried defining the partitions manually also. The safest and closest to original partition sizes before all these are the ones in screen shot 006.

    Then i highlight anyone those voume defined by me, (in screen shot 006, first one, which was supposed to be the C drive with most precious data) and click next in bottom right.

    Next i get screen as in screenshot 007. No bad sectors. Even if i do this with any volume defined by me or found by software itself, no bad sectros r found anywhere. So it means disk is healthy right?

    Then shot 008.

    Then i try to choose only two files like in shot 009. Uc i had forced parameters of my original drive c On second drive 2, all the contents shown here are that of my original drive C only, which was also the primary partition for this drive 2.

    Then i try to copy to Partition F of my Drive 1 as in shot 010.

    Hey now it did copy it (i wrote all this simultaneosuly this time, earlier i tried to auto detect volume on drive 2 and copy files, also i gave other values while manually definiing, it never copied them, but this time two files have been copied to Drive 1, will this work for all?)

    Now do i need to buy a software like this or is there any way i can again force partitions on drive 2 as ntfs and that too in the size i mention. (i think shouldnt be a problem bcoz my disk was very arranged, timely defreaged with all files compacted in right areas...)

    So what next? (thanks for this much help, im feeling positive!)
  7. scorpion_1112

    scorpion_1112 TS Rookie Topic Starter Posts: 18

    This is post for additional screen shots which i was not able to post in the previous post.
  8. Nodsu

    Nodsu TS Rookie Posts: 5,452   +6

    You shouldn't have to manually force anything. Filesystems and partitions should be detectable by ZAR itself. Did you tell it to scan for partitions automatically?

    There is another free file recovery tool you can try called "PC Inspector File Recovery".
  9. scorpion_1112

    scorpion_1112 TS Rookie Topic Starter Posts: 18

    This time i tried to scan for missing partition ( shot 001 ZAR Scan Missing Partition), And ZAR found the 4 volumes (shot 002 ZAR Scan Missing Partition Found)

    But i find that maybe coz this is evalutation version, i am able to copy only 4 files of same directory (not 4 directory). Even if 4 files r off diff folders then it does not copy them in next step and i have to termintae program by ctr+alt+del.

    Anyhow, now whenever i have to recover files i always manually define partition as found in shot 002 (this saves a lot of time, it takes about 30 min to find them, then it takes 23 min to analyse a partition and 5 more min to validate files found, only then it allows me to select 4 files from same folder to copy).

    I also tried the other software u told me... PC Inspector File Recovery.

    I read it in the download.com review that it works to find only missing partion in FAT format, but not quite true, this software also recognises presence of Drive two... and logical partitions on it.. but im able to access only 1.

    I have attached step wise shots for finding lost partitions using this software as well.

    As u can see in shot 003 PC Inspector.png, it shows an error while finding logical partitions on drive2.

    Dont know why it finds 5 drives!(partitions) on physical drive2.(my all 4 were ntfs)

    After is shows an error, it still shows the 5 logical partitions it has found on physcial drive 2. (shot 004 PC Inspector.png) (in this shot i have previwed one of the partition, u can see doesnt make any sense, nothing can be saved from there)

    Out of the 5 partitions found on drive 2, only 1 with the name "(lost) on fixed disk #2" is accessible. This was actually my logical partition D on drive 2.

    Shot 006 PC Inspector.png shows what i get after selecting that 5th partition and it also shows that i am able to copy stuff from that partition.

    So in all, atleast 1 of the 4 partition on drive 2 is fully recoverable now. As for other 3, i have to use ZAR... or something like that.

    In my last post i actually asked if i can manually setup partition tables without formating the disk so that everything can be just like b4? (i find all the data is properly intact)

    Or is there any way i can make PC Inspector find other partitions also?

    Or some other software?

    And yes, thanks a lot, man ur a pro, now i know all of my data is recoverable, thanks again.
  10. scorpion_1112

    scorpion_1112 TS Rookie Topic Starter Posts: 18

    (Post for additional screenshots). And thanks again.:approve:
  11. Nodsu

    Nodsu TS Rookie Posts: 5,452   +6

    Hum.. I didn't know ZAR was so restrictive.. Thanks for the info.

    Yes, if you know the partition locations exactly, then you can fill these in the partition tables and hope that Windows can make sense of it. This would mean that you have to write on this disk and writing anything includes overwriting something that could be useful. Risky business.

    Since ZAR and PCI FS were useless (I'm really sorry about that), you could try this CD linux called INSERT that comes with a utility called "testdisk". Never used it myself, but the features look promising. It will scan your disk for partitions and rewrite the partition table accordingly.

    If you have the disk space, you could make a snapshot of your broken disk and save it as a backup in case something gets broken.
  12. Samstoned

    Samstoned TechSpot Paladin Posts: 1,009

    My 2 Rubuls

    scorpion_1112 you really should not make such small partitions
    does not do a thing for your machine or XP
    file scavenger and O&O file recovery are very good at data retrieval
  13. scorpion_1112

    scorpion_1112 TS Rookie Topic Starter Posts: 18

    K i am continuing this after a "longggg" time, lol. but just wanted u guys to know that i had recovered all the data from Disk 2 to another disk (using a software that i purchased, Stellar Phoenix FAT & NTFS rocvery) and then written it all on CD/DVD.

    But i am continuing this msg because today i realised i never needed to buy that software! Even after recovery of data, disk 2 was not working... but now since the data was recovered, so i took the gamble of using "Testdisk" and it came off! And it was actually very easy to use. So just in case anyone else has this problem in future, i wish he doesnt have to waste his money when it can be done for free!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...