Dlink DI-604 not accessible

By kubikmichal · 5 replies
Aug 31, 2005
  1. Hi,
    I have router DI-604 Ver.D1,
    to the router are connected 2 PCs and router is connected with DSL modem

    I HAD this problem,
    on PC everyhing worked ok, on the other one sometimes yes and sometimes
    i could't access to Internet i had to turn off and on the router and then it was ok for few hours/days.
    On the router is no firewall, no filter as well on the PC's

    Originally there was firmware Ver.3.06 so i updated on Ver.3.11
    Afterwards PC which worked before, was still working, but PC with problems before couldn't access Internet at all.

    So I went back to Ver.3.06, but during firmware uploading i got message, that router is not accesible.

    Now one PC work still ok, but from other one i can ping other PC, but can not ping router
    (and also can not access web interface for configuration).
    I have a feeling like original IP address for router was change.

    Anybody can help?

  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    See what gateway the PC with operational internet uses. The gateway address is the router address.
  3. tdeg

    tdeg TS Rookie Posts: 119

    Have your tried hitting the reset button on the router?

    If you had problems while flashing though you may be looking at getting a new router though.
  4. kubikmichal

    kubikmichal TS Rookie Topic Starter

    i have tryed to reset it multiple ways, but nothing.
    As I read on Internet there is posibility to reset it to factory settings, but it doesn't work.

    And i dont know what my roommate was doing while i was at work, but not he also doesn't get IP adress from router (even before he did).
    Only way how to access internet now is to connest his computer directly to modem, but we need Internet both.
  5. tdeg

    tdeg TS Rookie Posts: 119

    I fear you may have killed the router when the flash update failed.

    It may have been flaking out before that though.

    Is it still under warranty?
  6. kubikmichal

    kubikmichal TS Rookie Topic Starter

    Problem solved

    Hi people,
    thanks to everybody for help, but i solved my problem by my self (actually my friend helped me)

    The problem was, that it is too many ways how to reset the router to the factory settings and just one worked in my case.


    For those which can not speak German
    1. Connect the router to electricity
    2 Press a hold reset button for cca.. 20 seconds
    3. Disconnect the router from electricity
    3. Still hold the reset button for next 20 seconds
    4. Connect router back to electricity
    5. Still hold reset for next 20 sec.
    (I know it looks strange but it's working at least in my case)

    Then I used utility from

    which detected old firmware in my router (It was crashed) and uploaded new one 3.09. Even it's not the newest one it's working so i won't touch it anymore. But it looks like that it's better the original 3.06 at least connection is not dropping anymore.

    Afterwards i did reset router normal way.
    waited cca. 30 seconds
    and then i could access router over »
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...