DNS Server prob after upgrade to XP

By Son-of-Froggie ยท 4 replies
May 14, 2003
  1. Hi. I just upgraded my secondary machine from Win98 to XP. All seemed to go smoothly, but now I am having problems with my internet connection. I can view the LAN and router and can ping and browse the internet using IP addys, but not with domain names. It appears that the Domain Name Server has decided to stop honoring requests from the box. The primary machine (also XP) has no problems. I can successfully ping the DNS addresses (ave. 7ms.). The DSL vendor wants me to disconnect from router before they will help me troubleshoot but I would like to avoid that for now. (Connecting direct I will have to change all the settings and possibly load up their software).

    Any ideas?

  2. Supra

    Supra TS Enthusiast Posts: 190

    Do you use your router as a DHCP or do you have the IP addresses for each computer staticly configured? If its static then you should check on your secondary comp to make sure your DNS ip's are correct in NIC's TCP/IP settings.
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Even if you use DHCP for IP addresses, you can still enter the DNS data manually.
  4. swisstpa

    swisstpa TS Rookie

    I am having same problem

    The other night, the DNS on my XP (Home Edition) machine stopped working correctly. Iwas trying to uninstall Kazaa, and all of a sudden, the PC would not recognize domain names. I can ping IP addresses, but it will not recognize host names any more - I have no idea why this is happening. I have three PCs behind a Linksys Router. The others are still working correctly. One is a Windows 2000 PC and the other a Windows XP Professional PC. Any suggestions would be appreciated
  5. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    KaZaA may change your hosts file which can block internet traffic.

    Search your Windows folder for a file named "hosts". It has no extension, just so you know. But you can open it in notepad or wordpad since it is just a text file.

    Make sure the only entry is: localhost

    If there is anything else, then you should add # in front of the line or delete the line entirely. # ignores entries after the # on the same line.

    The junk at the top is normal and as long as it follows the #, the entries are ignored.

    I consider the above problem unlikely, but possible. A more likely cause are network settings or a network service is not working properly. Uninstalling your network card and reinstalling it in device manager will reinitialize your network services and settings. In many cases, this can be a quick fix to configuration-related problems.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...