Drive letter not assigned but seen for removing

By PReinemann ยท 4 replies
Nov 20, 2006
  1. My problem is unlike the ones listed where the drive can't be used. My ACP-EP 512M flash drive worked fine on my W2K pro machine, until the hard disk fried, and and I put in a new disk with Win XP pro. Then the flash drive worked OK for a while (2 weeks?), and now:
    - the machine doesn't give it a drive letter when inserted in any USB port (I have 6 or so)
    - it shows in the task bar for removing it "Safely remove USB mass storage device"
    - Disk management doesn't list it
    - it works fine on all other machines, 98 SE, several W2K pro, Mac.

    Any ideas?
    (It sounds like HW with the computer now with XP Pro, except that it worked fine with 2KPro and XPPro at first, and it works with other USB devices.)
  2. smore9648

    smore9648 TS Rookie Posts: 697

    Have you tried any other USB device with the system in question? Or have you tried all six with your flash drive?

    Possibly a port issue
  3. PReinemann

    PReinemann TS Rookie Topic Starter

    In the exact same port, a Lexar 256Meg flash drive works just fine. It would seem to be something about this flash drive, but it works in other computers. Guess I'll have to try another XP Pro machine.
  4. PReinemann

    PReinemann TS Rookie Topic Starter

    Oh yeah, it doesn't work in either USB port on the front of the machine, and it doesn't work in at least one of the 4 USBs on the back of the machine.
  5. PReinemann

    PReinemann TS Rookie Topic Starter

    OK, I found out what was wrong - well maybe not, but I found out how to fix or get around it... and the answer was in many of the answers I found here or on other sites.
    For some reason, Windoze (XP Pro) got it in its head that the flash drive HAD to be on drive letter L. Dunno why. L has always, and is still, one of my network drives. A disk on another computer on the LAN. I assigned it to M and it works just fine. Dunno what will happen if I put in another flash drive!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...