Driver_irql_not_ less_or_equal

By lancerj ยท 15 replies
Oct 31, 2004
  1. So last night my PC suddenly shut itself down. When I restarted, the login screen appears. I enter my pwd and then I see the blue screen of doom. "Problem has occurred, blah, blah..." with the following message:


    Technical Info:
    ***STOP: 0x000000D1

    ***dne2000.sys - address F8CE3C00 base at F8CDD000 Datestamp 3c3cdbfy

    Then at the bottom it states the system is dumping physical memory. What are my next steps?

    I have tried re-installing WIN XP PRO but is still occurring.

    Thanks for the help. :blackeye:
  2. Goalie

    Goalie TS Booster Posts: 616

    The paricular error message you've posted isn't TOO informative, but it points in several directions-

    1. A bad driver, probalby a network card based on my searches for dne2000.sys. Look for driver updates and most recent versions.
    2. Bad ram. Try using memtest86 ( fixed thanks to Didou below..). Boot the floppy image and let it run.
    3. Bad Virtual Memory. This just sucks. I know of no good way to repair that.
    4. Potentially bad hardware. As I said, try the network card (removing it if possible).

    If you've reinstalled Windows XP, I'd lean towards bad driver, ram, and hardware in that order. The virtual mem shoulda been repaired by the reinstall.

    Do you ever get any different errors?

    btw- Welcome to Techspot! :wave:
  3. Didou

    Didou Bowtie extraordinair! Posts: 4,274

  4. lancerj

    lancerj TS Rookie Topic Starter

    quick update - brought PC up to my office (just the box) and one of our tech guys ran updates, checked memory, HD, etc. all checked out fine. used my netgear wireless usb adapter at the office and it worked perfectly. no more blue screen and no more errors.

    well, i brought it home, plugged it in, attached my wireless adapter, monitor, keyboard and mouse and started it up. the error is back, blue screen and all!!! any suggestions now? extremely frustrated here!!!! would my mouse or keyboard cause this problem?
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    How about a nearby microwave or DECT-telephone or speakers (or a neighbour with a strong CB-machine)?

    Move that PC to another room and see what happens.
  6. lancerj

    lancerj TS Rookie Topic Starter

    I've had the same set-up for quite some time with no issues.
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    You still have doubtful wireless adapter, monitor, mouse and keyboard.
    Swap them one by one until you find the culprit.
  8. Gunny

    Gunny TS Rookie Posts: 66

    Your BSOD is telling you which driver is causing the problem: dne2000.sys

    You should find it in C:\WINDOWS\system32\drivers. It is a Deterministic NDIS Extender (DNE) or Deterministic Networks VPN driver.

    Just in case you don't know, VPN stands for Virtual Private Network. If you are accessing your company's system from home you have probably installed their VPN software to do so. I would guess that the software is produced by a company called Deterministic Networks.

    The dne2000.sys file may be corrupted or may need to be updated (probably for SP2). You should speak to your company and/or to Deterministic Networks about it.

  9. lancerj

    lancerj TS Rookie Topic Starter

    According to DNE website, I may need DNE 2.20. I've googled my head off. Can anyone help me located this file?
  10. Gunny

    Gunny TS Rookie Posts: 66

  11. lancerj

    lancerj TS Rookie Topic Starter

    Success! Uninstalled the VPN client and removed the dne2000.sys file. All is well! Any ramifications of removing this file, as long as I do not reinstall the VPN client?

    Thanks! :bounce:
  12. Gunny

    Gunny TS Rookie Posts: 66

    If the problem was simply file corruption you should be able to reinstall.

    If the problem was file compatibility then you'll need to get an updated driver.

    Sorry, I can't answer your question about ramifications of uninstalling the software.
  13. Don G

    Don G TS Rookie

    I'm having a similar STOP message appear (see post below "SHUTDOWN W2K") and get a file mentioned:
    < from that post >
    I've been seeing random shutdown (I unchecked "shut down", so now I get the BSOD + error message) ever since I added a Plextor external CD/DVD burner to my USB2 port. It happens when I am using one of a few "labor/CPU intensive" programs, like EasyShare (photo management) software or viewing video input from my DV camcorder. Or just when I don't expect it!!

    Message is (w/ slight variations):
    *** STOP: 0X0000000A <IRQL_NOT_LESS_OR_EQUAL>
    *** Address: 804311EC base at 80400000
    ntoskrnl.exe <----- this occurs frequently

    ***STOP 0X0000000A <0X00000016, 0X00000002, 00000000, 0X804311EC
    Address 804311EC base 80400000, date stamp 40d1d183
    Begin memory dump......etc etc

    I've searched Win for this file and find no less than 8 copies (some in \system32, others in \$NtUninstallxxxxxxxxxx).
    Could I delete (or rename) these after finding ntoskrnl.exe on my W2K install disc and putting it in C:\WINNT\system32 ?
  14. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    This file is the Windows kernel. Do not mess with it.

    The one in system32 is the one you are using. The others in ntuninstall folders are older versions that have been replaced by Windows patches. Dropping in the version from your original CD while leaving other system components intact will mosy likely render your Windows unusable.

    Although your problems may lie within Windows kernel, you are better off playing around with drivers/hardware.

    Have you got the latest ones for your chipset? Maybe remove/reinstall allUSB drivers you have? Have a look in Device Manager (view hidden devices) and remove any unused/useless drivers you have there.
  15. Gunny

    Gunny TS Rookie Posts: 66

    I would suggest that you first run sfc /scannow. If the ntoskrnl.exe file itself has in fact been corrupted that should cure it.
  16. drustubbinsky

    drustubbinsky TS Rookie

    Wonderful! I was running the Cisco VPN dialer software which was the problem.

    I located the dne2000.sys file at C:\WINDOWS\system32\drivers, compared the install date with the VPN install date. After determining they were installed on the same day, same hour, I UNINSTALLED the VPN router via Add/Remove Programs.

    After a reboot the dne2000.sys file is still there, BUT the problem is fixed.

    THANKS! This totally fixed the problem!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...