Dual Boot Delimna - started with missing or too small page file

By oldlefty
Nov 23, 2006
  1. I have two computers running dual boot systems with W2K/WXP Pro. Both had been working great until last night. I decided to dedicate one to music and move all of my music files to it. I recently added a fourth hard drive and am now running two PATA drives and two SATA drives. The OS drive is a 250GB PATA drive on the primary cable.

    With XP running, I discovered multiple duplicate music files and started deleting them as I came across them. All was well until last night when I tried to boot into W2K. It displayed a message that one of my drives needed to be checked for errors. When it finished with that text across the screen kept scrolling upward non-stop. After 15 minutes I shut it down and turned it back on. When it got to the startup screen it informed me that the page file was missing or of insufficient size and gave instruction on how to fix it. But it would never fully boot, instead recycling and showing the WzK splash screen time after time.

    Today I booted into WXP and looked at the boot.ini and compared it to the other machine. The problem one shows W2K on partition 1 and WXP on partition 4. There are 4 partitions but XP is on partition 2. The other machine shows the two OSes on partitions 1 and 2.

    Somehow, I think this is part of the problem of not being able to boot into W2K but don't know how to fix it. Any ideas?


  2. Cams

    Cams TS Rookie Posts: 27

    Log in the recovery console using your XP installation disk. You can then run bootcfg /scan to find all Windows installations.

    This MS page explains the available commands and switches in the recovery console:


    I had to do to this one time as well. I've forgotten the specifics, but I know that it works. It gives you the option to add installations to the boot.ini file.

    Alternatively, since it seems you can still log into your XP, you could do that and simply change the number manually in the boot.ini file.

    I think I began my research when I had this problem by searching for the exact error message I was getting - missing ntdlr or something like that if memory serves. Your problem sounds much less serious that mine was - I had hosed my partition table with Partition Magic and was desperately trying to recover my data (which I did, but it took me three days).

    Creating a boot floppy from this site helped me to boot into Windows:


    It provided an edited boot.ini file with various options to try in sequence until it booted. Might help you out too - read through it and see what you think.

    Also have a read through this techspot thread:


    Good luck!

  3. oldlefty

    oldlefty TS Rookie Topic Starter

    Thanks for all of your suggestions. I've had quite an adventure and have ended up where I started. The first thing I did was to edit the boot.ini to match the one on my other computer. I left W2K as partition 1 and reset the XP partition from 4 to 2. After that I couldn't boot into either W2K or WXP. I tried booting with a bootable floppy and running fdisk /mbr as suggested in another forum. That didn't help. I then tried your suggestion of logging into the recovery console and running bootcfg. The results were:

    [1]: C:\WINNT
    [2]: E:\WINDOWS

    I ran fixmbr and bootcfg /rebuild. Somewhere between these two I managed to restore XP but still can't boot into W2K.

    When booted up Windows XP shows as on the D partition and in the 2nd partition position in Computer Management, yet shows as Partition 4 in the Boot.ini. It works that way and does not work when set to Partition 2 in the Boot.ini. Go figure.

    Anyway, I still can't boot fully into W2K. It boots up to the entry screen, the startup sound music plays and then it stalls with a light blue blank screen [not BSOD]. Eventually, it just starts recycling continuously, playing the startup sound and quickly displaying the W2K screen with the message that says "Loading Your Personal Settings" and then one that says "Saving your settings" like the one normally seen when shutting down. Booting into Safe Mode results in similar behavior.

    Remember that the initial problem resulted in seeing a screen that said the pagefile was missing or too small and gave instruction to fix it but never let me get to the screen to do so. I tried setting it from the XP partition but still have the same results.

    The W2K partition is 35GB with 21GB of remaining space. So it ought to be OK.

    Any other ideas?


Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...