Dual Boot XP impossible?

By JohnnyX
Dec 7, 2006
  1. Hi
    I'm new here and vey impressed with peoples knowledge on this forum. Hope someone might have some suggestions. I want to be able to boot from either of 2 separate internal IDE drives. One for vdeo editing, the other for general use. I have XP pro, mirror copied on both primary partitions of each drive using "Casper XP". My first drive is partitioned (C: D:) is Master on IDE primay chanell and is a 120gb (40gb on C: and 80gb on D:), with jumper set to "master". The 2nd drive (slave on IDE primary chanell ) is 750gb (40gb on L: and 710gb on M:) jumper set to "slave" on 2nd drive. Wondering if both should be set to CS (cable select) ? may not matter for what I am attempting...just wanted to mention it...ya never know.
    After copying C: to L: and editing boot ini to this:

    [boot loader]
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Regular computer" /fastdetect /NoExecute=OptIn
    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Video Editing" /fastdetect /NoExecute=OptIn

    I tried to model my boot ini from someone on this forum who posted a similar success but with differnt drive configuration using SCSI drive with drive controler card , posted by jsshackel back in 2003 and other posts very similar.
    I simply added the last line identical to the previous line, but I changed only the rdisk value from (0) to (1)

    With this change, it will boot to first option as in the begining, but 2nd boot option just goes blank screen until time out and reboots.

    Tried disconnecting power to the C: drive and re-booting....hoping it would seek L: drive , no go....same deal.

    Must be more to it....mabe the cable select option? maybe Casper XP did not really copy everything necessary? claims it does. Maybe one must use the Microsoft XP dual boot install routine, hopefully not.

    I tried osl2000 Boot Manager and it did not recognise the XP OS copy on drive L: after its scan routine.

    I also went to disk management and changed Drive L: to "Active" hoping that might help....still no go

    Possibly something in mapping drives? or registry edits in the XP copy on drive L: thinking something needs to be changed there like replaceing any C: to L: in certain places for osl2000 to recognize ?

    any thoughts would be more than welcome. Thanks
  2. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,443   +38

    Try changing the partition value in the last line to 2 and see if it helps. Maybe it's detecting L: as Partition 2 and M: as Partition 1.
  3. JohnnyX

    JohnnyX TS Rookie Topic Starter

    Thanks for replying. I realized my bios was not recognizing the 2nd drive as bootable. Talked to Seagate and they found the access mode setting for this drive was defaulted to "CHC" by the bios ater installing drive. I reset access mode to "AUTO" and all worked as desired, after creating the additional line in bootini file (with 2nd drive marked (1) after rdisk) instead of (0).
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...