Dual Harddrive

By streittk · 8 replies
Nov 10, 2003
  1. Was having problems on my machine and decided to slick the harddrive. My CD-RW was also having problems, so I decided to back the data on a 2nd harddrive.

    I took the second harddrive from another machine I have set up for my son and put it in the one I was working on. It was already being used as a secondary harddrive so I didn't do anything with the jumper settings. I just booted it up, and saved my data files to the second harddrive.

    :cool: So far so good. I booted from floppy, I formatted the C: drive and loaded my operating system. Everything was working good. I powered it down and went to bed figuring I just needed to finish loading software and copying back my data the following morning.

    Next morning, I powered it up. Got the error saying I didn't have any harddrives. BIOS didn't dectect any. None, zilch, nodda. Only way I could get it to recognize the harddrive was to unplug the cable to the secondary drive and power back up.

    Anyone ever hear of this? I must be missing something simple here. :confused: The only thing I had changed was the order in which it searched for booting up. I think it had been set to Floppy, then HD. I changed it so it would try Floppy, then CD, then HD.

    Oops. Forgot to leave my name. Thanks in advance, Kevin
  2. BBString

    BBString TS Rookie Posts: 20


    Unplugged from your second IDE line where your CD RW was or same line as C: is on?

    And it registered after this?

    For now.... (Sounds silly) but check the following to be sure......

    The IDE cables to drives are correctly in and the right way round.
    Primary HDD (c:) is set to "master".

  3. streittk

    streittk TS Rookie Topic Starter

    Went fishing yesterday instead of working on my computer. It was much more relaxing... :D

    Had to disconnect #2 (slave/D:\) HD in order for the machine to recognize the #1 (master/C:\) HD. If both drives were connected, the machine doesn't recognize either.

    I'm pretty sure the jumpers are set correctly on the slave. It was being used as a slave on another machine and I didn't change anything. And, as I said before, I had both connected on this machine and they both worked prior to formatting and reloading Win98SE on the master HD.

    The only other thing I have set up differently now is this:
    Remember I said I was having problems with my CD-RW? I think I fixed it by disconnecting a slave CD-ROM drive. There must have been something conflicting when both drives connected. BIOS recognized both, but kept having problems with reading from and writing to, the CD-RW.

    Had I figured this out first, I would have used the CD-RW to back up my data files instead of a second HD.
  4. BBString

    BBString TS Rookie Posts: 20

    Strange... if your second HD (d:) is on a seperate line, you may as well have it as a master.. try it...

    Edit: Just fixed that "(d:)" so it wouldn't have a smiley.
  5. streittk

    streittk TS Rookie Topic Starter


    I seem to be using wrong names for some of this and cornfusing you good folks.

    The two HDs are on the same IDE cable. I have two hard drives on the primary IDE and CD-RW on the secondary IDE.

    But, what you said might work. I may try to put the slave HD on the secondary IDE and unplug the CD-RW and see what happens. It's only temporary until I can get my data files back.

    Does that sound like it can work?

  6. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    Have you tried a different IDE cable? That may be the source of your problems.
  7. BBString

    BBString TS Rookie Posts: 20

    ok its either the IDE cable or confllicting devices....

    Try splitting the HD into seperate IDE lines and also try new IDE cable.

    Should be able to have Primary master HD and secondary master HD and CDROMs as slaves......

    switch the connection on the IDE cable as they do actually define which is master and slave too... (ie the very end is the master / middle slave..... (I think!)

    Hope this helps......

  8. streittk

    streittk TS Rookie Topic Starter

    I worked a bit longer on this last night. The two hard drives are on the primary IDE. The master is a Western Digital 40 gb. It had the jumper set to cable select (CS) and the cable connecter was for the master device. I know this because it was labeled as such on the cable.

    The slave that I took from the other PC and saved my data files is a Quantum Fireball 13 gb. It had no jumper and was on the primary slave connecter.

    This is what I tried last night: Using the WD-40 as the master, used CS jumper setting on the master and tried (one at a time) all the different jumper settings on the Fireball. Computer’s BIOS would not detect any HD.

    Note: The label on the Fireball is not too clear on how to use the jumper settings. It worked in the other computer as a slave without any jumpers, as it did on when I backed up my data files on this one.

    Then I did the same with the WD as master w/ jumper set at “Master with a Slave”. Tried all the setting on the Fireball with the same result.

    Then I tried setting it up on my secondary IDE as slave with CD-RW as master. Now BIOS detected nothing on the secondary IDE. Removed the CD-RW and tried booting up with the Fireball as the master on secondary IDE. Nope. Removed all drives and tried the Fireball as Pri/Master. Nothing.

    Now, I've used different IDE cables (Pri and Sec IDE), tried the HD as the master and the slave, and with and without other devices. Nadda.

    It seems when I built this computer a few years ago I went through similar problems with this HD. It may be the reason why I ended up attaching the Fireball to the other computer. For whatever reason, maybe my computer just doesn’t like it. It worked fine on the other.

    I wonder could it just be a problem with Quantum Fireball HDs connecting to the MoBo that I'm using? The one it was working on had an Intel chipset, (Celeron). The one I'm trying to get it working on again is a VIA C3 800 mhz.

    The only thing I can think to do now is see if it will work on my son’s computer again. If it does, I guess I can try to set up my CD-RW on it and copy my data files to CD. Don’t know what else to do.

  9. streittk

    streittk TS Rookie Topic Starter


    Okay. Job is done, sort of, and figured I'd give anyone interested a follow-up.

    I figured that since the Fireball worked on my son's Celeron that I could hookup the drive and my CD-RW in his and copy the files to CDs. Then I could put the CD-RW back in my machine and copy back my files.

    Well, I thought it was good idea, but it didn't work. I had the same problems on his computer. With the Fireball connected as slave, CMOS wouldn't recognize it. So, I took it back out along with the CD-RW and basically gave up.

    Anyway, after letting the fireball sit on the top of my desk for a week or so, I tried it in my machine again. I didn't change anything. I just plugged it in (outside the case), booted it up, and the drive was found! Quickly, I copied my files back to my master drive and shut it back down.

    Figuring it wouldn't hurt to keep the 2nd drive, I unplugged the machine, mounted the drive in the empty slot and powered it back up. Guess what. It wouldn't find the slave drive anymore!

    Oh well, at least now I don't need it. I got all my data back. Will probably just throw the thing away to save any future headaches.

    Now, I got a CD problem, but that's a different problem, so I'll save it for a new thread.

    Thanks for y'alls help.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...