DVD Burning Help

By Nezbit
Dec 28, 2004
  1. Ok, I've got a Phillips DVD+RW-D01 drive with the latest drivers. I also have Nero Well, it won't burn DVD+R. I checked the toolkit and it won't support it. I've tried a bunch of other programs like Cheetah and Deepburner and none of the them work saying that I have an Illegal disk. I've tried Memorex and Spin-X disks that are DVD+R's. The interesting thing is that Nero says it will support DVD+RWs. So, help me find out why I can't burn my DVD+Rs.

  2. rdel

    rdel TS Rookie

    firmware upgrade for dvd+rw-d01

    I found a firmware upgrade for the dvd+rw-d01 on a dell computer page
    (br59173.exe) is the upgrade that will bring the firmware on the dvd from 1.4
    to 1.9.
    when I used nero info to check my dvd it said dvd+rw only, now after the firmware upgrade it list dvd+r and dvd+rw. I don't have any dvd+r right now to check it but i'll let you know what I find.
    You can search for br59173.exe on google and it will bring you to the page.
    del :grinthumb
  3. rdel

    rdel TS Rookie

    oh well

    I tried a dvd+r and it won't record to it. Looks like dvd+rw only on a dvd+rw-d01
    del :hotbounce
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...