1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

DVD & CDROM drives suddenly not recognized

By Littlehorse ยท 12 replies
Jul 20, 2005
  1. Hi All,
    Windows XP Pro SP2: Both drives work (I can boot off them) and are recognized by BIOS but Windows cannot find them. Device Manager says drivers loaded OK but cannot locate hardware. Have uninstalled/re-installed via device manager. Have re-installed new drivers for both. Cables/connections seem OK. Have removed all non-MS drivers by renaming. Supposedly no viruses/spyware onboard. This may have occurred while updating I-Tunes software so I removed all traces of that as well. I have not re-installed SP2 yet. Any ideas out there? I'd like to find the cause rather than just re-install Windows - I'm the curious sort. TIA
  2. Littlehorse

    Littlehorse TS Rookie Topic Starter

    SP2 no help

    I found time since initial post to re-apply XP SP2. No change.
  3. luvhuffer

    luvhuffer TechSpot Paladin Posts: 443

    Have you tried clearing the CMOS and resetting the BIOS including redetecting all the drives? Are the ROM drives showing in UDMA 2 in device manager under ATA/ATAPI device controllers under secondary IDE channel? Also you may want to try and reinstall the chipset drivers. Have you tried uninstalling them and rebooting?
  4. Littlehorse

    Littlehorse TS Rookie Topic Starter

    Thanx for response

    Nope - haven't tried resetting bios or clearing CMOS yet. Seems a little drastic but may help. I will have to check device manager when I get home to see if they show in UDMA2 under ATA/ATAPI. Have done the physical disconnect however, removed power & cables a then re-detected. They're both on 2ndary IDE and have worked fine there for years.
  5. luvhuffer

    luvhuffer TechSpot Paladin Posts: 443

    I was having a similar problem with my kids system. Trying to install a SATA drive. Clearing the CMOS was the only way to bring them back. One other thing you may want to check is the voltage values for the PSU. A power drop will also do something similar to what you are seeing.

    Also go to start/run and type in Msinfo32.exe Go to the Hardware Resources, expand the tree and check each level for conflicts. Also go to error reporting at the bottom of the tree and see if there is anything in there.
  6. Littlehorse

    Littlehorse TS Rookie Topic Starter

    Still no luck

    luvhuffer, again appreciate your response - MSINFO did not reveal anything outstanding. No IRQ 15 (IDE 2) conflicts or any others that would seemingly affect these 2 bad boys, and both devices were of course not listed there. Error reporting had nothing significant to do with them but interestingly had all other reports dated in 2004 and nothing recent. I reset CMOS values in BIOS to no avail. I did not do a hard reset, haven't even looked in the mobo manual on that yet (old Gigabyte 845PE) - is that what you meant, a hard reset? Anyways - a Ballbreaker this one! I have an image from last year that I want to put back on to see if issues go away but then there's no learning value.
  7. luvhuffer

    luvhuffer TechSpot Paladin Posts: 443

    When I said clear the CMOS, what I meant was not just to reset to defaults. You need to physically go into the case and reset it. There are two ways. Both require you to unplug the system first. Inside the motherboard you will see the CMOS battery. A big flat oversized watch battery. Next to it will be a jumper with 3 pins. The jumper will be on pins 1 and 2. remove the jumper and put it on pins 2 and 3 for 60 seconds. Then return it to pins 1 and 2, then reconnect and reboot. You will need to reset the BIOS again. Make sure your date is right. The other way is basically exactly the same except you would remove the battery for 60 seconds, then replace it. You might also want to try hooking up the drives one at a time on the other IDE cable and see if they are recognized. You may want to check your system files as well. Go to start/run and type in sfc /scannow make sure you leave the space between the c and / That will start the system file checker. It will repair or replace any damaged system files. You will have to reinstall SP2 and all updates afterwards though.
  8. Triton

    Triton TS Enthusiast Posts: 82

  9. kathrynsbf

    kathrynsbf TS Rookie

    my dvd

    hello everyone im called tj nice to meet you all :giddy:

    im wondering if you could help me i have a dvd-rom drive and all of a sudden it cnt reqonize the dvd-rom or dvd-video that put in the drive but it can reqonize the cd-rom for example i have just a football game and its called
    Pro evolution soccer 4 PC DVD-ROM and its does not work at all and i just dnt it plzz help me
  10. Littlehorse

    Littlehorse TS Rookie Topic Starter

    Many thanx to Triton - Problem solved

    I checked in the registry as per the MS technote. There was an upper filter but no lower filter. I deleted this upper filter and rebooted, XP found and installed the hardware without issue. The upper filter was "GEARAspiWDM" so my initial suspicions were correct - this all started with an "I-Tunes" software upgrade for the IPOD. Thanx Triton and thanx again to you as well luvhuffer.
  11. lightingguy

    lightingguy TS Rookie

    I am having the exact same problem, but I get an error when I try to delete the key (upper filter, I don't have a lower either). Any suggestions?
  12. luvhuffer

    luvhuffer TechSpot Paladin Posts: 443

    The key would be the value in the left hand window. Are you talking about deleting that? You need to delete the filters by right clicking on the right hand filter name and hitting delete. If that's what you are doing (deleting the right hand one) what kind of message are you getting?
  13. Littlehorse

    Littlehorse TS Rookie Topic Starter

    Also - you need to have administrative rights to delete items fromthe registry.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...