DVD-Drive won't read a DVD-ROM

By MrTom ยท 15 replies
Nov 26, 2005
  1. Hey, first post here.

    I recently bought a DVD-ROM game and my DVD/CD-RW drive won't read it!

    What could be wrong? Please help

  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Does your dvd/cd-rw combo drive read other dvd roms ok?

    It could just be that your new dvd-rom disk is faulty.

    Regards Howard :wave: :wave:
  3. milky

    milky TS Enthusiast Posts: 85

    Perhaps your DVD Drive needs a Firmware update. Check the manufacturers website.
  4. MrTom

    MrTom TS Rookie Topic Starter

    It runs everything else fine.

    What is a firmware update?

    I have also gone and swapped the game, but this one doesnt work either! ARGH.
  5. iss

    iss TechSpot Chancellor Posts: 1,994

    Do you have any virtual drives, or prorams like Alcohol 120% or cloneCD installed? some game makers blacklist such programs and make it where thier games wont run or install if certain software is installed on the computer.
  6. MrTom

    MrTom TS Rookie Topic Starter

    Thats a good point.

    Can i find a list of what programs the companies do block?

    The game was made by Lionhead Studios and Activision.

    It's called The Movies.
  7. milky

    milky TS Enthusiast Posts: 85

    Firmware is software (or instructions) stored on a Programmable Read-Only Memeory chip inside the DVD Drive (lots of hardware devices these days contain Firmware). Sometimes this needs to be updated or 'flashed' with a newer version of the firmware.
    DVD-R/RW Drives usually have a media compatability list (which can also be found at the manufacturers website) which contains all of the different brands and types of media that the drive can read/write.
    Its possible that the game was burned to a brand of media that was not compatable with your drive at the time the drive was manufactured. A firmware update will bring this media compatability list up to date and possibly fix your problem.

    Goto the drive manufacturer's website and check if your firmware is up to date. If not, download and run the latest update.
  8. MrTom

    MrTom TS Rookie Topic Starter

    Hmm, there are no Firmware updates for it, I think its the blacklist thing.

  9. iss

    iss TechSpot Chancellor Posts: 1,994

    Virtually any copying software that is used to circumvent copy protections most notably. Alcohol 120%, CloneCD, Clone CD Virtual drive, Dameon tools, I have even heard of some games not working or not installing if any kind of virtual drive was installed.

    I have also seen some games with certain copy protections that would not install from a particular drive. I had a g ame once that would not install from my DVD rom but would install just fine from my CDRW.

    first thing I would do is return the game from wehre you bought it and tell them it is a defective disk and have them give you a new one ( it is always possilbe that the disk is defective) if the second copy doesnt install then it is probably some kind of protection blacklising a program you have installed.
  10. milky

    milky TS Enthusiast Posts: 85

    that's bull s@#t if it's blocking him due to a program installed. They don't have that RIGHT!

    There is a little thing called THE CONSTITUTION!
  11. MrTom

    MrTom TS Rookie Topic Starter

    Yeah, I have got another copy, same problem :(

    Crappy Lionhead. I remember the Black and White CD I had used to not read, but now it does..strange.
  12. iss

    iss TechSpot Chancellor Posts: 1,994

    The constitution deals with what the government can and cannot do. it has no bearing on his situation. and the companies that are doing this have covered themselves by requiring your agreement in the EULA. if you read it carefully and know what you are reading yo will find that by agreeing to the EULA you have agreed to allow them to install this type fo stuff.

    if you have Autoplay enabled then the protection probably installed some files on your system when autoplay ran. this is why savvy user disable autoplay. if you have copy software installed youmight check for updates, the better programs usually release updates to overcome the latest blacklisting efforts of the game makers.
  13. MrTom

    MrTom TS Rookie Topic Starter

    Argh this is so annoying.
  14. milky

    milky TS Enthusiast Posts: 85

    If I recall correctly, his drive was never able to read the disc.

    He didn't agree to any EULA simply by buying the game.

    If a message or EULA were to appear during the install process warning him that he must uninstall such and such program in order for install to continue, then the companies would have themselves covered. This isn't the case here though. He bought the game, and the disc doesn't work. It's not telling him why it's not working. So, either the company is in violation of the constitution, or there is a defect with the disc or the drive.
  15. I had the same problem recently with FARCRY on my pc. I bought the game got home, put in the disk, and blam,,,,,, nothing!

    Looked everywhere, and eventually found that my particular make of disk drive was not compatible with that game! LG GDR-8160b.

    Cut my losses and bought another drive (samsung), and ta-da!! no problems since.

    That could be your problem, as i also tried taking the game back,,,,, twice! LOL :)

    The shop put it in their pc and it loaded straight away.

    Just a thought.


    PS The drive worked fine with everything else i had, including other games, so i have kept it in the system.
  16. MrTom

    MrTom TS Rookie Topic Starter

    Yeah, I've gone with the new drive idea, its very reassuring that your problem was sorted by this, AmDuSeR, thanks :).
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...