DxDiag and Win2K

By bjsjr
Apr 7, 2002
  1. Does the Direct3D testing in DXDiag work with Win2K? I recently ran it and it passes the Direct3D test when using the DirectX 7 interface but fails when using the DirectX 8 interface with the followong error:

    Direct3D test results: Failure at step 5 (GetDeviceCaps): HRESULT = 0x8876086a (3D not available)

    I'm using the Nvidia reference drivers 28.32 and have also tried version 23.11. I have also reinstalled DirectX 8.1 numerous times during the test. I have the following hardware:

    EPoX EP-8K7A w/512mb RAM (not overclocked)
    Gainward Geforce3 Ti 200 (not overclocked during these tests)

    I tried playing Aliens vs Predator II (which requires DirectX 8) and it seems to play just fine. So I'm not sure if this is just a DxDiag problem or is my D3D8 really not functioning?

    Thanks for any help.
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Welcome to 3DSpotLight Forums!
    I'm quite sure I've seen this before but now I just can't find any info.. Anyway, if the games work, I'd say no need to worry, just a DxDiag problem.
    Or you could do the following:
    in dxdiag display tab, disable Direct3D acceleration. Reboot. Run dxdiag & enable Direct3D acceleration.
  3. bjsjr

    bjsjr TS Rookie Topic Starter

    Toggling D3D on and off in DxDiag did it. :grinthumb

    Thanks much!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...