emachines psu blew. Replaced psu but it won`t start.

By chffan ยท 7 replies
Nov 12, 2006
  1. I am working on a emachine for my brother. I put a new Power supply on, because the old one was fried. Now the cpu fan turns, but that is about it. I am afaid that something on the MB is fried. I am getting no beeps. I have an electronics degree, but that was 12 years ago. I know that the capacitors pop easy, but i am not seeing any bunrn marks or bulging. I have a multi-meter, but do not remember how the should test. Any ideas?
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    I have moved your post to it`s own thread, rather than leaving it in a thread that`s over a year old.

    What you describe seems to be a very common problem with emachines.

    The psu blows and unfortunately takes the mobo and/or other components with it.

    Take a look HERE and HERE.

    Regards Howard :wave: :wave:
  3. Spoelker

    Spoelker TS Rookie


    I'm in a similar situation. The PSU on a friend's EMachine blew. After replacing the PSU, the machine wouldn't boot - no POST, but the fans worked. At everyone's advice here, I replaced the MBO with a MSI PM8M-V Socket 478 MBO. I still am not getting any POST beeps, but I see that the CDRW and DVD lights are flickering - Power is getting to the board.

    Any other suggestions as to what I've done wrong....

  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    It is so important to make sure the replacement motherboard will accept the old CPU, and memory. Items like modems, sound and video cards could be damaged by the faulty power supply too
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    If you have any old cards from the Emachines remove them and see if the motherboard posts. If it does, install the cards one at a time until you have post errors again. Also make sure that the motherboard is properly installed and not shorting to the case. Have you tried resetting the CMOS?
  6. K@in

    K@in TS Rookie Posts: 36

    the psu usually takes the mobo with it, and some times the cpu.
  7. Spoelker

    Spoelker TS Rookie

    I have reset the CMOS. The only card that I was using from the old machine was the modem. Still no POST after removing the modem and resetting the CMOS. Could the CPU be zapped as well?

    As an update - the HD is spinning

    I've looked around for any obvious shorts. Where a some less obvious spots for shorts?
  8. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...