Epox 8KHA+ hangs with ATI Radeon 8500

Status
Not open for further replies.

Per Hansson

Posts: 1,974   +232
Staff member
This is a problem I've had for quite a while now, I'll try to explain it as in depth as I can...

Before I had the ATI Radeon card I had a Voodoo5 on the same mobo, everything worked fine and
I was quite amazed by the extreme stability of the Epox mainboard. (I actually never managed to crash
that configuration once!)
Then I tried to voltage mod my Epox mobo but that didn't go to well, (I fried the mobo), but end of
that story.
I had preordered my new ATI card a few months back and finally got it, but I didn't have my new
Epox mobo yet, so I just put the card into my other computer with an Abit KT7A mobo and everything
worked perfectly fine, no stability problems or visual artefacts at all...

But then when I got my new Epox mobo back the problems began; I had the same components in it as from the beginning only thing is that now the computer would always crash and display visual artefacts...

Ok I thought; must be a faulty mobo, but still something about that statement didn't sound right so
just to be sure I put my ATI card in the old mobo again; and sure enough, it ran stability tests 48H
in a row without crashing!

Ok, then I thought I'd just send in the Epox mobo as faulty but still this didn't feel right, after all
I've never in my life heard of a "DOA" Epox mobo...
So I borrowed a Geforce3 TI200 from a friend and ran stability tests on the Epox mobo for 8H in a row
but it didn't crash then either, and neither did it display visual artefacts!

So to sum it up: It can't be the ATI card being faulty, I've run that for 48H without stability or visual
Artefacts on my Abit mobo. Neither can it be the Epox mobo since I've run stability test on that with a GF3 for 8H without any crashes or visual artefacts!

It can’t be the drivers either because I've run the two configurations with the exact same installation:
Install Win98,
Install VIA 4in1437 and latency patch 0,19
Install DirectX 8.1a
Install win98 GFX driver: 9016

And on the computer with the Abit KT7A mobo this config ran 48H straight, on the Epox it barley runs one minute, and that is with visual artefacts! Though the GF3 could run this config for 8H without crashing...
Also mind you that these are "clean" installs, i.e. I've done a format between every change of hardware...

If I am to worsen the already strange problem lowering the frequency of the "Built by ATI" ATI Radeon 8500 Retail card with a default core/memory clock frequency of 275/275mhz does infact allow the card to run longer; up to 10 minutes with some luck, though remember that on my other computer it can run in full speed for 48H so it's not a problem with the card itself...

And this takes us to where I believe the problem lies. Do you remember the old Creative/VIA debate over which one of them was guilty of who created the infamous "crackly" noise?
If a Creative card was put on a VIA mobo it often created crackly sound, but paired with an Intel board no crackle was present.
Though if you just went and bought a Hercules soundcard or whatever and paired it with your VIA mobo everything worked perfectly, so it would seem both VIA and Creative was guilty, and I'm willing to bet that the same thing is happening here...

So what I'd like to hear now is your side of the story; do you have the same problems or does your comp run fine? I sure want to know!

And before I forget it, here is an easy was to reproduce the bug; first download 3DMark 2001 SE, start it and select Tests > Change, click "clear" and only tick "Point Sprites" (the spinning white horse) click "ok" Now Options > Change and tick the two buttons at the top "disable title screens" and "looping". Now click "ok" and "benchmark"

Though this isn't the only way to reproduce the bug; just take your favourite game, I for example can't finish a single lap in Need For Speed 5 Porsche Unleashed...

The visual artefacts I'm talking about are also a good indication of the problem; my monitor can’t cause them because with the GF3 they aren't there, and neither can it be the ATI card because on my Abit mobo they aren't there. And as I said it couldn’t be the Epox either because that's what the GF3 was tested on, so to sum it up:

The crashes and or visual artefacts aren't caused by anything!

I'll try to describe the visual artefacts also, they can appear anytime, I'm seeing them as I type this text in Windows, though they appear more often in 3DMark2K1, they are quite hard to explain to, it's like a 5cm long and 1cm thick line "flashing" on the screen for about 0,1 second...

Also said should be that I've never seen these artefacts when I've had stability, i.e. get rid of the artefacts get rid of the crashes too...

The crash is also a bit weird, I’ve only tried it in Win2K but if I run Winamp in the background the song will continue to play when the computer has crashed until it comes to the end, it won’t begin on a new song though… And the image of the horse just “freezes” on the screen, pressing “reset” is the only way to restart the computer it seems…

Oh; and I also always run Windows 2000, it was just under the tests that I ran Win98, but the problem is exactly the same under both OS'es...

Sorry for the long message and happy hunting in figuring out this problem for me; I've already given up ;-)
(Psst, if you figure out this problem I'll throw in a good word for you in the ongoing contest, just don't tell anyone ;))
 

Didou

Posts: 4,190   +11
Have you tryed fidling around with the BIOS ?

I'd set it to 1x AGP, no fastwrites, 64 mb apperture & try to run windows. If it works without a hitch, I'd re-enable each function in the BIOS one at a time & let windows run for a few hours for each function.

A BIOS update could also be a good idea ( unless you've tryed that allready ).
 

SuperCheetah

Posts: 704   +1
Have you tried the newest VIA 4-in-1 driver yet? The 4.38 drivers have the newest AGP drivers in them. You can get it here:

http://www.viahardware.com/download/index.shtm#4in1

The AGP driver version 4.10b has these upgrades:

4.10b -

- Provides an enhanced AGP driver for Windows XP
- Fixes some information strings to pass some driver verification tools published by 3rd party companies
- Supports the AGP function in VIA P4X series North Bridge Chips
- Certified for Windows XP in the INF file

You can also download the 4.10b AGP driver without downloading the whole 4-in-1 package. The package includes:

4.38 (a) Final - Latest Official 4-in-1 Driver - Fixes many of the problems associated with the previous 4-1 driver. Incorporates the 4.10b AGP driver, fixes a memory dump in Windows NT with dual processors, and add the ATA133 feature in XP

Hopefully this can be of some help to you. :) Also, do you mind throwing out your system specs so I can do a little more research into your problem? I've heard horror stories with the VIA 4-in-1 4.37 series even though your previous setup seemed to be fine. I would definitely try a different version if I were you.

Edit: You wouldn't happen to have a Creative sound card would you? I've heard the the Epox board does not play well with the ATI 8500, Creative sound card, and especially the 686B southbridge chipset. One more thing, is it the infinite loop error, or something different?
 

Per Hansson

Posts: 1,974   +232
Staff member
Didou; Yes, I have tried different BIOS settings, I've set it for the most stable possible but still it helped nothing, I also downloaded the newest BIOS yesterday but that didn't fix it either:(

SuperCheetah; Yes, I saw the new VIA driver yesterday, though it didn't help to install that either...

I might add that I have tried without the VIA driver but the problem was still there (clean install)

I do infact have a Creative 5.1 soundcard, though the mainboard doesn't have the 686B southbridge, it has the new(er) VT8233 southbridge and KT266A Northbridge... (And I have tried without the soundcard, clean install but same problem...)

I don't get any blue screen at all so I assume it can't be an Infinite loop because Win2K should sense that and put up a blue screen then...

I have tried to run the system with as few components as possible, though my full configuration is as follows:

Epox 8KHA+ mobo, KT266A NB and VT 8233 SB...

Athlon XP 1700+ (1,466ghz) CPU, watercooled, not overclocked and default voltage (1,75v)

TwinMOS 256MB PC2100 CAS-2 DDR RAM (tested myself in the review of this mobo up to 185mhz with stability...)

"Built by ATI" ATI Radeon 8500 Retail with a clock of 275/275mhz (core/mem)
---
Creative SB Live! 5.1 soundcard, in PCI slot2 (have tried to remove it - didn't help...)

Realtek 8139 LAN card, in PCI slot3 (have tried to remove it - didn't help...)
---
Enermax 431w PSU (the power outlet is grounded)

Maxtor DiamondMax HDD connected as master on IDE1

Pioneer 16x DVD player, connected as master on IDE2

1,44mb floppy (yup, it master to :D)
---
Microsoft Intellimouse Explorer, connected to USB port

Analog Eizo F57 monitor connected to VGA output on GFX card

Usual keyboard, connected to PS/2 port

Cambridge Soundworks DTT 3500 digital speakers, connected to digital DIN on soundcard...

V.90 modem connected to COM1...

I might also add that all screws for the mobo are there so it's grounded as good as it can be...
 

SuperCheetah

Posts: 704   +1
Ok I'm getting desperate here :)

What kinds of ATI drivers have you tried so far??? Try reverting back to some of the older 4-in-1's if all else fails and try different drivers from ATI. I'm sure you've already tried this, but its just a suggestion.

Also, try reinstalling DirectX 8.1.

Maybe this can be of some help, although you seen to have done an excellent job of exhausting all of the options I can think of.
 

Didou

Posts: 4,190   +11
I've had a similar problem with an ATI Radeon VE & an ECS K7S5A...

It would crash at all times. Sometimes in 2D while surfing. In the High Poly Test in 3dmarkSE, during games. The card work flawlessly on any other mainboard.

I ended up putting a GF2MX400 instead & no problems ever since.
 

Per Hansson

Posts: 1,974   +232
Staff member
As I've said it works with the Win98 drivers on the Abit mobo for two days, but if I use the same config on the Epox mobo it hangs after just a minute...

It just must be a conflict between the ATI Radeon and Epox 8KHA+ mobo...

Does anyone have this configuration, Epox 8KHA+ mobo and ATI Radeon?
 

lokem

Posts: 653   +0
I found a thread which might be of interest to you. The "solution" worked for one member, but didn't for the other. Try it out ;)

http://forums.viaarena.com/messageview.cfm?catid=22&threadid=9568

I have a 8KHA and I have also experienced major lock ups that seemed to happen on random. After experimenting and doing some research, this is what I have found and maybe it'll help you. I have a Radeon 8500 retail on Win XP and no matter what I did, it was locking up on me. Fresh installs, different 4in1's, you name it, I did it. I did the power supply thing too, nothing seemed to help. The only way that I could get the system stable was to limit the aperture size in the BIOS. If I went over 16 Megs, the system would hang. But it wasn't always like that so I was puzzled by this. So, I went back to an earlier revision of the BIOS and the problem went away competely. I am rock solid running my Radeon at 290/290 with a BIOS hack and 328MHz FSB with my Corsair PC2400. It seems that Epox has introduced a new "feature" in the BIOS that seems to cause some AGP instability. I tried to contact them and all they told me was to make sure I have a a right BIOS for that board. From what I have seen, many people have been having problems with these boards, especially the 8KHA+ and from the poeple that sell them, I heard a lot of them are manufacturing faults. So, try out different revs of the BIOS and try the AGP aperture trick. If that doesn't work, then I don't what to tell ya.

Edit: There's also this huge thread over at amdmb.com

http://www.amdmb.com/vb/showthread.php?threadid=86495&highlight=radeon+8500+hang

Seems like there isn't any real solution to this problem. Some pple are just luckier than the other it seems {g}
 

Per Hansson

Posts: 1,974   +232
Staff member
Reducing AGP Appeture size didn't help, neither does reducing any of the other settings in the BIOS to "most stable"

I tried to install an old BIOS dated 09/25/2001, this didn't help either (though the person you refer to is using an even older BIOS; 08/09/01 but I was unable to find it, I've e-mailed him and asked him to send it to me...)

I also tried another thing; Turning off ACPI, I did so, formatted my "test harddrive" put Win98 on it, DirectX 8.1a and the latest drivers on ATI's homepage (the same ones as I've been using all time and that have been stable on the Abit mobo)
Though the computer would crash just as before... (VIA 4in1 driver wasn't even installed...)

But if you happen to know where I can download that 08/09/01 BIOS please give me a call, though I almost doubt there is one because I've found no references to it anywhere...
 

SuperCheetah

Posts: 704   +1
I can't help but to begin to think you got a faulty board or chipset with your board. Have you called Epox or the manufactorer and tried to RMA it yet???
 

SuperCheetah

Posts: 704   +1
Just a thought, but have you tried running Dr. Watson and seeing if you get any type of strange unforseen error that you didn't know about? I doubt it is software related, but it's a thought and about the only other suggestion I have right now. :)

I think if anything on your mobo is faulty it is either the AGP port or more likely the chipset on your board. I wish I knew of a program that could tell you if you had a problem with either of these that was hardware related.
 

Per Hansson

Posts: 1,974   +232
Staff member
I haven't run Dr.Watson, will try it when I get home from school/work

I doubt that it's my mobo that is faulty since with a Geforce3 I can run 8H straight benchmarking without hangs or visual bugs...

Although then it can't be the GFX card either since I can run that on another mobo 48H straight, with no visual bugs then either...

Lokem; I just got back an e-mail from that person, it appears that BIOS is for the 8KHA (not the plus+ version)
And I did try to flash with it yesterday since I found it myself then but that didn't work. (the flasher prevented me from doing so...)

If anyone knows how I can bypass that safety feature in the flasher preventing me to put the "wrong" BIOS on my comp I'd be glad to know how, don't worry; I have a backup BIOS chip in my dead Epox mobo;)
 

lokem

Posts: 653   +0
Oops.. Sorry for not noticing that in the BIOS d/l page. I'll try to look for more info on the topic ;)
 

Per Hansson

Posts: 1,974   +232
Staff member
Right now I'm looking for two things: An even older BIOS than the one listed on Epox site; 09/25/2001

And a flasher which I can flash the "wrong" BIOS to my comp with (see above for reason)
 

Per Hansson

Posts: 1,974   +232
Staff member
Some interesting information: I thought that I should try to reduce the clock speed of the card down to 175mhz like the GF3 TI200 I tested just to make sure that this isn't a frequency problem i.e. that I get "crosstalk" on the AGP port due to the high speed of the card.

Well said but not quite as easy done, all programs I found would only allow me to clock down to 200mhz.
So I thought I'll change the BIOS on the card then, said and done I reduced the speed to 175mhz, but woa! All text became garbled and the "white horse" test in 3dmark was just a big chunk of white boxes spinning around!

So I went back to the original BIOS and thought; why did this happen on a lower frequency? Well crazy as I am I overclocked the card by 5mhz and viola, now the horse spunn almost double the time compared to default speed, at a 10mhz increase I got a hang after just a second though...

Go figure; The visual artefacts weren't removed but I atleast made this case even harder to solve, that's always something ;)
 

Per Hansson

Posts: 1,974   +232
Staff member
I just measured how much current my Radeon gets and the numbers I got are quite low.

The memory was at 3.51v, a Retail 8500 should get 3.65v...

The core was down at 1.61, a "built by ATI" 8500 should get 1,75v

You can read the article on how to do these tests here over at Exclamation

Unfortunantley I don't have my second rig up and running (on which the ATI card ran 48H straight benchmarking) I'm waiting on a new CPU for it, (and hopefully when I get that I can resume the heatsink tests btw...)

On a small sidenote I might add that I tried to remove the fan on the GFX card (and connect it directly to the PSU 7v line) in hope of the card getting more current by this but it hung anyway...
 

lokem

Posts: 653   +0
Hansson, perhaps you can d/l the utility called UniFlash from http://www.pppr.sk/rainbow/programs.html.
I found it at http://www.bioscentral.com/misc/downloads.htm. Here's a synopsis of the proggie:

UniFlash 1.26
Flash anything anywhere

UniFlash (Universal Flasher) is program created by Pascal Van Leeuwen and Galkowski Adam. It was abandoned in 1998 (v1.17b). It was almost dead project, but it LIVES AGAIN NOW! UniFlash supports a wide range of chipsets and Flash ROMs (read uniflash.doc for a list, it's also included in the ZIP package).
Warning: This program is for experienced users ONLY. Improper use of this program (when you flash a WAV file instead of BIOS image to your Flash ROM) or bug in the code (especially with untested hardware) can cause your motherboard to not work. If you do this, I AM NOT RESPONSIBLE for that (original authors aren't too, YOU ARE). To make your motherboard work again, you need to hot-flash your Flash ROM or use external Flash ROM programmer.

Not sure if this proggie works, but it's worth a try.
 

Per Hansson

Posts: 1,974   +232
Staff member
Thanks a thousand Lokem, I'll try out the program when I get home...

Though I already think I have found the cause of my problem (see my previous post)
 

lokem

Posts: 653   +0
Originally posted by Per Hansson
Thanks a thousand Lokem, I'll try out the program when I get home...

Though I already think I have found the cause of my problem (see my previous post)

Just read the link to the Exclamation web page. It's rather yucky to know that the cards aren't built to specs :(
 

Per Hansson

Posts: 1,974   +232
Staff member
Yea I know that the LE cards aren't getting as much current as they should. (That's the reason I bought the Retail card...)

If I now could just get my new CPU home so I can verify this on my Abit mobo... (I.e. that it gets it's full current on that vs my current Epox...)

Btw the flasher didn't work; it didn't support the KT266A chipset but thanks for the trouble in finding it anyway.
 

Per Hansson

Posts: 1,974   +232
Staff member
Ahh, sometimes life is so unforgiving!

I've now run the card on my Abit rig for 44h in a row without a single crash or visual artefact (well I didn't excactly watch it the whole time but you get the point I hope;))

And I've also been measuring how much voltage the card gets and it was whitin 0,01v of the Epox mobo!

I'm gonna trie two things now, one is phone up ATI and ask them if they have any idea on how to fix this, two is to do the "voltage mod" and get the current up where it should be...
 
Status
Not open for further replies.