Epson Stylus Photo 900

By Demolition49
Nov 6, 2005
  1. I put the cd for the printer in and it says please insert the usb from the printer and turn it on... it detects the printer and then installs all the software for it.

    Then when i try to print somthing it will not work... test pages do not work also

    .... it has worked on other computers

    My oporating system : xp pro
    RAM : 512mb
    processor pentium 4 3.06ghz
    graphics card : 256mb ram nvidea

    This sould be more than enough to handle a printer.

    I have also tryed re installing windows from scratch and trying to then install the printer, i still get the same result.

    Cable works, Printer Works , no paper jams etc,Brand new+working cartridges, installed drivers...

    What should i do?????????/ help plz
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Try another USB-port. See if you have both USB 1.1 and USB 2.0.
    If you use a hub, put the cable directly in the PC, it might not get enough 'juice'.
  3. Demolition49

    Demolition49 TS Rookie Topic Starter

    No hub, all ports are usb 2.0 tryed all usb ports
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Try another USB-cable.
    Check that the new printer is set as the default printer.
    What does it say when you try to print, printer not found, or what?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...