Error Creating Registry Key when installing a Utility Program

By wlknaack ยท 5 replies
Mar 9, 2005
  1. I successfully installed Road Runner Medic, a utility program for the Road Runner Broadband Service, for one of two administrators on the computer, but I get the following error message when trying to install Medic for the second administrator:

    Error Creating Registry Key


    RegCreateKeyEx failed; code 5

    Access is denied

    If I ignore the error and continue the installation, Medic is installed but is denied access to the Internet, which renders it useless. Can anyone help me understand this error message? Specifically, what is code 5? I have Windows XP Home Edition.
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    "Access denied" says it all.

    The user you are installing the thing as has no privileges to create that key under HKLM\Software
    You are an administrator, right?
    You can check and change the permissions in registry with the regedt32 tool.
  3. wlknaack

    wlknaack TS Rookie Topic Starter Posts: 143

    Thanks Nodsu for your help.

    There are two people on the computer and both are administrators, so I do not understand why one of them is denied access.

    I checked the Registry under that administrator's account with the account set as "administrator" and then set as "limited," and in both cases I could not open "" and got the error notice: Error while opening key. There were other folders I could not open and received the same error notice. All the folders had the same thing in common: They were associated with programs which were not installed under that administrator's account, but were all installed under my administrator account. If I could install Medic in that administrator's account, I assume this would go away but, as I outlined in my initial post, I cannot get a clean install.

    Therefore, if you are correct and, for whatever reason, Windows has denied access to that administrator, can you instruct me as to change that in the Registry? I do not know how to do that.

    Again, thanks for your reply to my post.

  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    In registry navigate to the key you are having trouble with and right click it. Select permissions and set them any way you like. You may need to set yourself as the owner of the key first to able to change it.
  5. wlknaack

    wlknaack TS Rookie Topic Starter Posts: 143

    Nodsu: Problem Solved

    You were "spot-right-on" in your diagnosis of, and solution to the problem. I went in and edited the "permissions" for the "" key and the utility program installed, but gave me another error warning regarding another key: "SupportSoft." Once I edited the permissions for that key, everything was OK. Thanks.

    As a note aside: I noticed that there were other keys in the registry for which the administrator did not have permission. I download and/or load and install all software under my "administration," and it would appear to me that some, but not all, programs do not automatically establish permissions for the other administrator. Is this a fair assessment?
  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    My bet would be that some installers don't bother themselves with permissions at all and the access controls for any keys will remain as they are set by Windows.

    Don't know if it is possible to tell Windows to create keys with permissions for both administrators.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...