1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Error Loading Operating System - XP

By Fuzzylogik · 12 replies
Jan 30, 2006
  1. Howdy all. I was hoping someone -- ANYONE -- could help me with what has become the bane of my existence!

    Long story short, my first SATA drive, a Maxtor 6B250S0 died a few months after I got it, and was covered under warranty. Upon receiving the new drive, I wanted to GHOST (v10) the old EIDE ATA Drive onto the new SATA drive. The operation succeeded except I could not make the new SATA drive the system drive. I eventually gave up and decided to rebuild the system. I mention this only because I was able to successfully move all the contents of the old drive onto the new one (and I could access and manipulate the files, I just couldn't boot from the disk) -- the consistent problem was that after navigating the BIOS on boot up, I would receive "Error loading Operating System" when the OS should have taken over.

    Now to my existing problem. Actually, the same problem. I have killed the existing partition and low-level reformatted the drive. After copying all of the XP files onto the hard drive, I'm getting the same error -- "Error loading operating system". Here is what I have tried in no particular order:

    1. Fixboot
    2. FixMBR
    3. Tried using Maxtors MAXBLAST to establish the a full 250 GB partition (running original XP disks; not SP1 or SP2)
    4. Tried utilizing standard 137 GB partition via XP
    5. Removed all EIDE cables except those utilized for CD-ROM/DVD access
    6. Diag'ed the disk using Maxtor's Powermax (it's fine according to the diag)

    I'm tapped. No matter what I've tried, it does not appear to want to be anything other than a slave drive, EVEN THOUGH THE BIOS LISTS IT AS A MASTER DISK (and it is installed on SATA 1 on the MB; ASUS A8N-SLI Deluxe). It currently is the ONLY HD that is installed on this computer. The kicker to all of this is that the original SATA HD that eventually failed never gave me any of these installation problems, so I don't believe that it is related to SATA problems on the MB.

    Any ideas/suggestions on what God I can sacrifice to in order to get this thing bootable??? :hotouch: Thank you in advance.

  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Does the BIOS actually try to boot from the drive? Maybe you have to tell it to boot from SATA? Did you perform the fixboot and fixmbr procedures with only the SATA drive attached too?
  3. Fuzzylogik

    Fuzzylogik TS Rookie Topic Starter

    I have tried to boot the SATA drivers at the f6 prompt when XP is loading -- to no avail. I'm not sure if I know how to answer if it actually attempts to boot from the drive. Basically, at the handshake when the BIOS hands over control to the OS, I virtually immediately receive the error. If a CD is in the drive (ie XP OS), it will give be five seconds to manually select whether I want to boot from the CD. If I let the timeout go uninterrupted (to boot to CD) it immediately gives me the "Error loading Operating System" and stops, so in a sense it does not appear to attempt to boot. Yet the BIOS indicates that it is the Master SATA and is indeed the only HD in the computer.

    I cannot tell you how many times I have loaded OS's onto computers (literally hundreds if not thousands of times) and I have never seen anything like this. My gut instinct is that it is another failed HD, yet it can be written to, and I suspect that if I slaved it, it would work fine in that capacity right now (based on previous experience with the drive). It just does not want to boot for some reason.

  4. iss

    iss TechSpot Chancellor Posts: 1,994

    to use Sata you have to have at least SP1

    you can create a XpSp2 disk by using your original XP disk and using a utility like Nlite to slipstream SP2 into it. it's very simple.

  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You should see the HDD LED blink when the bootsector is loaded from the HD.
  6. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    set the bios to optimum defaults
    and try loading OS and drivers again
    sounds like it's the bios setup not booting the drive
    the bios has to see the sata drivers first to boot the drive
    you may have 2 areas of boot config
    my intel uses 2 diff bios boot option windows
    american megatrends
  7. Fuzzylogik

    Fuzzylogik TS Rookie Topic Starter

    I DL'd and installed nLite -- love the program! Unfortunately slipstreaming SP2 was not helpful. I know SP2 was successfully loaded because XP now recognizes the entire 250GB partition. Like before, however, it loads just fine until it reboots and then I receive the dreaded "Error Loading Operating System".

    Samstoned, I'm not sure what you mean by optimizing the BIOS. Right now I have two EIDE controllers (listed first) and two SATA controllers (listed afterwards). There is no way to prioritize one controller over another. I'm starting to miss the pins on the back of EIDE HD -- at least you could FORCE them to communicate in a way you wanted them too. (BTW, does anyone know what the two pins on the back of the SATA are for? Can't find that info). Further, when looking at the boot sequence, it only boots generically to HD, CD/DVD, and Floppy. There is no way to specify a specific HD, for instance.

    My BIOS is Phoenix-Award (always hated Phoenix, loved Award -- apparently Award got the short stick when they merged). I flashed the BIOS a few days ago when I originally ran into the Error Loading Operating System hoping that would take care of it -- to no avail.

    Any other suggestions?

  8. Fuzzylogik

    Fuzzylogik TS Rookie Topic Starter

    Problem figured out! The problem -- believe it or not -- is that the HD wanted to defined as LARGE versus AUTO. I cannot take credit for this, so here is the reference where I found the solution:


    Thanks to all who tried to help brainstorm.

    Best regards,
    Fuzzylogik :hotbounce :hotbounce :hotbounce :hotbounce
  9. iss

    iss TechSpot Chancellor Posts: 1,994

    Glad you got it sorted out. And thanks for posting the solution that is good info to have.
  10. naivetech

    naivetech TS Rookie

    Error loading OS - XP; how to change BIOS setting to large


    I am trying to install XP (full version with SP2) on a new 300gb SATA hard drive in my Dell Optiplex GX520 (am replacing an existing hard drive which was 40GB). I would like to try the option 1 in the article posted by fuzzylogik


    How do I change the BIOS setting of my machine (Dell Optiplex GX520) --- change the translation method used to access the hard drive from the default setting “Auto” to “Large”

    I can only get to F2 (Setup) or F12 (Boot Menu) during bootup process but I do not see an option to change the translation method.

    Can some one shed light on how I could try doing this?

    thanks in advance
  11. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    That article refers to (ancient) IDE drives. The addressing settings are irrelevant for SATA.
  12. itch77

    itch77 TS Rookie


    Hello Fuzzylogic and others. This is mid december 08 but as I spent over 3 stressful nights on this error message upon trying to install windows xp on my new sata drive, I feel compelled to report back that the final 'trick' that made the installation work was, indeed, the switching of my SATA drive ACCESS MODE setting in Phoenix Bios from AUTO to LARGE. Thanks be to the internet forums & all such as you! :)
  13. WillyCool

    WillyCool TS Rookie

    Three years since this thread was started and it is still useful. Thanks for the info guys. It worked like a charm..
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...