Errors partitioning/using usb flash drive

By klopapier
Dec 27, 2007
  1. Hey there,

    i bought myself 2 weeks ago an 4gb emtec usb flash-drive but i'm having some problems now i don't understand. Ok so, i use it just to storage music because it's for my cars radio.
    I started it using first under suse 10.3, copying on it a music folder from another stick.

    I've been experiencing some reading problems on the radio, i use an external usb-reading-device connected to it and it sometimes got stuck reading out whats on it.

    Besides on the computer i've tried to delete what is on it to store more music and at first it copies well, but when i try to play those moreorless 450 files i only get to see 1 folder (4copied) and only about a 100 files.
    When i stick it in the computer to see what wrong i see the storage capacity of ALL files i copied used, but when i open it i see that i only have 1 folder and half of the files are not the new ones i copied, but like 40 or 50 copies of 2 or 3 files, all the same.

    I get errors deleting them on windows as well as on Suse. I've tried to format it but it doesn't solve anything. I've tried to delete and to create a new partition with fdisk on suse but i don't manage to write it to the partition table since i get an error i don't know what to do with:

    "Command (m for help): w
    The partition table has been altered!

    Calling ioctl() to re-read partition table.

    WARNING: Re-reading the partition table failed with error 22: Invalid argument.
    The kernel still uses the old table.
    The new table will be used at the next reboot."

    Can anybody help me out with this?

    Thanks in advance.
  2. klopapier

    klopapier TS Rookie Topic Starter

    the story goes...

    Since my computer crashed the other day when i tried to fix my non-working mobile phone cable touching the metal pins with a metal piece while being conected (d'oh!! - i know), i thought that maybe my mobo could have got any damage, so i tried to copy the files from a laptop but i get the same stupid problem.
    I've run the "HP USB Disk Storage Format Tool" and "dskchkr32" with no luck.

    What can i do?

    P.S.: I kinda remember having to delete 4 partitions when having seen only 1 with "fdisk -L" when re-partitioning it on Suse; Maybe that could be a problem or maybe the solution...
  3. klopapier

    klopapier TS Rookie Topic Starter

    And it gets even worse...

    i've been messing around with"qtparted" now but i to get it to work. I thought i could make 4 partitions of 1gb each instead of 1 big one, but that doesn't seem to work either since there is an error and the program closes when i try to make the third partition. It also seems to get stuck when doing all 4 partitions and committing the changes after this.

    Now back in Suse i got those 2 partitions i could make recognized as 2 separate removable drives. I copy 1gb of music into the first one and no problem, just enormously slow for USB 2.0 (250KB/s - 460KB/s moreorless).
    When i try so with the second it starts the copying process (with a very slow transfer rate again) but it goes down more and more until it reaches 0 and then it says "stalled". I get an error message that a certain file could not be copied and both partitions mount themselves again (like i would stick it out and put it back in).

    Kinda weird...
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Do you feel alone here?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...