External hard drive not recognised

By shells · 7 replies
Feb 8, 2007
  1. Thank you in advance to any help I receive. Here is my story...

    My Versa NEC E2000 notebook has had several problems under warranty since purchased under lease 2.5yrs ago - it's had 3 hard drives and 1 motherboard replaced under warranty. NEC advised a global replacement program for the battery.
    So I had my hubby undo the base of the computer to check out whether my battery part number fell into the range requiring replacement, which he did so that I could submit it to NEC for replacemt Since then (don’t why seeing the 2 areas aren’t connected?) my DVD/cd drive has been faulty. It intermittently will not read cds/dvds and won’t write new discs PLUS it makes this awful “whirring” and “scraping noises” when you press the eject button & close unit (whether disc in it or not) or upon start-up.

    Basically I couldn’t rely on it & because it was similar to problems that occurred when I ended up with the other warranty repairs I began to freak I would lose my data & programs. I had a small portable external hard drive which I kept as much pictures (semi pro photographer so I have 1000s of digital files) and business data on as possible - I had tried backing up to it but it wouldn’t take the everything on my notebook plus the stuff already on small drive. Seeing I couldn’t write stuff to cd/dvds we decided to go and buy bigger external hard drive. (I have virus/adware/spy scanning in place & used to backup to discs and/or my small external drive)

    So 5 days ago I purchased a Maxtor Personal Storage 3200 external drive thinking there would be no way I would ever run out of space then & could have regular backups timed to it off my notebook as well.

    Day 1 went well - I moved the data off my small drive to it (so I could use the small one for backing up amended files when I travelled with notebook for work reasons) I checked stuff regularly & all looked good & was useable from the new home & the transfers and copying was quite speedy. I then started transferring data off the notebook c drive to it as well - thinking by doing so I would speed my notebook up a bit plus THE BIG WORRY in the back of my mind was that the notebook was about to go physco again & therefore I wanted to get all important stuff off it before I had to track a NEC warranty agent down (previous crashes occurred whilst I lived in diff. state).

    Day 2 I thought I really should be backing up just in case my notebook does crash
    So I put a Windows backup for my c drive into play before going to bed that night. The next day it was still going and was telling me it would take another 2 days to complete. This blew me away a bit but I left it going and went shopping. Whilst out I purchased a few PC magazines hoping to get a bit more insight into better backup options. When I came back to the machine late in the day it still showed 1 day and 17 hours to go. So after reading about different backup programs & talking to my husband that night - I decided to stop the windows backup & I deleted the partial content from the Maxtor drive with the intention of installing another program to do backups.

    BUT that is when the .... hit the fan. It took approx 20 trys to get my cd reader drive to work and install paragon drive backup (cos I thought with 3 drives it would be handy to choose which drive to backup and to be able to backup the structure I had set up after so many rebuilds with this computer). When I did get it downloaded & ready to use I then went to setup the backup to find that the Maxtor drive couldn’t be located to send the back up there. I went to my computer & it was as if it didn’t exist. Though prior to the windows backup I had my computer opened several times whilst transferring data from 1 drive to another and it was always there then.

    So I did the basics of closing everything down and rebooting system; unplugging the Maxtor drive and starting again; shutting down and turning everything off even unplugged everything from each other and surge protector and left off for few hours then set it all up again and tried again (read about residual current and heat factors causing problems).

    I tried the Maxtor drive in different USB ports - even on a different notebook computer but the result was the same. It would click to announce connection but then pop up a message that the device would work faster on a USB 2 port and click here for list of ports etc. or driver not held. Didn’t do that previously though. If I had the Maxtor drive connected and tried to open a new folder or program it would just slow right down then lock up so that I would have to force a shut down or unplug the Maxtor & if I had it connected upon restart it would just hover on the screen after the logon start-up music. However if I unplugged the Maxtor, the system would speed back up & start-up as per normal. If my computer was open on screen before I plugged in the drive and then I plugged it in (it would not show the drive) but then unplugged it again the Maxtor drive would flash on screen then disappear. Intermittently the notebook would say that there was no driver for the item plugged into the USB port (my interpretation of computer words) but if I went to the driver and checked windows trouble shooter it said it was operating correctly & that the drivers held were the best available.

    I do not know if my computer is to blame or the Maxtor drive is faulty or if I somehow caused the problem – I have stayed up at night with worry that I accidentally deleted all the data off the Maxtor however I logically cant see how I could of made the drive not work etc… when I hit delete (which I am 98% certain was highlighting the windows backup icon only & even then that file was in its own folder separated from the other transferred files and folders). Its just that everything was operating ok prior to me cancelling that backup (if you ignore the dvd/cd drive probs and battery and past history that is), though I cant understand why the backup was going to take days when previously it has never take more than a hour or 2 with much more data on the c drive.

    I got extremely worried I was going to lose the data already on the Maxtor as well as what was on the notebook c drive so I pulled as much off the c drive as possible using the small drive to transfer to another computer and I used the Paragon program to make a backup capsule of the c drive on the notebook itself (which meant most the memory I had on it was taken up again).

    I then started trying the SEAGATE trouble-shooter (as I found out Maxtor was bought out by Seagate and therefore none of their support sites/numbers work anymore). I tried the windows does note see my drive options first. http://www.seagate.com/ww/v/index.j...toid=5d824a3cdde5c010VgnVCM100000dd04090aRCRD
    My device manager shows the Maxtor and the USB mass storage where they should be & without the yellow/red marks that apparently determine a problem.
    However my disk management would only open if I had Maxtor disconnected. The C drive listed as healthy. If I plugged Maxtor back in it shows nothing but if I then unplug it and replug it quickly shows Maxtor (I) drive then it disappears. It never showed any status or file information though. I had the right XP service pack 2 & when I checked the USB controllers in the device manager I had an Enhanced listing amongst the controllers as the Seagate site said I should.

    I found a download for Personal Storage 3100 diagnostic utility & tried that but it found no errors. I have tried all the windows trouble shooting for the device/driver EXCEPT uninstalling and reinstalling the driver.

    Although Seagate had it as a trouble shoot item - I haven’t defragged the system as yet cos my hubby said it can sometimes lose data (I don’t want to lose the data on either drive if possible but most definitely not the Maxtor, as it has stuff that I have no copies to on it – yeah I know that is stupid) Seagate had a section on defrag and a generic drive test I could install etc – but seeing it was Seagate not Maxtor & I wasn’t sure about defrag I haven’t done this.

    So I have checked the power and cables, removed hubs and tried every port and used other cables and other computers. Checked my device manager and the drive seems to be detected and configured properly. And the Maxtor drive still will not appear on my computer or the disk management section + I cannot access the data that was placed onto the drive.

    Though once when I looked at the properties for the Maxtor drive in device manager it said no driver held (which matched a message that came up a few times when I reconnected the drive to the notebook) but then 5 minutes later it changed its mind and listed a driver and that it was working correctly?

    The only other thing I can tell you is that when my husband connected the Maxtor to his work computer 2 days in from initial problems, after a while it did show up on his My computer as a drive but it stated that the drive was empty. (465Gb free of 465 storage – though box said 500Gb size my computer did say 465Gb at the beginning) I did not know the exact amount of data I transferred but I know it was in excess of 80Gb being that it had all from the small drive and some from my notebook c drive on it prior to be attempting the backup. I did think strange that it showed up on his drive and not mine (which it still doesn’t) but more scarily it showed on data held!

    Now after all that rambling to which I apologise for (just blame it on my oversensitive aussie female nature) I am hoping someone out there can help me work out what is going on and fix it or at very least recover my data.

    So far my extra storage purchase which was made to help make my system more safe has cost me $ time & much heartache and tears! Any help, tips, advice will be greatly appreciated.
  2. shells

    shells TS Rookie Topic Starter

    Me again - I decided to try once more plugging my maxtor drive in... and guess what it turned up on my device manager this time stating 465.76 Gb space 100% free. This has shocked me being that I have attempted this approx 10 times prior to posting during the day and NOW it shows up. The drive has been making noises ever since (10mins +) but it doesnt show up on my computer still. Please please help me. I am going crazy here wondering what the heck is going on. If i have to return the maxtor under warranty and my NEC under its extended warranty then fine - but i really want my data back first.
    Wishing for a computer angel.
  3. N3051M

    N3051M TS Evangelist Posts: 2,115

    right click My computer >manage > Disk Management.
    Look for the maxtor drive there, and right click it to assign a letter to it.
  4. shells

    shells TS Rookie Topic Starter


    Thanks for the tip
    However when i do open disk management up with the drive connected it takes approx 40 mins to show on screen and when it does it has a letter "i" assigned to it already.
    My notebook hard drive is called Disk O and Volume HDD (C) and the Maxtor called Disk 1 and Volume (I).
    Both say healthy and active. But the Maxtor drive says its empty and it should have at least 100Gb on it.
    I can highlight the drive "I" and right click.
    When i try to right click OPEN the drive starts to make noises and the computer management screen goes blank....
    Previously when this happens i have had to dissconnect the drive to get the screen to unlock again.
    Should i attempt to change the Volume number?
    I am unsure i will be able to do it but would it make any difference?
  5. N3051M

    N3051M TS Evangelist Posts: 2,115

    what type of noises? scratching or crackling, screeching or just spinning etc?

    i don't know what volume number would do, so i have no clue what will happen..

    i have a feeling it could be your HDD may have the problem with its controller or some electronics or if its in the connection to your PC.. theres a few tests you can do to determine whats what..

    - try a different USB cable, making sure you're using a USB 2.0 spec'd cable (yes, apparently there's some odd difference between 1.1 and 2... don't ask)
    - try on a different PC. Save a file on the HDD then shut it down/disconnect. Reboot the HDD and check the file for its integrity. if ok, disconnect the HDD and plant it on another PC or your laptop and see if you can get to the file.
    - try downloading a live OS CD like Knoppix or Ubuntu CD and see if you can see it through there, as well as view the file if you've done the test before first.

    I want you to try a program called CCleaner. I don't know if it will help your situation, but just incase its part of some registry error (provided that the "other PCs" test was successful) this will clean up some of them.
  6. Failsafe

    Failsafe TS Rookie Posts: 21

    I have the same HDD - a Maxtor Personal Storage 3200.

    In the 3 months that I have owned it it has "vanished" twice from my system.

    I tried looking in disk management , checked for drivers etc at their website and also downloaded the 3100 utility.

    Nothing worked.

    Yet on both occasions after leaving it unplugged for 48 hours or so then plugging it back in it would miraculosly reappear.

    The last time it went down was about 4 weeks ago, just after plugging in a PSP into the USB port next to the 3200 USB.

    Can I ask Shells, did you unplug the drive after selecting safely remove hardware or do you just remove the USB lead, or while the PC was turned off ?

    I don't have a lot of confidence in this drive and regret buying it.
    Just try doing nothing with it for a couple of days and see how you go .. i know this doesn't sound like the most scientific answer ... but it has worked for me twice !!

  7. shells

    shells TS Rookie Topic Starter

    Thankyou both for input.
    1) The drive noise is a grating sound like the spinning mechanism is catching on something (even when no disc) though it all looks ok. Plus an intermittent grinding noise and squeeling occurs too. When I have no problems it is fairly quite. The drive hasnt read or written anything for many days now. So I am pretty sure my notebook computer has operating system probs (similiar to previous warranty repairs -see first post)
    2) I have on several occassions tried different USB ports and cables with and without my Belkin USB 4 port minihub. It doesnt seem to make any difference. My other external hard drive still works fine with any cable. I have tried the maxtor drive on 2 different computers and it is as slow to show up on disk management/or doesnt show at all depending on the attempt. (see first post for explaination) Neither machine ever gets the data to show.
    3) how do i locate the knoppix or ubuntu or ccleaner? Will they be any use if i cant keep my system from slowing/locking up when the maxtor drive is connected?

    I have just purchased a Seagate 250 external drive usb 2.0 planning to use it to back up the remainder of my notebook data in case something further goes wrong with it. So i will try that cable with the Maxtor to see if I can get any access.

    I am glad to hear someone else has had problems in a perverse way it makes me feel better that maybe its' not my fault! Though a miracle answer would have been great.
    As I mentioned in previous posts - I did get the system to acknowledge the drive partially after shutting down and disconnecting everything for entire day - however it has never become operational.
    As it has been untried for about a day I will try again with new cable...

    I have not been using the safely remove hardware icon though the properties for the drive did have the option for disconnecting the drive without using the S R H icon, so I assume that I was ok unplugging it? There was no instructions or manual with the Maxtor drive when i unpacked it and I was redirected to Seagate site each time I attempted to web info for Maxtor. I didnt realise just unplugging could cause problems (it worked fine for 2 days and I always used my other small external drive that way (it was made in computer shop not a brand name drive). I have just attempted to use the safely remove icon to disconnect the small drive and it says I cannot and should try again later? though its not being used?

    I wonder if I should just try to backup what i currently can access on the notebook onto the Seagate and then take the Maxtor to a file recovery business to see if there is any chance of saving the data and take both the Maxtor and notebook to respective warranty agents?
  8. N3051M

    N3051M TS Evangelist Posts: 2,115

    hmm.. the grinding noise doesn't sound too good.. usually (applies to all HDDs) its just a 'whirr' and the occasional seeking sound when its looking for something..

    CCleaner you can google for.. lemme try and get the link for you.. here: http://www.ccleaner.com/download/
    Ubuntu and knoppix are linux OS that can be run straight from a CD or dvd, so this is helpful to ruling out if its hardware fault or otherwise. (if it can be read in there, then it would be a windows problem, if it still can't, then its probably hardware). Again, you can google to get a download for them or look through some PC magazines' attached CDs etc, then burn it to a cd then boot off it.

    I have a feeling that your laptop has no current problems at the moment, since you're able to read other forms of media, and that this sort of problem is usually symptoms of a failing HDD. If you still have warranty on the maxtor, send it in for replacement or repair etc. You can take it to a data recovery center, but be warned that it could cost a bit over what you'd think it would be.. anywhere between $500-2000+ depending on how bad it is...

    backup your data to your new seagate is probably a good idea..

    You should start using the Safely remove hardware icon before taking out things like HDD or flash drives, not only since its good habit to do techwise, but also even if USB is designed as "hot-swappable" sometimes there are delayed data transfers going on through between the PC and the device and even if it says its finished its probably a few seconds premature, so chances of corrupt data increases..
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...