External USB 2.0 HDD Problem

By Azmodaii
Aug 16, 2007
  1. Hello,
    I have owned a Toshiba 80GB external USB hd drive for over a year now and it has worked perfectly well at all times for me until recently. I reformatted my computer about 3 weeks ago and installed windows etc. and everything perfectly. Most of my backup stuff was on the hard disk so I accessed them without any problems and set up my new computer... I then went on to install some of the drivers i didn't have on me from the internet and run ms update, this is when everything started to go wrong...

    All of a sudden out of no where, my portable hddisk started to give write errors. I would get a notification saying "error, unable to write date" or something of the sort onto my hddisk drive and now whenever I plug my portable hddisk in, my computer does not recognise it. Sometimes it will not recognise it at all, sometimes it will recognise it, give a write error straight away and disable itself. Sometimes when it recognises it, if i write or copy a file onto my pc or to the hddisk immediately it works normally, but most of the time the hdd drive is not located at all.

    I tried going into the device manager and updating the drive to no avail, sometimes it will have a yellow exclamation mark next to it while most of the time it does not even show on the device manager.

    I have no idea how everything went wrong, there were no virusus or anything, the hddisk works PERFECTLY fine on my brother's desktop and my two laptops. I also tried plugging in my brothers USB hardisk and that didn't work either. I tried changing the cables, plugging in both, tried different usb jacks nothing works at all. I even rewired my USB ports inside the pc to make sure but nothing works. My flash drives work fine, my usb devices work fine, its just USB Mass Storage devices that will not be recognised or get write errors.

    Please help me out. I am on a Pentium IV 3.0GHz prescott with 2gb ram and a 160GB SATA hddisk. There doesn't seem to be any conflicts with any devices in the machine. I am running windows xp pro and its fully authorised and updates properly and everything...

    Please help me out. I tried to explain my problem as clearly as possible but nothing will work.

    p.s: I also tried setting the hddisk property so that I do not have to select "remove safely" when I unplug it (forgot the name of that function) but it doesn't work either, tried both options. I also tried changing the registry setting to enable that very function but it didn't work either (the registry change was suggested by every tech site with relation to the HDDISK write error).

    Its a lengthy post but i tried everything. Please help. thanks.
  2. Azmodaii

    Azmodaii TS Rookie Topic Starter

    Upping this topic after a while...

    After reading countless forums and trying everything in my hands I reformatted my harddrive and made a clean windows xp install... My computer is fresh and new right now and When I plug my Toshiba external hddisc into the usb port it is not readable, flashdisks it reads fine, but my hddisk it won't. Please help me resolve this problem... thanks.
  3. Fragrant Coit

    Fragrant Coit TS Guru Posts: 363

    This worked for me once - very similar problem.

    Go to Device Manager, Right click on the USB Controller /s and uninstall them.
    Sometimes there's a lot of them, but uninstall the lot.

    Reboot, let windows find & install them again, reboot and try your HDD.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...