'Failed to connect to a windows service' problem?

Status
Not open for further replies.

jabs1090

TS Rookie
Hi, I have been trying to fix my laptop from earlier this morning and it seems a new problem keeps arising. I really need help.

First: I've had the 'NetWorm-i.virus@fp' problem, and I have tried coutness Anti-Virus and Anti-Spyware software to get rid of it, and it hasn't worked. But for some reason, when I was uninstalling CA Anti-Virus software because it hadn't worked, the computer froze and I had to turn it off and back on again. When it rebooted, the error message stopped popping up. Also, a 'Failed to connect to a windows service' message pops up instead after start up. When I type in my password for my user account, it takes about 5-7mins to actually display my screen, after going showing a black screen for about 3-4mins out of the 5-7mins.

The message says: 'Failed to connect to a windows service: Windows could not connect to the System Event Notification Service service. This problem prevents limited users from logging on to the system. As an administrator user, you can review the System Event Log for details about why the service didn't respond.'

Secondly, I downloaded AVG Anti-Spyware and ran a scan while in Safe Mode and a 'Trojan.Obfuscated.en' was found, and I quarantined it. But the 'Failed to connect to windows service' message still appears after start up.

Thirdly, for some reason, when the 'Failed to connect to a windows service' message started appearing, my wireless has stopped working. I can recieve a signal from my PSP and another laptop, but not the affected laptop.

Also, I try to use 'Windows Help and Support' but it won't work. And I can't go to the URL the error message gave to me since my wireless isn't working.
 

grimesy69

TS Rookie
ok,

Boot in safe mode and login under a local adminstrator account.

Right click My Computer and click manage, up will pop up a computer management window, in that window double click Services and Applications and then click Services.

In the list of services scroll down to "System Event notification" and double click it. The properties for this Service will then display.

Make sure the start up type is set to Automatic and make sure the Service status is set to Started.

After you have done this click "Event Viewer" in the far top left of the screen and click "System". This will bring up the logging of events in which have happened on your machine. This can help us determine whats causing the error.

So click "Action" on the top toolbar and click "Save log files as," save it somewhere and then upload it in your next post. Do not copy and paste it.

Reboot your machine see what happens.

Regards,
 

baaldox7

TS Rookie
hi, it seems that i have the same problem that jabs1090, my problem started when i tried to connect to a friend Ethernet connection (in my house I have a wireless router and it works with my computer), well, i cannot connect in my friends house, a message in my anti virus (Kaspersky Internet Security) appeared and I block some of them, later i went to my house and i couldn't connect to the router. I tried with diagnose and repair and it says that the wireless option is off, but it is on on my computer.

I say that is the same problem that jabs1090 because the same message appeared, and the same things happened to me, like the black screen like 4-5 min.

I tried the steps that grimesy69 says, but when I start in safe mode, when I try to start "System Event notification" it says that it cant be started in safe mode, and when I turn it on in normal mode, the status says starting, never started.

I have windows vista and I don't know what to do. I would be pleased if you can help me.
 

Bobbye

Helper on the Fringe
For the Service: Windows XP
Boot into Safe Mode> Control Panel> Administrative Tools> Services> Right click on System Event Notification> Properties> change Startup mode to Automatic. Do NOT attempt to start the Service.
Make sure the Event Log Service is also set to Automatic.
Reboot into Normal mode and this Service should start.
http://www.theeldergeek.com/services_guide.htm#Services

For the Event Viewer in Windows XP: Follow this path:
Control Panel> Administrative Tools> Event Viewer> Click on System & Apps, one at a time on the left> look for Errors on the right> right click error> Properties> note description of error, Event# and Source.

There is a "copy" button below the up/down arrows. Click that, then paste (use CTRL-V) the event details here. It makes for easy reporting of the event-you do not need to include the lines of code that follow the Description-but paste all else.

You will be looking for Error that occurs at the time of the problem. Please ignore Warnings. If you have multiple Errors with the same ID#, the same Source and the same description, only one of each is required.

For the Service in Vista:
Boot into Safe Mode.
Control Panel> Administrative Tools> Services> right click on System Event Notification Service> set startup mode to Automatic. Do NOT attempt to start the Service.
Make sure the Event Log Service is also on Automatic.
Reboot into Normal Mode. The Service should be started.

For the Event Viewer in Vista:
http://www.windowsnetworking.com/articles_tutorials/Monitoring-Event-Logs-Windows-Vista.html
Please observe the same guidelines for reporting: ignore Warnings, only one copy of recurring identical error.
Copy button is on lower left.
 

baaldox7

TS Rookie
thanks for answering, i did the stuff that bobbye suggested, I started in safe mode, and the system event notification and windows event log were both in automatic start. I reboot in normal mode and the problem persist. What I should do?
 

Bobbye

Helper on the Fringe
baaldox, you cannot assume the problem is the same because you get the same message!

"connect to a friend Ethernet connection". Please explain what you mean by this. It sounds like you are attempting to connect to someones wireless connection, other than your own. Not only is this illegal, but it doesn't necessarily work just because you have a wireless router.

"a message in my anti virus (Kaspersky Internet Security) appeared and I block some of them" What message? What do you block?

"later i went to my house and i couldn't connect to the router." What did you do to the router trying to connect to someone else's wireless connection?
 

baaldox7

TS Rookie
sorry i am Mexican and i trying to explain my problem the best i can, and i`m not very good at computer things.

My friends computer burned and he wanted to connect to the Internet, so I went to his house and connected my laptop to his Ethernet cable.

When I connected his cable to my laptop a row of messages started to appear of my antivirus, that if i wanted to change some programs, I didn't pay much attention because it always says something like it, I accepted a lot of them, but because they didn't finish, I denied some of them.

I didnt do anything to my router, I just came home and tried to connect to my wireless router like always, but i couldn't,
 

markiepoos

TS Rookie
Hey

I have the same problem as baaldox

Kaspersky popped up asking me to allow or block some things that i htink might of been related to system32. I allowed most of them but i blocked some of them because they kept popping up and I didnt know what they were.

I never connected to my friends ethernet, all I did was turn my laptop on and a system event notification popped up and it wont let me log on with limited users and it carnt find any wireless routers.

Need help :(
 

tw0rld

TS Maniac
This is real simple, but i have found that a lot of the times we tend to over think things. Try disabling any firewall software that you have running and see if you can connect. It sounds like you blocked something that you should not.
 

Bobbye

Helper on the Fringe
Post Separately

Hey

I have the same problem as baaldox

Kaspersky popped up asking me to allow or block some things that i htink might of been related to system32. I allowed most of them but i blocked some of them because they kept popping up and I didnt know what they were.

I never connected to my friends ethernet, all I did was turn my laptop on and a system event notification popped up and it wont let me log on with limited users and it carnt find any wireless routers.

Need help :(
Please start a new thread with your information. This thread you are on is over 6 months old. Do NOT turn your firewall off to all access. We will help you learn what is trying to access and help. Give us that current information on a new question, starting a new thread.
 

markiepoos

TS Rookie
The Fix!!

Try this...

Start computer in safe mode.

logon on to administrator.

Click the start button

Search "cmd.exe"

Select it and then "ctrl - shift - enter" to allow elevation request

Type in - "netsh winsock reset" press enter

Then Restart your computer

...Mark... :grinthumb
 

tengri

TS Rookie
Thank you

I would like to thank Markiepoos, all day I was looking to fix this, Services could not connect but now I have only 1 problem: it is the Windows Image Acquistion service " There is no application registered for this event" I press closed and it pops up back, Hey at least I have Internet now on the main computer :) I was just wondering what It could be.

Before the problem I never seen that type of error. As soon as the problem started, I had this Windows Image Acquisition Serivce error, fixed the problem with your winsock reset and it is still there.
 

Bobbye

Helper on the Fringe
now I have only 1 problem: it is the Windows Image Acquistion service " There is no application registered for this event"
Although technically I don't have enough information to troubleshoot this, I will make this suggestion: Put this service on Manual:

Start> Run> services.msc> right click on Windows Image Acquisition> Properties> set Start up Type to Manual> Close and reboot.

Be careful that you choose WIA as there are several Services beginning with word 'Windows.' This is a good ans safe setting.
 

markiepoos

TS Rookie
Tengri

Windows Image Acquisition Serivce error...

Try...

You need to click... "Start"

Search for... "Services"

Once found... Right Click and select "Run As Administrator"

Scandown till you find... "Windows Image Acquisition (WIA)"

You then need to Right Click on it... select "Stop"

Then Right Click on it again and select... "Properties"

Start up type as... "Disable"

Reboot

...Mark... :grinthumb
 

kimsland

Ex-TechSpotter
Windows Image Acquisition (WIA)
Used for some scanners, web cams, and cameras. If, after disabling this service, your scanner or camera fails to function properly, enable this service by placing it into automatic.
 

BloodySpoon

TS Rookie
Thank you!

Try this...

Start computer in safe mode.

logon on to administrator.

Click the start button

Search "cmd.exe"

Select it and then "ctrl - shift - enter" to allow elevation request

Type in - "netsh winsock reset" press enter

Then Restart your computer

MarkiePoos you ROCK! thanks so much, I was spending hours of touble shooting on my own and decided to search, this is the second place I found and your post fixed EVERYTHING thanks so much.

...Mark... :grinthumb
 

Bobbye

Helper on the Fringe
And just for the record, so someone doesn't get into trouble, using information that had been given to someone to fix their specific problem is risky. In this case, it happened to have worked for another. But that isn't always the case, so be careful.

Netstat commands can be invaluable. But you have to know when they are indicated, which one to use and how to read the results.
 

mornington

TS Rookie
Thanks markiepoos

Worked great. I had no idea what to do. So thanks markiepoos... This will not be the last time someone Googles this thread.


Try this...

Start computer in safe mode.

logon on to administrator.

Click the start button

Search "cmd.exe"

Select it and then "ctrl - shift - enter" to allow elevation request

Type in - "netsh winsock reset" press enter

Then Restart your computer

...Mark... :grinthumb
 

Bobbye

Helper on the Fringe
Hopefully someone will close this thread now before someone else posts on t! It is a year old and has directions from multiple people to multiple users! It is good to search old threads for help, but not to post a new problem.
 

Sophia

TS Rookie
Giving credit where credit is due.....

I understand what you are saying Bobbye....but...
I agree with mornington...."This will not be the last time someone Googles this thread."....
I had the exact same problem as the original poster stated....
Whether this post is 6 months or 6 years old....Markiepoos answer worked!

Markiepoos.....You're the Greatest! :wave: I'm giving credit where credit is due :)
 

Bobbye

Helper on the Fringe
It could just be my idea of how threads are used but:
Searching any computer board before asking a question is always a good idea. And most boards keep the threads available for specified times.

If someone finds help on an old thread that works to resolve their problem, that is good. I just don't like seeing people post about their own problem on the old threads! The most specific reason is that only the people who have remained subscribed to the thread are going to get any notification.
 
Status
Not open for further replies.