Far Cry problems

By ragincajun ยท 18 replies
Jun 19, 2004
  1. I just plunked down 40 beans for this dog. Pretty to look at, but it FREEZES to the point where the game's not usable. Very frustrating. ALSO, the "check points" that are supposedly saved are not there the next time I load the app, so I have to start over again from scratch. Very lame, very frustrating. Has anyone out there had similar issues, and possible fixes? Thanks.
  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    If you are looking for a solution, we'll definitely need more information about your computer.

    Many things can cause freezing and may be caused by system problems or incompatible hardware in your computer.

    I can tell you the game is not designed to freeze though, as it works perfectly fine on my system and a friends. So that is definitely something it should not be doing.
  3. Julio Franco

    Julio Franco TechSpot Editor Posts: 7,579   +961

    First thing to try would be to install patch 1.1 in case you haven't done so already.
  4. kuro

    kuro TS Rookie

    Have you read my replies to the thread for SoF2 and whatnot? Other than the fact that I think they were ignored, I did solve my problem in SoF2 with the game freezing for no damn reason.

    For my ATI Radeon card, it seems I absolutely had to drop my AGP to 4x to stop the lockups. You may have to do the same. I think my Intel mobo is crap.
  5. ragincajun

    ragincajun TS Rookie Topic Starter

    Thanks for the feedback. I'm running XP on an AMD Athlon XP2000+, 1.6 GHz, 512 Mb RAM. Also, a Radeon 9200.

    I've had recent issues with spyware, it sapped system performance, so I re-installed the OS earlier this week. Now I'm running SpyBot S&D frequently, as a preventive measure.

    Aside from the freezing behavior, I don't understand why the Far Cry app doesn't save the checkpoints from previous sessions. During a session, the check points are saved, but when I re-launch the app, there's no record of check points. I hope I can sort this out, as it seems like an excellent game. Thanks.
  6. kuro

    kuro TS Rookie

    I've yet to try FarCry, so I don't know about the checkpoints. Are you exiting the game properly? Some applications don't save things until program is closed (gracefully) and if it crashes or otherwise is closed against its will-- that data can be lost. Also, make sure you don't happen to have your game files read-only by some odd chance ?oO
  7. xtrmn8r

    xtrmn8r TS Rookie Posts: 53

    as far as freezing goes, its probably your graphics card not being good enough (sorry!) i run it with a gf4 ti4600 and its quite jumpy at times...

    as far as saving games go, the only thing i can suggest is uninstalling it and re-installing it? make sure you patch it first though to see if you can solve it that way.
  8. ragincajun

    ragincajun TS Rookie Topic Starter

    Thanks to everyone who replied. I'll try these approaches, with the card upgrade as the last resort.
  9. BloodRaven

    BloodRaven TS Rookie Posts: 89

    yeah i have had some problems with farcry too, exept for me its not freezing. its the sounds of the gunfire. i can hear everyone elses gun fire but when it is shot out of my gun it sounds like its silenced or the sound file isnt even there. i can hear the bullets hit stuff but i cant hear the gun fire. its very annoying. other than that the game is great but that part just kinda messes up the whole experiance.
  10. ragincajun

    ragincajun TS Rookie Topic Starter

    Thanks for the feedback. Sounds similar to the problems I had with Aliens vs. Predator 2. The video was fine, but the sound was completely screwed up, regardless of game and system settings I tried. It made the game totally unplayable. The first AvP gave me no such problems. Another mystery.
  11. bshaw11

    bshaw11 TS Rookie

    Far Cry Demo

    Hello i was wondering if anyone could help me, i just tryed to play a far
    cry demo that i got off a DVD cover disk and it installs fine and everything
    but when i play it i cant really see anything, could this be to do with a
    wrong graphic card driver installed or something?

    i have all the recomened specs and everything that is asked for it to run,
    other games that i have play fine.
  12. FeTaLDaMagE

    FeTaLDaMagE TS Rookie Posts: 44

    bshaw11, normaly this is because of your drivers yes . Try updating your video drivers.
  13. LNCPapa

    LNCPapa TS Special Forces Posts: 4,263   +453

    Make sure you download your drivers from your laptop manufacturer. I don't know what kind of performance you're gonna get on a 440Go - I have on in my laptop but I haven't even tried it on that.
  14. bshaw11

    bshaw11 TS Rookie

    Yeah im pretty sure it is the driver that is the problem because when i tryed to install another demo off the disk (prince of persia, sands of time) it does a similar thing and before i started it, it said there was a problem with the graphics driver, an incorrect one was installed or something...so i went to my laptop manufacturer but the drivers arent on the site, not yet anyway
  15. FeTaLDaMagE

    FeTaLDaMagE TS Rookie Posts: 44

    bshaw11 here is a good link about your type of situation. mabe it can be of some help. I think you can use det. drivers from nvidia. hopfully someone who knows more about laptops can help ya.http://www.resellerratings.com/forum/t38407.html
  16. bshaw11

    bshaw11 TS Rookie

    okay cheers ill check that out! :grinthumb
  17. fede42

    fede42 TS Rookie

    hi, i just bought an xfx geforce 6800 xt(i used to have a crappy 6200) and it works exelent with all games included oblivion ,but when i run far cry it looks like shxxx ... the water ,the lighting ,the textures all sucks....any ideas? my specs are:celeron d 3.0,1024 mb
  18. Problem_far

    Problem_far TS Rookie Posts: 19

    Really Problem...

    My problem with farcry, is that it is almost installed, but then...It says that i need to verify that: Textures.pak file is in the CD.But when I go to it's folder, and there IS the file, what should I do? Please, help me.
  19. Problem_far

    Problem_far TS Rookie Posts: 19


    Looks like I've found the reason for that installing problem...Now when I play, and whenever I load any map, its just started to load, but then...The farcry quits from the game itself...And it doesen't even say anything.So...Ummm what should I do?:confused:
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...