Fed up

By s3xynanigoat
Nov 20, 2007
  1. I have a 3800+ in a A8N 32-SLI Deluxe board and it is powered by Liberty 620W PSU sitting inside of it's Thermaltake Tai-Chi case. Electrical surges have downed this machine twice now. The first time it took out the PSU which was easily replaced, this second time though....

    At first I believed it was only the PSU and video card that got nailed this second time around, so I replaced both. After getting the video card installed I powered the thing on and found that windows was corrupt. No biggie - reinstall windows. Done. Windows installed and wanted a reboot of the machine so I did just that, and rebooted. Upon reboot the machine would get to the Windows logo and then reboot. No problem I thought - yank on this, tug on that, it shouldn't be an issue. Now I've really done nothing to this machine out of the ordinary to make it not work but I am now in a position where I have a machine that, as you guessed, does not work.

    Here are my symptoms currently -

    Step 1: Push the power button
    Step 2: LED/Fans come on
    Step 3: Wait
    Step 4: Wait
    Step 5: Wait
    Step 6: Still nothing on the monitor
    Step 7: Repeat steps 1-6

    I'm at a loss here, I get no video on the screen and I get no beeps from the mobo during post; If it's even posting. Here is a short list of things I tried, each one leaving me where I was.

    Thing 1: Known working PSU
    Thing 2: Remove all RAM and then boot
    Thing 3: Try a new video card
    Thing 4: Smash face against keyboard
    Thing 5: Check for blown or bulged caps

    Is anyone familiar with these symptoms? I was thinking it's either the Mobo is dead or there is a grounding issue on the mobo. One of my two LAN connections link lights stays on constantly since this last surge so I can kind of tell there is a mobo issue based on that. I'm pretty technically inclined buyt very lazy and I didn't want to yank the mobo without asking around first. Thoughts? Anyone??
  2. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Did you clear the CMOS using the jumper and battery removal.

    Take your time don't get upset...

    Make sure the CPU is in there by press down on it.
    Make sure all the RAM is tight.

    What I would do it connect one stick for ram and the main HDD and see if you can get pass your problem. Something is not right. Reset the BIOS to defaults, Clear the CMOS and try it again..
  3. s3xynanigoat

    s3xynanigoat TS Rookie Topic Starter Posts: 94

    I have not tried to clear the CMOS yet - the whole thing is strange to me because it worked for a few minutes until after Windows was reloaded.

    @tipstir - I will clear the CMOS and reset the BIOS via jumpers tonight when i get home.

    A side note - The monitor clicks on with my cpu power but I'm getting no feed to it. I also do not hear the HD's spinning.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...