Fedora 3 ethernet/lan/network setup

By deki ยท 12 replies
Jan 27, 2005
  1. Hi I need help configuring LAN network modem.First of all i'm running fedora 3 on pentium 2 332mhz, it runs great , but the problem is setting up network adapter. I think that the linux does it during the boot but it can't make the eth0; to activate.I have charter h.s.i. got 348kbs which i share on the two computers, so i have to make both computers run on 10T half mode to run properly.Does anyone knows how to configure network speed/ duplex on linux fedora 3?
    If this is unclear its the same thing on xp start ,right click mycomputer ,properties , hardware ,device manager, click on network adapters , highlight the name of the ethernet card, and then right click properties , advanced ,link speed/duplex mode . This is what fedora dont have or maybe i don't know how to find it, if anyone can help i would appreciate!!!?? Thank you! :suspiciou
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    I can't imagine where it would fit in a "proper" Fedora system configuration, but you can set speed/duplex manually by using ethtool.

    On command line run "ethtool -s eth0 speed 10 duplex half"

    You can put this into the /etc/rc.local file to be run at every bootup.
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    If you are having problems getting your card activated, I had the same problem with a 3Com 100TX adapter which was listed as fully supported. It simply would not activate. I tried a number of things, researched theh problem for several days... I found that was not Linux savvy enough to fix the problem and switched back to Mandrake 10.1 a couple of weeks later. ;)

    Fedora 3 seems pretty slick, but I wasn't the only person with that problem.

    Hopefully Mic answered your other question.
  4. deki

    deki TS Rookie Topic Starter Posts: 25

    linux don't recognize 'ethtool -s ' command

    Nodsu --> i tried using 'ethtool ' in on the command line and the bach : dont recognize the command?
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    1: Obviously you have to be root to mess with network interfaces
    2: You need to have the ethtool package installed
    3: You may not have the sbin directories in your PATH. Try running /sbin/ethtool
  6. deki

    deki TS Rookie Topic Starter Posts: 25

    found the ethtool

    hi nodsu, i did like you asked
    [deky@localhost~]$ /sbin/ethtool
    ethtool version 1.8
    ethtool DEVNAME
    ethtool -a DEVNAME
    ethtool -A DEVNAME\
    ethtool DEVNAME\
    [speed 10|100|1000 ]\
    [duplex half |full]\
    [ port tp| ...... ]
    this is what came up so i tryed running the same command from before:
    $ ethtool -s eth0 speed 10 duplex half but it dont recognize ethtool command.
    i entered the ip adresses and default gateway manually, when the computer had detected the new hardware(linksys 100/10 t). ip
    On the other computer (XP) showed ip adresses conflict so i think it is connected but probably speed is great .So what the DEVNAME is and how do you execute the commands above?Thanks nodsu.
  7. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    /sbin/ethtool -s eth0 speed 10 duplex half
  8. deki

    deki TS Rookie Topic Starter Posts: 25

    Thanks nodsu.
  9. rose_love

    rose_love TS Rookie

    Thanks for the info... :) Im looking for that configuration also

    I just want to clarify something in that directory u mention .Is my understanding right? I 'll run the ethtool on that directory /etc/rc. local to run the 10 Mbps full duplex in boot up?
  10. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    Linux System V startup

    In FedoraCore 2, the boot scripts are located in the directory
    /etc/rc.d and rc.local would be stored there. There are comments in that
    script that it runs after all other init scripts.

    see Linux SYSTEM V initialization for an overview
  11. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You can run ethtool wherever you want - it doesn't care about filesystems. rc.local is the file where you ought to put your own things you want done at system startup. So if you want the ethtool thing done at every boot then you should edit the rc.local file to include the ethtool command.
  12. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    yes, any LOCAL needs for services to be controlled at boot time real ought to be
    in the /etc/rd.d/rc.local script :)
  13. rose_love

    rose_love TS Rookie

    Thanks ....everyone :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...