Fedora Screwed up My Windows Partitions

By MrCodeDude
Apr 10, 2006
  1. I've been having horrible trouble getting Windows and Linux to cooperate, Ubuntu didn't like my X800, Fedora limited itself to 800x600 with 24 colors, etc.

    I finally got Fedora working correctly by selecting the option: Remove All Linux Partitions and Install on Selected Drive.

    Everything worked out perfectly, couldn't have gone better.

    Until I tried to get into Windows. It gave me the error:

    Autochk.exe not found - Checkdisk will not be run

    Then it would reboot. I fixed this problem by changing the drive's hex ID from 0x17 (hidden NTFS) to 0x07 (NTFS).

    Now Windows and Fedora will boot, but I can only see half my partitions. Well, I can see all my partitions, but I can't view them.

    This is how my computer is set-up:

    Drive 1: C:\ (30gb) and S:\ (80gb)
    Drive 2: E:\ (80gb), F:\ (15gb) & Linux Drive (which is recognized by Windows as M:\) (50gb)
    Drive 3: Z:\ (80gb)

    The C:\, F:\ and Z:\ partitions all work fine in Windows, but E:\ and S:\ I can't view. They are shown as healthy in Windows Disk Management and Linux says that their hex thing is 0x07. But if I try to view them in Windows, it just asks me if I want to format the drives.

    Using GetDataBack, I can recover all the files, however the partitions Fedora decided to screw over were my two biggest partitions so I can't back up the data to a current existing drive. Is there anyway to restore the current drives using GetDataBack or a similar program? GDB has confirmed all the data is still there.

    edit: I've backed up pretty much all essential data already, it's just I'd rather not lose my music collection and have to re-install all my games.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...