Flash drive problem on xp

By wasabe ยท 7 replies
Jan 28, 2005
  1. When I plug both a Lexar 512mb flash drive and a PNY 512 flash drive into the usb ports of either of two Dell laptops running xp home, both drives work perfectly. The drives appear in Device Manager under Disk Dives, with the usbstor.sys driver, xp's mass storage driver. When I plug the same drives into my Asus P4P800-E Deluxe (Intel 2.8 GHz) running xp pro, I get an "Unrecognized Device" message. The drive doesn't appear under Disk Drives in Device Manager, but an "unknown device" message appears under USB Controllers. All three computers show that usbstor.sys resides in Windows\system32\drivers, but the Asus will not load it or recognize the drive. The only time I've gotten the Asus to recognize the drive is when I removed it in Device Manager and then had Add New Hardware search the XP Pro installation disk for a driver in the folder containing both the usbstor.sys and the usbstor.inf files (I386). Obviously, I can't do this every time I want to use the flash drive. This is the only USB device with any problems. All three machines are running SP2. I've seen several posting on other forums where people are having the same problem with flash drives or similar devices. When they finally get through to tech support, they're told to download usbstor.sys and usbstor.inf. But everyone has the same problem: how to get the machine to load it. Any suggestions?
  2. wasabe

    wasabe TS Rookie Topic Starter

    New information on the same problem: If I plug the flash drive into a usb port before startup, I get "unknown device" under USB Controllers in device manager and my USB Linksys Wireless Receiver becomes disabled. When I unplug the wireless, the flash drive is recognized and works perfectly. Both devices are plugged into the front usb ports of an Asus P4P800-E Deluxe.
  3. julleswede

    julleswede TS Rookie

    Hi there,

    I have exactly the same problem. Have you solved it some how? After many trials the usb installed itself for a few seconds. Then everything went back to the normal state: not functioning.

    Thaank you very much,

  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    I had some symptoms of something similar to that on my newest comp (asus K8n-e deluxe mobo). I have a powered 2.0 hub connected to the mobos usb (the ones by the LAN) and 1 port of that I get the unrecognised usb device. Another port on same hub it works fine.
    I know that doesn't help any, but perhaps it could provide insite to any 'pattern' that may be devloping.
  5. StormBringer

    StormBringer TS Maniac Posts: 2,244

    most USB wireless adapters are meant for the back ports, since those have a tiny bit more voltage than the fronts. The difference usually isn't a problem(just something for tech support to blame your problems on) but it sounds like it may be the cause here. Since the wireless adapter likely uses a lot of power(most do) it may be too much for the flash drive to operate properly while sharing thaat power with the wireless adapter.
  6. jobeard

    jobeard TS Ambassador Posts: 11,166   +986

    USB hub usage

    the usb hub is very useful, but often HIDES the true identity of the device(s) on the otherside. I use the hub for keyboard/mouse, but directly attach the USB Thumbdrive and 120GB external HD.

    I've found that making the connection BEFORE booting allows Windows to autoconfigure correctly - - assuming the right drivers are available. Specifcally I refer to the USB Mass Storage driver/configuration. This needs to be configured manually at least once and then it will work like a charm :)

  7. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    Ok stupid question here, but have you installed drivers for it?
    I was reading thru & didn't see anything really about u trying to update or uninstall or re-install drivers ... don't u think that might help?

    But yeah maybe i've chopped myself here ... i'll check again! But try that too! Go on the net & find them!

  8. markfiona

    markfiona TS Rookie

    USB problems

    like most of you I have been all over the Net for answers. What I have found is that the front USB ports are LOW SPEED, and therefore not adequately powered for most USB devices.
    What I did was continually plug the device in and out, until it was recognised. I have tried reboots, sys32 driver updates to no avail. With the ASUS P4 m/boards you are only supposed to run 2 USB per IDE device, eg. HDD internal.
    So with me I used to plug it in and it would come up with unrecognised device or it would display the explorer window G:/ etc but not show contents of drive, even though there was stuff there. After plugging in/out 10 times it finally read it. Also in WM Player with the "sync" tab selected it helps it recognise the device???
    none of this is very tech but at least it gets results, or just buy a USB extender cable run off the back of your PC to plug in the device.
    Even stranger is my 2 front ports can run a MIDI controller keyboard no problems!!! - with no latency??
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...