Flash drive problems.

By loki80 ยท 6 replies
Aug 23, 2006
  1. I have a 256MB kingmax flash drive. When I inserted my flash drive in to my notebook computer, it was detected and ready for use. But, when i inserted it to my desktop computer (pentium IV, mainboard Intel), it was detected and show message "but i can't access it, and appeared a error "USB device not recognized". On the device manager, it's listed on Unknown device. My notebook computer has USB 1.1 ,desktop computer has USB 2.0. Then I disable a Universal Serial bus controllers "Intel(R) 82801DB/DBM USB 2.0 Enhanced host controller - 24CD" on Device manager, and my flash drive works fine. I don't know why, anybody please help me!
  2. Peddant

    Peddant TS Rookie Posts: 1,446

    Did you restart the PC ?

    Some PCs don`t recognize some USB flash drives automatically.

    You just have to install/reinstall/restart manually.At least that`s my experience.
  3. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    do you have service pack 2? Are you running XP?
    The drivers for your flash drive probably aren't recognized.
  4. loki80

    loki80 TS Rookie Topic Starter

    It's only don't recognized with USB 2.0 port. USB 1.0 and 1.1 work fine
  5. loki80

    loki80 TS Rookie Topic Starter

    My flash drive uses USB 2.0, winxp SP2 isn't a problem. I thinks the problem's USB 2.0 on device manager, when i disable USB 2.0 port, my flash drive works fine.
  6. apaullo

    apaullo TS Rookie Posts: 80

    maybe u need to restart ur pc before u can use it as peddant had said. and also if ur using win98 u need to install the driver first before using it

    hope that helps
  7. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    this definately sounds like a driver issue.
    contact the manufactuer.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...